Saving in old MS Office formats (.doc and .xls) with onlyoffice document server

After update the last document server in linux with “apt get update” “apt get upgrade” in a linux debian machine, we can’t edit .doc or .xls office format. Before the update worked perfectly.

We checked that the property in the default.json file is set to: “assemblyFormatAsOrigin”:false,
the update change the value to true.

The .doc files can be opened and changed, but when you close it, It doesn’t save the file.
With .docx or other format works fine everything.

Something has changed in the last update. Please, could you tell us how maintain the compatibility? Now our users that still works with old office format can’t save their documents with onlyoffice.

Hello, you can set assemblyFormatAsOrigin within default.json (/etc/onlyoffice/documentserver/) back to false, this way your doc files will be saved in docx format. Also, remember to restart ONLYOFFICE services afterwards: systemctl restart ds-*.

Hello, thanks for answer.
I’ve tried with true and false and restart. The issue continue.
If I open a .doc and edited, the document server can’t save it in the same format? in .doc and not in docx.
Perhaps is missing another parameter in the default.json?

Unfortunately, ONLYOFFICE Docs does not support saving in legacy formats such as .doc.
Please provide an example of the .doc file

Hello DmitriiV,

Thanks for your quick response.

It’s works fine in OnlyOffice v 7.4. When you open an old “doc” file with the editor, the server convert it to the new format, then when you close the file it is saved, internally this is in new (docx) format, users don’t care about this, the document was edited and successfully saved.

Now there is a bug in V8.0. I have tested it after an update to V8.0 and in a fresh Debian 12 installation.

When you close the document, it is not saved at all. I think save process is failing. If you can’t test it, we can send you the out logs from server.

Thanks.

Please provide the following info:

  1. Document Server logs (/var/log/onlyoffice/documentserver)
  2. So, the issue occurs with all .doc files? If it happens with some particular file, please send it to us
  3. What do you integrate Document Server with? (for example, ownCloud, Alfresco, etc.)

Hello DmitriiV,

Please, let me some time to deploy a new server in my cloud provider. The other server with fresh install Onlyoffice v8 was deleted.

I integrate Document server with own API. I use javascript and config.

One server Debian bullseye with Onlyoffice v7.4 works perfectly with “doc” documents. The file is saved with changes, it is internally converted to docx without problems.

The new Onlyoffice v8 do not save changes in documents “doc”, it works with “docx”. There is something wrong, some bug, I have change configuration several times with no success.

Thanks.

Alright, please take your time to deploy, after that reproduce the issue and send us Document Server logs

Hello DmitriiV,
docservice-out.log.docx (25.2 KB)
converter-out.log.docx (25.0 KB)

Attached I send the logs after open a “doc” and changes are not saved.

Thanks.

Please provide an example of .doc file with which you face the issue.

example word 97-2003.doc (25.5 KB)
Hello, here you are.
Thanks.

We checked the provided file using a built-in Test Example of Document Server in which preliminary conversion from legacy formats to ooxml formats was implemented and the problem was not reproduced.

Please provide full Document Server logs as you provided only a piece of them.

Hello, so, the file can be opened, the problem is when you modify and close it.
That it doesn’t save and remains like opened.

Give me some time to gather the records you need.
Thanks again.

Hello, alright