OnlyOffice Community Edition: Document Loading Issue

Dear OnlyOffice Support Team,

I recently installed the community edition of OnlyOffice on my Windows system by following all the instructions provided in the Installing ONLYOFFICE Docs for Windows on a local server guide. However, upon completion of the installation process, I encountered an issue with document loading in the web editor.

While the installation process went smoothly and the application initially worked without any problems, I’ve noticed that documents, spreadsheets, presentations, and other files fail to load in the web editor. Instead, the loading process seems to continue indefinitely until it eventually times out.

Despite my attempts to troubleshoot the issue, I haven’t been able to find a solution. I’ve explored various avenues but haven’t had any success in resolving the problem.

To provide you with a better understanding of the issue, I’ve attached a screenshot illustrating the problem I’m encountering.

I would greatly appreciate any assistance or guidance you can provide to help resolve this issue and ensure the smooth functioning of OnlyOffice on my system.

Thank you very much for your attention to this matter. I look forward to your prompt response.
![Capture 1|690x356](upload://pDpNMv3D737zduGnWYqWeX679b6.png)
![Capture 2|690x365](upload://juiTEZcbRrGQzcThkAjxgBGA23h.png)

Unfortunately, the images you provided weren’t uploaded. Please send us Document Server logs as a file, so we would be able to analyse the issue in depth: C:\Program Files\ONLYOFFICE\DocumentServer\Logs


Thank you for your response and willingness to assist.

I apologize for the inconvenience caused by the lack of uploaded images. Please find attached the Document Server logs file.

I hope this helps in identifying and resolving the issue with document loading in the web editor.

Looking forward to your further guidance.
log file.docx (13.0 KB)

Please provide full Document Server logs as an archive file, the full content of the Logs folder is needed. I look forward to your feedback

Also, please provide the following additional info:

  1. Output of netstat -aon | findstr “5672” command
  2. RabbitMQ’s logs: C:\Users\Administrator\AppData\Roaming\RabbitMQ\log
  3. Open Start Menu - find RabbitMQ Command Prompt - run rabbitmqctl status - send the output to us
  4. Send us the screenshot of RabbitMQ’s port (Windows Services → RabbitMQ properties → Protocols and Ports)

RabbitMQ is not installed in my machine. Let me install it first then I will share these required details with you.

1: Please find the full Document Server logs folder in this link [].

2: Output of netstat -aon | findstr “5672” command: Please find the attached output result 1 file below.
Output result 1.docx (4.5 KB)

3: RabbitMQ’s logs file is in this link [].

4: RabbitMQ Command Prompt - run rabbitmqctl status: Please find the attached output result 2 file below
Output result 2.docx (5.1 KB).

5: I couldn’t locate RabbitMQ’s port in windows services (please find attached screenshot

). I couldn’t find rabbitmq.config file as well.

Please remember that RabbitMQ is one of the essential dependencies of Document Server, Document Server won’t work without all required dependencies installed and running (please check the System Requirements section of the installation guide: Installing ONLYOFFICE Docs for Windows on a local server - ONLYOFFICE), pay attention to the required versions as well ( Erlang: version 24.2, RabbitMQ: version 3.9.12, PostgreSQL: version 12.9 or later), make sure that all the versions are correct and all dependencies are installed and running.
Also, the following ports should be opened for the dependencies: Ports which must be opened for ONLYOFFICE Docs - ONLYOFFICE

If after doing the above, you’ll see that the issue still reoccurs, please provide the screenshot from Windows Services showing the versions of dependencies installed as well as their statuses


Thank you for the support; ONLYOFFICE Docs is now working correctly on our server. However, I’m facing a new issue when trying to integrate it with my web application using the API path and secret key. I keep getting an error that says, “The document security is not correctly formed.” I’ve tried to resolve this, but without success. Could you help me figure out what might be going wrong here?

Thank you for your assistance.

You need to find the secret in local.json config (%ProgramFiles%\ONLYOFFICE\DocumentServer\config\local.json):

      {"string": "yoursecret"}, 
      {"string": "yoursecret"},
      {"string": "yoursecret"}

After that you need to form a token (ONLYOFFICE Api Documentation - Security) including this secret as its signature (ONLYOFFICE Api Documentation - Signature), the payload should be the whole content of your Editor’s initialization config (ONLYOFFICE Api Documentation - Config) :
ONLYOFFICE Api Documentation - Signature
Then you need to pass the formed token as an attribute (ONLYOFFICE Api Documentation - Config) within Editor’s initialization config.

Sorry for my late feedback, was getting busy with other problems.

I have managed to solve my issue thanks for your input. Now there is other error “The document could not be saved” even though the file is actually being saved on my machine. I tried to troubleshoot the error as mentioned here [ONLYOFFICE Api Documentation - Troubleshooting] but i can’t get it exactly.

Hello, please provide Document Server logs after reproducing the issue (%ProgramFiles%\ONLYOFFICE\DocumentServer\Logs)

I’ve reverted back to the default.json file and reproduced the issue. You can find the log file [Log – Google Drive]

Hello @Saba

Most recent logs does not contain any records. Please reproduce the issue again and then provide fresh logs for analysis.

Hi @Constantine Please find fresh logs folder []

Hello, there are no errors in the most recent logs, also it seems like several days’ logs are missing. Can you please reproduce the issue once again and sends the logs anew?

Hello, Here is the log folder containing the logs after reproducing the error:

[Attach log folder]

Please provide the following additional info:
Config’s both of the
Example and Document Server (Windows - %ProgramFiles%\ONLYOFFICE\DocumentServer\config and %ProgramFiles%\ONLYOFFICE\DocumentServer\example\config)


Thank you for your request. Here are the links for both the Example and Document Server:

  1. Document Server:
  2. Example Server:
    [Example – Google Drive]