ONLYOFFICE Docs v7.3 released: enhanced forms, SmartArt, new security settings, Watch Window, and more
ONLYOFFICE Docs v7.3 released

Download failed... 403 forbidden

I’ve installed ONLYOFFICE Document Server to Linux. When I try to open a document in web browser editor, the editor is opened but loading of document failed. Message box shows “Download failed”. In a browser console I’ve found message:

403 Forbidden:
GET https://office02.myserver.de/cache/files/data/UPhLvQW9EXxPqW11j272/Editor.bin/Editor.bin?md5=caAHgf2ec7jZGXp2TkYApw&expires=1676716894&filename=Editor.bin

What is going on? Why 403? I cannot find any error in any of the server log files. What could be wrong? What shall I do now?

Hello,
Please try executing the following script to fix the issue:
bash documentserver-update-securelink.sh
Let me know the results.

Hi all, I bumped into the same issue, and luckily the support helped me (many thanks). Let me describe the problem and the solution.

Environment: Ubuntu 22.04 LTS, Installation along the guidelines provided in:
https://helpcenter.onlyoffice.com/installation/docs-community-install-ubuntu.aspx

a.) Same issue as above, Error “download failed”. This only happened to me, when ssl was on, it worked ok with http:// only. Verification was done just on the examples page /example

b.) I used a self signed certificate (which also seemed to be important, as naturally certificate verfication fails)

b.1) The doc service log : /var/log/onlyoffice/documentserver/docservice/out.log shows the following error:

 [2023-01-30T09:05:00.090] [ERROR] [localhost] [172.30.41.23Test.xlsx1674744767521] [uid-11] nodeJS - changesError: Error: Uncaught TypeError: Cannot read properties of null (reading 'Tsj') Script: http://onlyoffice.mydomain.com/7.2.2-56/sdkjs/cell/sdk-all-min.js Line: 1530:320 userAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/109.0.0.0 Safari/537.36 platform: Win32 isLoadFullApi: false isDocumentLoadComplete: false StackTrace: TypeError: Cannot read properties of null (reading 'Tsj')   at Sb.N$g (http://onlyoffice.mydomain.com/7.2.2-56/sdkjs/cell/sdk-all-min.js:1530:320)
  at i.onDocumentContentReady (http://onlyoffice.mydomain.com/7.2.2-56/web-apps/apps/spreadsheeteditor/main/app.js:8:2371185)
 at i.onLongActionEnd (http://onlyoffice.mydomain.com/7.2.2-56/web-apps/apps/spreadsheeteditor/main/app.js:8:2366275)
 at D (http://onlyoffice.mydomain.com/7.2.2-56/web-apps/apps/spreadsheeteditor/main/app.js:8:7870)
 at z.<anonymous> (http://onlyoffice.mydomain.com/7.2.2-56/web-apps/apps/spreadsheeteditor/main/app.js:8:8074)
 at z.<anonymous> (http://onlyoffice.mydomain.com/7.2.2-56/web-apps/apps/spreadsheeteditor/main/app.js:8:1249)
 at z.trigger (http://onlyoffice.mydomain.com/7.2.2-56/sdkjs/cell/sdk-all-min.js:1162:262)
 at Sb.ee (http://onlyoffice.mydomain.com/7.2.2-56/sdkjs/cell/sdk-all-min.js:1430:462)
 at Sb.iw (http://onlyoffice.mydomain.com/7.2.2-56/sdkjs/cell/sdk-all-min.js:1258:78)
 at http://onlyoffice.mydomain.com/7.2.2-56/sdkjs/cell/sdk-all-min.js:1267:480

As could not find any reasonable comments in the public, I contacted the support, and their recommendation was:
a.) Switch off ssl verification in /etc/onlyoffice/documentserver/default.json, i.e. search for entry “rejectUnauthorized”, change the value from true to false and restart the services by using: sudo supervisorctl restart all

On my end, this did not help, I still had an the permission issue as before. Only after running the command (as described here as well): sudo documentserver-update-securelink.sh things went ok.
I do assume that self signing is key for this error, as I ran OO in a very similar environment on debian with a letsencrypt certificate and never had any such issue
Thanks for the great help of the support.
Hope this helps to save some time for others.

1 Like