Can't open any DOCX, XLSX, and PPTX file

ONLYOFFICE Mobile: Documents
Do you want to: Report a bug

Device: Samsung Galaxy A11
OS version: Android 12
App version: 5.7.1
Mode: On Device

I was just about to try this application. When I started trying by opening three sample document files provided by OnlyOffice, the app got stuck at “Prepare to open” before finally not responding and then crashing. Reinstalling the app did not help. Please provide a solution. Thank you!

Here’s a screenshot when I’m finished reinstalling and trying to open one of these sample documents (in this screen I’m trying to open “OnlyOffice Sample Document.docx”)


Hello @Anyum
Is the situation related to samples only? Please try to import any other file to ‘On device’ directory and open it. Also, if it’s possible, please record a video file of your test.

Yes, I’ve tested with one of my DOCX file and it’s still the same, stuck in the “Preparing to Open” screen. So not just happen in the sample files, it’s happen on any other document files too

Sorry I can’t give you my screen record of my test because I’m new in this forum

Also, I’ve tried to create a new document, and still stuck in the “Preparing to Open”, and then the “ONLYOFFICE Documents is not responding” notification (in this screenshot the notification shown in Indonesian based on my locale) is shown like as follows

I have increased your forum level. Please record a video file with your test and provide us with it. I believe we have to take a closer look at it.

I confirm this bug on Redmi 12C for .docx files, elaboration is available in another thread.

Your other thread describes the situation with specific txt files. I believe this topic provides a different scenario. Let’s wait for information from @Anyum

Alright, thanks for increasing my forum level. And this is my screen record showing my attempt to open my PPTX file saved on my device (I’ve also have another screen record showing an attempt to open an XLSX file saved on my device too)

Also, this is my screen record showing an attempt to create a new DOCX file. I’m really stuck at “Preparing to open” screen even after two minutes.

Here’s what I’ve found when I’m trying to open my XLSX file stored on my device

Indeed other topics I created here at this moment are related to the .txt files but I’m taking about the topic I didn’t created but commented in. Here is what I wrote in the topic Files from phone can only be opened inside OO app and not from outside OO app when we choose an option "Open with" regarding the situation with .docx and .xlsx and .pptx files:

‘ONLYOFFICE Sample Spreadsheets.xlsx’ opened from ‘open with other app’ list: app immediately closed after showing ‘Preparing to open’ message window. Another attempt displayed ‘Wanna repair?’ dialogue window, the results of the repair was even quicker exit of the app.

‘ONLYOFFICE Sample Presentation.pptx’ opened from ‘open with other app’ list: same as the previous.

‘ONLYOFFICE Sample Document.docx’ opened from ‘open with other app’ list: the ‘Preparing to open’ message window never disappeared, the OnlyOffice app hunged.

The very same results I’m getting now when opening that files from inside of the app. It looks as the problem with the app handling the cache / the storage. But on Redmi 5 the files were successfully opened from inside of the OnlyOffice app.

But @Anyum already answered, his feedback is a prio.

Hello @Anyum and @dimm
@Anyum Thank you for provided data, we are checking the situation.
@dimm, ah, now I see it. Your feedback was collected within the mentioned post, the checks are still in progress. I believe these are separated cases, because in your mentioned thread files open via File Manager. I will contact you in this thread when we have something to share.

Hello again @Anyum
Please confirm that described situation reproduces constantly (100% of your attempts of file opening).

Yes, this problem occurs constantly, even after several reinstalls of the app.

Thank you, we are checking the situation.

I encountered this with OO on OnePlus 10 Pro.
The issue went away when I cleared cache with Settings > Clear cache.

Hello @mj-j
Thank you for your sharing.
@Anyum just for your information, we are still investigating this case.

Thanks for the information :pray:

Hello @Anyum
Please confirm that the situation reproduces on the latest version of Android app (v.7.5).

Yes, this situation is still happen on the latest version (7.5)

When opening all of sample documents and opening any file stored on my device (either from the file manager or from the application), now the app crashes after displaying “Preparing to open” for several seconds.

Clearing app cache and force stop then reopen still not fixing the problem.