Meet ONLYOFFICE Docs Cloud, complete office software as a service
Meet ONLYOFFICE Docs Cloud

.xlsx file being open as a .docx file

Do you want to: Report a bug
OS version: Fedora 36
App version: 7.1.0
Downloaded from: ONLYOFFICE website / Other (specify) flathub via gnome app store.

I have the desktop editor set as default for speadsheets. when I attempt to open a spreadsheet from the gnome filemanager the desktop editor launches and attempted to load it as a word doc. The file location location is in my nextcloud instance and I have it also connected to the desktop editor app. If I go to my nextcloud within the desktop editor and open that way the file loads properly.

One important note is if I have a spreadsheet saved to my downloads folder that opens just fine.

Hello @D4vastu
Recently we have released Desktop Editors v.7.1.1. Could you please run an update and re-check the issue. If the issue still persists, please provide us with step-by-step scenario (you can make a videofile) and Nextcloud app version.

Thank you for the reply.

The flathub version is still 7.1.0. Once that receives the update I will try again and post and update.

Thanks!!

1 Like

Ok, please keep us updated.

Have the same problem in 7.1.1.57

1 Like

Hello @alfptz
I have tried to reproduce the situation on my test machine (Fedora 36, Nextcloud desktop app v.3.5.2 and the latest Desktop editors), but without a result.
Could you please reproduce the issue and provide us with videofile?
@D4vastu as soon as you have the same issue, please reproduce the issue too and send us videofile with step-by-step scenario

HI, I just updated to 7.1.1 and experienced the same issue.

here is a video of the issue

Thanks!!

Hello @D4vastu
How exactly have you mounted this path?

Do I understand it right that you have connected Nextcloud storage directly to Fedora filemanager system?

That is correct, I have my nextcloud account connected via the online accounts setting in fedora

I have connected Nextcloud storage via webDAV to my Fedora 36 machine, but unfortunately, Iā€™m still not able to reproduce the issue:

Please let me know how exactly you connected Nextcloud storage to Fedora File manager system.

I went ahead and removed my nextcloud account from my machine from the online account section. I re-added it through the settings and experienced the same issue. I then took the spreadsheet file and moved it to my local documents folder and the document opened as expected. just let me know anything else you want me to try. I also sync my nextcloud with my win11 machine and that file opens as expected with the desktop editors program there.

Hello @D4vastu
We are trying to check out described situation. I will update this post when we have something to share.

These are the steps I have taken to resolve me issue.

  • Just in case, I reinstalled fedora 36. added my next cloud account through the fedora settings and experienced the same issue
    -I also tested opening a spreadsheet on my NAS and experienced the same issue.
    -I turned off file sync for nextcloud in my fedora settings then downloaded the nextcloud sync app. After my files were downloaded and synced everything is opening as it should

My observation is the desktop editors program seems to be able unable to recognize the file type for network shares.

Thank you for your update, I will notify you when we have something to share.

We have tried to reproduce the issue, but without any result. I believe that the issue is related to your machine. We are still looking into it. I will update this post when we have something to share.

Ok, I will create a fedora vm on my local server and see if I experience the same issue

Hello, I was able to recreate the issue in the following environment.

Proxmox VM
resources assigned, default plus the following
4 cores
50gb of SSD
8gb ram

I created the vm, added my nextcloud account during the Fedora setup. Removed libreoffice and installed any system updates. After reboot, I added the flathub repository then installed desktop editors flathub. I rebooted again then attempted to open an excel file via the default file manager. Same issue trying to open it as a word document.

We have tried to reproduce, but without any result. New idea just crossed my mind. Could you please contact me via PM and share your Nextcloud account? We will try to check if the issue is related to Nextcloud since we cannot reproduce your scenario on our machines.

sure thing

Would you mind sending me PM? I am struggling to figure out how on my end