Meet ONLYOFFICE Docs Cloud, complete office software as a service
Meet ONLYOFFICE Docs Cloud

Version restore doesn't work

I just tried to restore a previous version of a file in Nextcloud and it didn’t work at all.

Even worse, the version I tried to restore is now no longer listed in the versions at all, so now I can’t even find the version I want to restore!

Document Server version: ONLYOFFICE Docs 6.4.2
Type of installation of the Document Server (docker, deb/rpm, exe): Cloudron package cloudron / onlyoffice-app · GitLab
OS: Ubuntu 18.04
Browser version: Chromium Version 97.0.4692.71 (Official Build) snap (64-bit)
Nextcloud 22.2.3
Nextcloud ONLYOFFICE connector app: 7.2.1

Hello @jdaviescoates
Please clarify your version of ONLYOFFICE connector app. Also please reproduce the issue and provide us with Document server and Nextcloud logs folders.

1 Like

I just created a new spreadsheet and was able to reproduce this. I’ll do more testing to see if I can narrow it down a bit more too…

Not exactly sure where to find the logs you’re asking for.

Here you go:

Thank you for provided video file. We are checking the situation. Meanwhile, please let us know version of ONLYOFFICE connector app.

Hello @jdaviescoates
We double-checked the issue. It’s related to current Document server version. Today we are going to release new version of Document server (v.7.0) where the issue is not reproducible. When it is possible, please update your Document server and let us know the result.

Thanks.

BTW the banner about 7.0 on here and the website links to https://www.onlyoffice.com/blog/2022/01/onlyoffice-docs-7-0/ which is currently a 404

I just checked it out, it works OK, Please clear your browser cookies\cache. Probably this banner was enabled recently.

@jdaviescoates
We double-checked the scenario and figured out that the issue still can persist on the DS.v.7.0. We are continuing our checks. I will update this post when we get any new information.

Hello @jdaviescoates
The issue is fixed in connector app v.7.3.2

1 Like

Hello @Alexandre
I have a similar issue with Nextcloud 24.0.5, Onlyoffice Document server 7.1.1 (Docker installation), Onlyoffice connector 7.5.4 and Groupfolders app 12.0.2.
When I try to restore version of a file in groupfolder and open the file, onlyoffice opens the last version, not restored. But if I try to download it from Nextcloud, I get restored version, so it seem like onlyoffice downloads the wrong version/file.
Any ideas on how to solve this?

Hello @ntoponen
I believe we should start troubleshooting process with Document server and connector app updates. The latest versions are v.7.2.1 and connector app v.7.5.6 (for Nextcloud 24).
Please prepare whole server backup before update process just in case.
When update process is finished, please double check the issue and provide us with whole Document server logs folder and videofile where you are reproducing the issue.
Logs are located here: /app/onlyoffice/DocumentServer/logs/documentserver/

Hello @Alexandre!

Thanks for your reply! I’ve tried to update Document server and connector app to the versions you provided, but they didn’t work well in my setup for some reason.

Here is a video of reproduction of my problem: No restore in groupfolders reproduction - YouTube

What was fixed in 7.3.2 to solve this issue? Maybe we can do the same for files in groupfolders?

Hello @ntoponen
I have installed Groupfolders app to my Nextcloud v.24 test server. But everything looks OK.
What settings did you set up for ‘test’ folder from your video file? As far as I understand, you have created this folder via Groupfolder app.

I’ve tried to update Document server and connector app to the versions you provided, but they didn’t work well in my setup for some reason.

Please clarify what exactly you faced.

Hello @Alexandre
I’ve set up test server in Docker on my local machine (Nextcloud 24.0.5; Onlyoffice Document Server 7.2.1; Onlyoffice-nextcloud connector app 7.5.6; Groupfolders app 12.0.2), and here is what I’m facing. When I try to open the file from Nextcloud, I get such error:

image

When I switch back to Onlyoffice Document Server 7.1.1 everything works just fine.

Also I tried to reproduce it on absolutely clean setup with versions listed above. And here is what I got:

  • When I restore version for the first time everything works as expected.
  • When I restore any other version nothing happens in Editor, but when I download the file, I get version, which I restored.

And here are the settings for ‘test’ folder from video:

This is different issue. We enabled JWT in v.7.2, so probably this error is related to it. You have to check that JWT secret matches on both sides (on the Document server side: /etc/onlyoffice/documentserver/local.json file and on Nextcloud connector app page: Secret key box).

Let’s focus on this issue first. When we solve it, we will continue troubleshooting version history situation.

Fixed that by adding secret from local.json to the secret key box, thank you!
The problem with restoring though remains the same

The problem with restoring though remains the same

Could you please reproduce it and make a videofile with your exact steps one more time? Also please confirm that you are using the latest versions of Document server and connector app.

Here you go: Onlyoffice-nextcloud versions do not restore - YouTube

Thank you for provided video. The videofile and your description ‘When I restore any other version nothing happens in Editor, but when I download the file, I get version, which I restored’ look like the issue with browser cache. I have tried to reproduce it on my test server, but without success.
Could you please clean browser cache and cookies and double check the issue (or just use other fresh installed browser)?