ONLYOFFICE 7.0: online forms, password protection in sheets, collaboration improvements and much more
ONLYOFFICE 7.0 released

Version restore doesn't work

I just tried to restore a previous version of a file in Nextcloud and it didn’t work at all.

Even worse, the version I tried to restore is now no longer listed in the versions at all, so now I can’t even find the version I want to restore!

Document Server version: ONLYOFFICE Docs 6.4.2
Type of installation of the Document Server (docker, deb/rpm, exe): Cloudron package https://git.cloudron.io/cloudron/onlyoffice-app
OS: Ubuntu 18.04
Browser version: Chromium Version 97.0.4692.71 (Official Build) snap (64-bit)
Nextcloud 22.2.3
Nextcloud ONLYOFFICE connector app: 7.2.1

Hello @jdaviescoates
Please clarify your version of ONLYOFFICE connector app. Also please reproduce the issue and provide us with Document server and Nextcloud logs folders.

1 Like

I just created a new spreadsheet and was able to reproduce this. I’ll do more testing to see if I can narrow it down a bit more too…

Not exactly sure where to find the logs you’re asking for.

Here you go:

Thank you for provided video file. We are checking the situation. Meanwhile, please let us know version of ONLYOFFICE connector app.

Hello @jdaviescoates
We double-checked the issue. It’s related to current Document server version. Today we are going to release new version of Document server (v.7.0) where the issue is not reproducible. When it is possible, please update your Document server and let us know the result.

Thanks.

BTW the banner about 7.0 on here and the website links to https://www.onlyoffice.com/blog/2022/01/onlyoffice-docs-7-0/ which is currently a 404

I just checked it out, it works OK, Please clear your browser cookies\cache. Probably this banner was enabled recently.

@jdaviescoates
We double-checked the scenario and figured out that the issue still can persist on the DS.v.7.0. We are continuing our checks. I will update this post when we get any new information.