The file size exceeds the limitation set for your server

When I opened a 106.5MB sized PPT document, the ONLYOFFICE docs server reported an error:

The file size exceeded the limit set for your server. Please contact your Document Server administrator for details.

I tried to modify some values in default.json, but it still doesn’t work. How can I modify the upper limit of editing file size?

Best Regards

Hello @Jackson

To increase that value first locate and open /etc/onlyoffice/documentserver/default.json config, then find "inputLimits" section and change the value for presentation extensions in "uncompressed" string:

			"inputLimits": [
				"type": "pptx;ppsx;potx;pptm;ppsm;potm",
				"zip": {
					"uncompressed": "50MB",
					"template": "*.xml"

Here value is defined in megabytes.

Then restart Document Server services with:

  • supervisorctl restart all for Docker installation;

In case you are running Document Server in Docker container please locate and change the config inside the container.

  • systemctl restart ds-* for DEB/RPM packages installation from version 7.3.

In addition, you can increase the general file size that Document Server can handle:

	"FileConverter": {
		"converter": {
			"maxDownloadBytes": 104857600,

This value is defined in bytes.

After that re-upload your presentation to the storage (I’d recommend also changing a name of the file slightly) and try to open it again.


@Constantine Thanks very much!It works!

1 Like

I am glad to hear that it helped.

1 Like

I also encountered the same problem. I couldn’t open a 45MB Word file, which contains a large number of images. There is no problem with storing text at 75M

Hi, i can not open a .xlsx file ,the size just 49M,the error is same to the topic, but i see the defalut settings for xlsx is 300M.
ps :i can open a xls file for 99M

Hello @onlyofficeUser1 @zjie

Total size of the all XML data of the file can be checked. inputLimits parameter depends relies on this total uncompressed size of the file. To check the value of unpacked data you can create a copy of the file on the desktop, change extension of the copy to .zip and unarchive it to any folder - the total size of the folder is the total uncompressed size of your document. Based on that value, you can set up proper values in the config as per guide above.

Hello @Constantine,

I’m unable to find the default.json file located underneath the etc/onlyoffice/documentserver. I am currently running the OnlyOfficeDocumentServer through Unraid from the Community App Store created by Ascensio System SIA.
I went to the host files and /var/www/onlyoffice/documentserver to if the default.json file is there. Unfortunately it is not. Do you have recommendations on what I should do next?


Hello @DC_Interstellar

As I can see, you created separate topic for this issue. Please continue discussion there: