The document could not be saved

Hello,
8.0.1
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=22.04
DISTRIB_CODENAME=jammy
DISTRIB_DESCRIPTION=“Ubuntu 22.04.4 LTS”

Ekran Alıntısı

Hello,
According to the logs, your have the following error:

Error: DNS lookup 172.16.154.11(family:4, host:iys.isyon.istanbul) is not allowed. Because, It is private IP address.

To fix it you can do the following: open default.json file (/etc/onlyoffice/documentserver/), find the parameter "request-filtering-agent", set allowPrivateIPAddress to true. After that you have to restart ONLYOFFICE services by running systemctl restart ds-* command.

Also, it is recommended that you update Document Server to the latest 8.1 version as we do not provide support for older versions.

Hello,
I did what you said, but I continue to get the same error. After solving the problem, I will upgrade to 8.1.

Hello,

We are waiting for your feedback on the subject.

Hello,
Sincerely sorry for the delayed reply, please provide new Document Server logs after the issue reproduction (/var/log/onlyoffice/documentserver)

You can see the latest records in the link.

Strangely there are no errors in the most recent logs. Could you please reproduce the issue once again and provide new logs? You can also enable extended logging by going to /etc/onlyoffice/documentserver/log4js/production.json and changing WARN to DEBUG:

{ "appenders": 
  { "default": 
    { "type": "console", "layout": 
      { "type": "pattern", "pattern": "[%d] [%p] %c - %.10000m" } 
   } 
     }, 
   "categories": 
      { "default": 
        { "appenders": [ "default" ], "level": "DEBUG" } 
 }}

After that please restart ONLYOFFICE services by running systemctl restart ds-* command

I restarted the service by making the changes you requested and tried again. I am sharing the logs again.

Hello,
What should I do regarding the issue?