The chatGPT plugin function does not work properly

Do you want to: Suggest a feature / Report a bug / Ask a how-to question
For feature suggestions, describe the result you would like to achieve in detail: chatGPT does not work like other plugins.
For bug reports, provide the steps to reproduce and if possible a minimal demo of the problem:chatGPT works like any other plugin.Can be displayed and used after installation
Document Server version:
Installation method:
Browser version:

Hello @QikX

I don’t quite follow what is the problem with the plugin, please elaborate on this. If possible also provide a video demonstration of the issue that you are facing.

For me ChatGPT also doesn’t work as it should.

System: Garuda Linux (latest KDE version)
OnlyOffice version: (deb)

Steps to reproduce:

  1. installed the ChatGPT plugin through plugin Manager
  2. Afterwards I was not able to find the ChatGPT Button in the menu (even after restarting office)
  3. By right-clicking (contextmenu) I was opening the settings and added my newly generated OpenAI API key
  4. Trying out features like Custom request, Chat - it returns the error “Quota exceeded”
  5. Checking OpenAI Webpage - says API key has never been used. Quota can’t be exceeded for my account - never used it before (new created OpenAI account with fresh API key)
1 Like

Hello @brandy

Please refer to the documentation from our Help Center about ChatGPT plugin to see all guidelines on how to use it:

In general, does this issue occur when using Custom Request/Chat features only or all of them? Is it possible to record video demonstration of the issue for better visual understanding of it?

Also, have you tried checking quota on OpenAI side by performing any requests directly there?

Same problem here and OnlyOffice can’t remove the plugin too!

Hello @Ventura

If you are experiencing the same problems as @brandy, please provide this information:

Additionally, please let us know which product do you use, e.g. ONLYOFFICE Docs, Desktop Editors, etc, and its version.

Please provide more details on how do you approach removing of ChatGPT plugin, i.e. step-by-step scenario, for better understanding of your actions.

As I can see, you have also created separate thread for the issues with plugin. However, it does not mention requested information:

“Does this issue typically occur when using just the custom request/chat features or all of them?”

The problem occurs with any way of using the plugin. The problem is the plugin itself (or the Onlyoffice). I would like to remove it.

I’m using ONLYOFFICE Desktop Editors, version (x64 exe).

As mentioned in the other topic that clarified the problem better, the list of problems:

  1. The ChatGPT menu button in the Plugins tab doesn’t open the ChatGPT window on the left;

  2. This previous issue remains even after adding the generated OpenAI API key and restarting the office;

  3. When trying “Custom request” and “Chat”, I get the “quota exceeded” error. My account quota cannot be exceeded because I have never used it before;

Steps to remove the plugin:

  1. Access the “Plugin Manager” button through the Plug-ins tab menu;

  2. Access the “Available Plugins” in the Plugin Manager dialog box;

  3. Find the ChatGPT plugin card;

  4. Click on the “Remove” button.

When removing the plugin, the “Warning” dialog box that says “Do you want to completely remove this plugin?” doesn’t work either. When clicking the “Yes” button nothing happens. When clicking the “No” button, the new removal dialog (with timer) freezes and never closes.

On the first attempt, there were two ChatGPT plugin cards under “Available Plugins”! One with the rating stars filled in and the other without this data. After the first removal attempt, only the one that didn’t have the rating stars filled in remained.

After the first (and tenth) removal attempt, although the Plugins tab’s ChatGPT button is still there, the problem that remains is that NO context menu features work now.

I understand that the explanation is very clear and there is no need to record a video for demonstration.

As a result, I cannot use the plugin and cannot remove and reinstall it!

I also cannot find the ChatGPT plug-in folder in the system to remove it manually.

In the Program Files\ONLYOFFICE\DesktopEditors\editors\sdkjs-plugins folder there is only the default plugins.

Wouldn’t it be easier to indicate the folder so I can remove the plugin manually?

I have to mention that I did not experience any issues with usage of ChatGPT plugin whatsoever. I’ve configured the plugin according to Configuration section of this guide, for instance:

Actual version of ChatGPT plugin works from context menu (right-click) only, the left toolbar window was deprecated.

Such error occurs when quota on your OpenAI account is exceeded. You can check it out here:
It may not be related to the exact API key you’ve generated for plugin.

All installable non-default plugins are located in C:\Users\[username]\AppData\Local\ONLYOFFICE\DesktopEditors\data\sdkjs-plugins. ChatGPT plugin ID is {9DC93CDB-B576-4F0C-B55E-FCC9C48DD007}.
Please note that /AppData/ folder may be hidden.

1 Like

After uninstalling the plugin by deleting the folder with the path provided and having the plugins menu clean (without the ChatGPT button), I reinstalled the plugin following the instructions on the page provided (which I had already done previously).

NOTHING worked! None of the context menu options worked!

The ChatGPT plugin simply does not work for a pt_BR system. I have a contract with OpenAPI and I use the chat bot normally. But with the Onlyoffice plugin it didn’t work. I deleted the folder again and gave up.

I’m sad to know that. In case you decide to troubleshoot the issues, feel free to contact us back.