Problem with converting

Hello, I have a problem with converting doc/docx to pdf.
Everything works fine until it comes to large files. I have large files with huge tables and when converting such files, I get an error with code “-3”, a conversion error. I do not receive it immediately, but after some conversion time (1-2 minutes). I’m using the Asynchronous way.
I cut out a large table separately and got the same error again (file ~1Mb).

This is my data that I send in a post request

data = {
        "async": True,
        "filetype": file_extension,
        "key": document_key,
        "outputtype": "pdf",
        "url": file_url,
        "title": pure_file_name,
}

With small tables everything works well, with large files without tables (~11Mb) everything works well
I have 420MB docx and it didn’t work, I cut out the tables from it at the end of the document (the file became 418Mb in size), and everything worked, which means the problem is in them.

HELP PLEASE!!!

Hello @belevich00

Did you check if it is possible to convert the document that only has these tables? If you face an issue with this document with only tables, please share it with us for analysis.

@Constantine Thanks for the answer. Yes, I tried only these tables. I have 2 files.
First - tables 639 pages works perfect. Second - same file, but 20 pages more at the end and it doesn’t convert, error -3.
I cant upload files here, because

Sorry, new users can not upload attachments.

It seems that downloading of these files is restricted. Without files I cannot analyze the situation. If you are worried about safety, you can sent these documents to me via PM.

@Constantine
tables 656 pages.docx (479.5 KB)
tables 639 pages.docx (467.4 KB)

639 pages works well, 656 pages doesnt work

Thanks for documents. Unfortunately, I didn’t manage to reproduce the issue with any of these files. I’d like to mention both files have more pages then in their names.

Please let me know the version of Document Server to which Conversion API you are making requests to convert these files.

I apologize for the long response. Could you tell me how to see the version if I have it deployed via docker. I didn’t create this container and I don’t know how to look =(

You can either check it from the editor interface by navigating to About tab on the left toolbar or by executing docker exec -it <ID> apt list --installed | grep onlyoffice command from the terminal (where <ID> is ID of container with Document Server).

My OnlyOffice version: 7.0.1-37 amd64 [installed,local]

I see, thanks. Note that your Document Server is outdated and not supported. Please update it to the actual 7.5 version and ty again.