Permanently change default font

I’m using OnlyOffice version on a laptop using Arch Linux.

When I create a new, blank document, the font is automatically Arial, 11 pt. and . Of course, I can change this without a problem, but I’d prefer to have new documents start automatically in a different font and font size. Is there a way to change the default settings for this? Everytime I search for a way to do this, I just get an answer to change the font for the current document, not all future documents.

Hello @rpallen
You should replace the pre-made example of the file by another one with necessary font settings saved to achieve your scenario. Examples are located here: /opt/onlyoffice/desktopeditors/converter/empty

Thanks. That worked, but it wasn’t as easy as it might seem. Below is what I did.

  1. In a terminal as root (sudo) I backed up the original /opt/onlyoffice/desktopeditors/converter/empty/pt-BR/new.docx to new.docx.orig.

  2. I then opened new.docx.orig in OnlyOffice, changed it to the settings I want and then tried to save, but it wouldn’t let me.

  3. I closed without saving.

  4. I opened a terminal window and started OnlyOffice as root (sudo onlyoffice-desktopeditors).

  5. I opened new.docx.orig.

  6. I then was able to save the file as new.docx.

  7. After I closed OnlyOffice as root and opened it again as a non-root user, the new document opened fine with the new settings.

Thanks again and feel free to pass on these more detailed instructions to anyone who asks the same thing. Or feel free to incorporate them into the OnlyOffice docs.

1 Like

Thank you for the guide, I will share this post if I face similar question.
By the way, I think there’s a shorter way to achieve it;

  1. sudo chmod -R 775 /opt/onlyoffice/desktopeditors/converter/empty/
  2. Copy new.docx file to another location > edit it and replace back.
    It worked this morning during the tests, but your way seems to work too.

I understand what you’re saying, but I am a bit reluctant to change permissions in a program-even if it is just a document. I’m not a complete newbie, but I’m certainly no expert. Sometimes there are reasons something has the permissions it has that I may not know about. I’m not completely against doing so, but if I have an alternative way to do something that is not too convoluted, I’ll generally take the alternative.

Salve, mi sono appena iscritto e quindi trovo una risposta di 6 mesi fà, mi scuso in anticipo per la meraviglia, ma veramente è necessario fare questo iter per preimpostare il carattere, l’altezza, i margini e così via?

Please note that the language of communication on this forum is English. Please specify your request.

Hello, I apologize, I don’t go to the forums very much; I translate the message with google translate
Hi, I just signed up and then I find an answer 6 months ago, I apologize in advance for the question with amazement, but is it really necessary to do this process to preset the font, height, margins and so on?

As I said in a previous post, your method worked. Unfortunaley, when I update the program, updates restores the original template file. I don’t know if there is a way to prevent this, so I’m left with doing the same procedure after each time I upgrade or just live with the settings in the original template.


I have done this but OnlyOffice is seemingly not using/ignoring those files. It did work for a while, but not anymore.

I have also placed these templates in the en-GB and en-US folders. But new documents still have English (US) as the default locale.

Any suggestions as to what might be going wrong?

EDIT: I had to resave the files and it seems to work again. My guess is that after OnlyOffice updated, it began ignoring the ‘older’ files in the structure.

Hello @theneilkirk and @rpallen
This is expected behaviour. Each time the app runs an update, templates are replaced with default ones. It’s necessary step to avoid conflicts with new version of the app.
Workaround solution is saving necessary templates to other location before the update process and replace them back when update process is finished.

1 Like