Opening every file as read only

I am facing a problem after updated my Opensuse Tumbleweed with KDE Plasma 6.0. Whenever I try to open an Excel or Doc file in OnlyOffice it opens as read only. I tried to Save as that file with new name & location but nothing works. Even I tried to create new file but not able to save that too. I am getting the message that " This file can not be saved / created due to following possible reasons -

  1. The file is read only.
  2. The file is being edited by other users.
  3. The disk is full or corrupt."


Kindly suggest any solution for this problem.

Is there no one who can solve this problem?

Hello @Omsoni

Please specify how Desktop Editors are installed. By the way, you can try out alternative installation methods for the test purposes to see if it makes any difference:

I have uninstalled and reinstalled Onlyoffice Desktop editor through Discover app in Opensuse Tumbleweed. But the result is same.

Please try installing Desktop Editors according to this guide:

I am not quite sure from where mentioned Discover app brings the sources.

Got the solution. I removed it from Discover app and reinstalled through Snap. Now it is working properly.

1 Like

Iā€™m glad to hear that everything is working now. Unfortunately, as I mentioned we are not sure how Discover app installs the app and from which repository, thus we recommend installing apps according to the official site instructions.

I am closing this topic as solved.