ONLYOFFICE Docs v6.4 with conditional formatting, new scaling options, and WOPI protocol support
ONLYOFFICE Docs v6.4 released

"Open in Onlyoffice" -> "Sorry, something went wrong"

Good morning,

I installed latest version of Onlyoffice Docs Community Edition using Installing ONLYOFFICE Docs for Windows on a local server - ONLYOFFICE on a Windows Server 2012 Virtual machine. I can see the Welcome Screen on the Document Server Vm, on the Sharepoint Server Vm and also on the user machine.

I also installed Sharepoint Integration v1.2 on a Sharepoint 2016 on premise using ONLYOFFICE Api Documentation - ONLYOFFICE SharePoint integration solution (Sharepoint is running on a Windows Server 2012 R2). I added there the IP address of the Document Server with preceding “http” in the Onlyoffice settings.

If I open my Sharepoint site (using https) and click the button “Open in Onlyoffice” on a .docx document, I can see the error “Sorry, something went wrong” on a new tab. Why?

Can the problem be because of https is not enabled in the Document server or my network structure is using ADFS?

Hello Ank.

Can the problem be because of https is not enabled in the Document server or my network structure is using ADFS?

That’s right. If your storage (Sharepoint) is using https, then Document server should use https too. Otherwise, you will face mixed content issue. Please try to get SSL certificate for your Document server and reproduce the issue. Please let us know the result.

Hi Alexandre.

It seems that you cannot enable https on Onlyoffice Docks if you have it installed on Windows Server with an exe file (at least I cannot find a documentation for that, only for Onlyoffice Groups and Workspace).

So I installed Onlyoffice Docs with Docker on a Centos machine using Installing ONLYOFFICE Docs for Docker on a local server - ONLYOFFICE. I start running Onlyoffice Docs with:

sudo docker run -i -t -d -p 80:80 -p 443:443 -e LETS_ENCRYPT_DOMAIN=oo.dev.local onlyoffice/documentserver

and I can open localhost and oo.dev.local (after editing /etc/hosts) using http:

[root@centosdevelop develop]# docker ps
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
fec1adde06ec onlyoffice/documentserver “/app/ds/run-documen…” 26 minutes ago Up 26 minutes 0.0.0.0:80->80/tcp, :::80->80/tcp, 0.0.0.0:443->443/tcp, :::443->443/tcp thirsty_swartz

But I cannot open the site using https: “This site can’t be reached”.

I checked the firewall:

[root@centosdevelop develop]# iptables -L -n
Chain INPUT (policy ACCEPT)
target prot opt source destination
Chain FORWARD (policy DROP)
target prot opt source destination
DOCKER-USER all – 0.0.0.0/0 0.0.0.0/0
DOCKER-ISOLATION-STAGE-1 all – 0.0.0.0/0 0.0.0.0/0
ACCEPT all – 0.0.0.0/0 0.0.0.0/0 ctstate RELATED,ESTABLISHED
DOCKER all – 0.0.0.0/0 0.0.0.0/0
ACCEPT all – 0.0.0.0/0 0.0.0.0/0
ACCEPT all – 0.0.0.0/0 0.0.0.0/0
Chain OUTPUT (policy ACCEPT)
target prot opt source destination
Chain DOCKER (1 references)
target prot opt source destination
ACCEPT tcp – 0.0.0.0/0 172.17.0.2 tcp dpt:443
ACCEPT tcp – 0.0.0.0/0 172.17.0.2 tcp dpt:80
Chain DOCKER-ISOLATION-STAGE-1 (1 references)
target prot opt source destination
DOCKER-ISOLATION-STAGE-2 all – 0.0.0.0/0 0.0.0.0/0
RETURN all – 0.0.0.0/0 0.0.0.0/0
Chain DOCKER-ISOLATION-STAGE-2 (1 references)
target prot opt source destination
DROP all – 0.0.0.0/0 0.0.0.0/0
RETURN all – 0.0.0.0/0 0.0.0.0/0
Chain DOCKER-USER (1 references)
target prot opt source destination
RETURN all – 0.0.0.0/0 0.0.0.0/0

and checked what netstat says:

[root@centosdevelop develop]# netstat -tulpn
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:5355 0.0.0.0:* LISTEN 1412/systemd-resolv
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 1/systemd
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 20456/docker-proxy
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 1176/cupsd
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 20435/docker-proxy
tcp6 0 0 :::5355 :::* LISTEN 1412/systemd-resolv
tcp6 0 0 :::111 :::* LISTEN 1/systemd
tcp6 0 0 :::80 :::* LISTEN 20464/docker-proxy
tcp6 0 0 ::1:631 :::* LISTEN 1176/cupsd
tcp6 0 0 :::443 :::* LISTEN 20443/docker-proxy
udp 0 0 127.0.0.53:53 0.0.0.0:* 1412/systemd-resolv
udp 0 0 0.0.0.0:111 0.0.0.0:* 1/systemd
udp 0 0 0.0.0.0:42074 0.0.0.0:* 980/avahi-daemon: r
udp 0 0 224.0.0.251:5353 0.0.0.0:* 19748/chrome --type
udp 0 0 224.0.0.251:5353 0.0.0.0:* 19707/chrome
udp 0 0 224.0.0.251:5353 0.0.0.0:* 19707/chrome
udp 0 0 0.0.0.0:5353 0.0.0.0:* 980/avahi-daemon: r
udp 0 0 0.0.0.0:5355 0.0.0.0:* 1412/systemd-resolv
udp6 0 0 :::111 :::* 1/systemd
udp6 0 0 :::5353 :::* 980/avahi-daemon: r
udp6 0 0 :::5355 :::* 1412/systemd-resolv
udp6 0 0 :::56710 :::* 980/avahi-daemon: r

But I cannot find the problem.

It seems that you cannot enable https on Onlyoffice Docks if you have it installed on Windows Server with an exe file (at least I cannot find a documentation for that, only for Onlyoffice Groups and Workspace).

For Document server Windows installation please check this: Switching ONLYOFFICE Docs for Windows to HTTPS protocol - ONLYOFFICE

As for your docker installation.

and I can open localhost and oo.dev.local (after editing /etc/hosts) using http:

Please note that docker installation doesn’t imply additional changes to the configs. Everything should work out-of-the-box. Are you using totaly clean OS in your test?

LETS_ENCRYPT_DOMAIN=oo.dev.local

Did you blur your domain name or did you try to get SSL cert for top level domain name (for example, test.my.local). Please note, that LetsEncrypt doesn’t support local domain name.

Hi,

I installed Onlyoffice Docs on CentOS VM using Docker and enabled HTTPS on it and I also installed Sharepoint Integration v1.2 on a Sharepoint 2016 on premise. I can call up the Document Server page from the Sharepoint VM. I configured the Document Server Adress in the Onlyoffice settings in Sharepoint.

If I use the button “Open in Onlyoffice”, I get the error " Sorry, something went wrong" and the redirection does not take place (I am still on Sharepoint). I investigated in the logs using UlsViewer and found out that the 0x80070005 (Access denied) error occurred when I am using the button.

But in the Sharepoint Administration in Authentication Providers is “Anonymous access” and “Trusted Identity provider” with the ADFS enabled, but not “Require Use Remote Interface permission” and “Enable Windows Authentication” (in contrast to the video tutorial of the installation of the sharepoint connector).

I also checked under Anonymous Access Restrictions “Permissions to None”.

Does anyone know a solution?

Hello Ank.

The error looks like a problem with Default zone. Please double check it. ‘Enable anonymous access’ should be ON. The rest of the settings on this page (Authentication Provider) do not need to be touched.

Also, you can make screenshots of your Authentication Provider and Anonymous Access Restrictions pages and share them with us.

Hello Alexandre.

Authentication Providers Settings:

Anonymous Policy Settings:

But if I click on the Button “Open in Onlyoffice”, I get:

and in the logs you can see:

As you can see, it gets an 0x80070005 error when attempting to redirect the page.

And I can only attach one image to a post, so sorry for that many posts.

Go to Anonymous Access Restrictions and choose Default zone in drop-down menu. Anonymous User policy is left as it is (None - No policy).

If that doesn’t help, please run a test. Go to Authentication Providers Settings and enable checkboxes which you disabled before (Client Object Model, Windows Authentithication, etc.) According to our guide, there’s no necessary to disable it, but I see a disabled one on your first screenshot.

https://api.onlyoffice.com/editors/sharepoint

After that please let us know the result and make screenshots of all settings on Authentication Providers page.

Even if I select default zone and save this configuration. If I then open Anonymous Access Restrictions again, “All zones” is selected again.

I also enabled Client Object Model according to your guide but that doesn’t help though. I cannot disable “Trusted Identity Provider” (because this is the authentication I am using) but even if I enable “Windows Authentication” it still doesn’t work.

Ok, please reproduce the issue and send us whole Document server logs folder. It’s located here: /app/onlyoffice/DocumentServer/logs/documentserver/

Here are the Document server logs: Download - TransferNow

But I think the problem lays in Sharepoint

But I think the problem lays in Sharepoint

I agree. According to provided logs, the file does not even reach Document server.

We found description of solution for the error which you observed in UIsViewer:

Could you please try it and check the result?

I tried it but it still doesn’t work.

Here are the logs observed by UlsViewer:

Could you please run a test? Create a new user on Windows server > grant the user rights for Farm and Web Application > try to reproduce the issue via the new user account. Will the result be the same?

Could you more describe what you mean by that?

I also installed the SharePoint Connector on another SharePoint 2016 on premise but I got the same result.

And can it also has something to do with the Authentication settings in the IIS? I remember that if I wanted to login in SP Central Administration, the Windows Authentication failed (despite of I was able to login in the Windows machine with the same credentials). I solved the problem by disabling the Windows Authentication and enabling the Basic Authentication in the IIS. Though I don’t know if that problem has something to do with the current problem because I was able to login in my SP since the beginning (because Anonymous Authentication is already enabled).

Hello Ank.

Could you more describe what you mean by that?

I meant that the issue may be related to Windows administrator account. So I suggested a test with creating another user to check it out. Could you please run the test and let us know the result.

I think the results are the same.