Need dedicated support? Click here
Need dedicated support?
Click here

OnlyOffice integration in Chamilo doesn't work at all

Do you want to: Ask a how-to question
Document Server version: 7.4.0-163 amd64 Docs Community Edition
Installation method: Command line
OS: Mint 21.1 (Linux 5.15.0-76 Kernel)


Thanks to the OnlyOffice plugin available in Chamilo (v1.11.20, connector v1.2.0), I want users to be able to create/modify documents thanks to OnlyOffice.

I’ve installed OnlyOffice on my local server with command lines, Chamilo and the server can communicate together via HTTPS.
I’ve put the IP address of OnlyOffice server in the Chamilo configuration plugin.

nginx server is setup to manage HTTP/HTTPS requests to /var/www/onlyoffice/documentserver/

I can create documents with the button, but it opens a blank page, with the loading animation and nothing more except a error message after 30/40s.
I didn’t really understood how to be able to modify documents, when I click “modify with OnlyOffice”, nothing loads on the Chamilo page.

(see screenshot)

first line : WebSocket connection to ‘wss://’ failed:

then multiple of the same error : GET 502 (Bad Gateway)

I’ve checked the nginx logs, and I have this line :
2023/07/25 17:23:19 [error] 2390497#2390497: *10 "/var/www/onlyoffice/documentserver/doc/3452050894/c/index.html" is not found (2: No such file or directory), client:, server:, request: "GET /doc/3452050894/c/?EIO=4&transport=polling&t=OcDfSSz HTTP/1.1", host: "", referrer: ""

I’ve also tried to use the node.js example to test things in a dev env locally, but it doesn’t load any document when I want to (but they are created in the right folder)

Please can somebody explain me how to be able to see document and edit it, with the path of the files I may need to create, etc…

I need this to work with nginx + document server + maybe nodejs if required

Hello @BastienG

This post seems like duplicate of other your post with the same problem:

Please continue communication there and try avoiding creating multiple posts with the same issue. I’m closing this one.