Need dedicated support? Click here
Need dedicated support?
Click here

OnlyOffice integration in Chamilo

Do you want to: Ask a how-to question
Document Server version: 7.4.0-163 amd64 Docs Community Edition
Installation method: Command line
OS: Mint 21.1 (Linux 5.15.0-76 Kernel)
Browser version:


Thanks to the OnlyOffice plugin available in Chamilo (v1.11.20), I want users to be able to create/modify documents thanks to OnlyOffice, and the integration of the WOPI API.

I’ve installed OnlyOffice on my local server with command lines, Chamilo and the server can communicate together via HTTPS.
I’ve put the IP address of OnlyOffice server in the Chamilo configuration plugin.

nginx server is setup to manage HTTP/HTTPS requests to /var/www/onlyoffice/documentserver/

Then, I didn’t really understood how to be able to modify documents, when I click “modify with OnlyOffice”, nothing loads on the Chamilo page.

I’ve tried to specify paths for api too and all the files for the documentserver to work, now something loads up in the page (with the OnlyOffice logo), but I’m not able to modify or even see the document.
(see screenshot)

I’ve also tried to use the node.js example to test things in a dev env, but it doesn’t load any document when I want to (but they are created in the right folder)

Please can somebody explain me how to be able to see document and edit it, with the path of the document I may need to create, etc…

I need this to work with nginx + document server + maybe nodejs if required

Hello @BastienG
Sorry for the late reply.
Please go to connector page and click Save button > please make a screenshot of the result.
After that please collect fresh Document server logs. They are located here:
docker: /app/onlyoffice/DocumentServer/logs/documentserver/
deb\rpm: /var/log/onlyoffice/documentserver/

One more thing. Please point me to the guide that you used for Document server installation. Additionally, let us know how exactly you installed the connector app.

Thanks for your answer.

Since this, I’ve noticed that there was issues during my documentserver install, so I reinstalled everything correctly using Docker. (guide)

With the new install, the Chamilo / OnlyOffice integration works.
I can create documents from the Chamilo course interface, and I have access to them.

But when I want to make a copy of this document (File > Save a copy as), the document is created but seems corrupted, and sometime it even doesn’t save the document.
(on the top, the newly created document)

I can open it but the content of the file is completely removed.
I’ve searched a bit and it seems that the document is actually present in the “forgotten” folder, located here : “/app/onlyoffice/DocumentServer/lib/documentserver/App_Data/cache/files/forgotten/”

Here’s the log file content : (/app/onlyoffice/DocumentServer/logs/documentserver/docservice/out.log)

[2023-08-01T08:10:47.903] [WARN] [localhost] [4088318783] [11] nodeJS - sendServerRequest returned an error: data = {"error":1}
[2023-08-01T08:10:47.937] [WARN] [localhost] [4088318783] [11] nodeJS - storeForgotten
[2023-08-01T08:10:48.597] [WARN] [localhost] [3532238677] [11] nodeJS - sendServerRequest returned an error: data = {"error":1}
[2023-08-01T08:10:48.610] [WARN] [localhost] [3532238677] [11] nodeJS - storeForgotten

(this time, the document wasn’t even created)

nginx.error.log contain this when the document is created and I try to open it :

2023/08/01 08:15:47 [error] 7158#7158: *24 open() "/var/www/onlyoffice/documentserver/web-apps/vendor/socketio/" failed (2: No such file or directory), client:, server: , request: "GET /7.4.0-163/web-apps/vendor/socketio/ HTTP/2.0", host: ""
2023/08/01 08:16:07 [error] 7158#7158: *24 open() "/var/www/onlyoffice/documentserver/web-apps/vendor/socketio/" failed (2: No such file or directory), client:, server: , request: "GET /7.4.0-163/web-apps/vendor/socketio/ HTTP/2.0", host: ""

Chamilo is on version 1.11.20, installed via this guide, with the v1.2.0 integrated connector

Hello @BastienG

It seems that Document server can’t save file to Chamilo. Please reproduce the situation and record a videofile. Also check out this scenario: edit a file > close file > wait for 10-15 seconds > download local copy of the file. Will there be changes in the local copy?
When tests are completed, please provide us with whole Document server logs folder.

Hi Alexandre,

Thanks for your answer, here is the video with the document that can’t save to Chamilo, and the local copy of the file : WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free
I couldn’t get to reproduce the situation where the file was saved but empty.

Here is the log folder :

Best Regards,

Thank you for provided video and logs.
We have found this error entry:

[2023-08-09T07:59:19.134] [ERROR] [localhost] [3123919735] [7] nodeJS - dnsLookup error: hostname = *your_domain_name* Error: getaddrinfo EAI_AGAIN *your_domain_name* 
    at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:71:26)

It seems that Document server doesn’t know your Chamilo domain name. Please try to resolve your DNS settings. Additionally, you can check out your ipfilter section in the default.json config file (on the Document server side). This title might be useful: Configuring IP filter for ONLYOFFICE Docs - ONLYOFFICE
If you changed something in this section, try to rollback it to default state.

Hi Alexandre,
Sorry for the late reply

I’ve changed the DNS settings of docker to match the ones of my local network, and it seems that I don’t have the error line anymore, but it still doesn’t work.

I proceeded to some tests, and one time when trying to save a file, I got an error in the console “file is exist”

Here’s the logs file in case you can find something: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

Best Regards,

Hello @BastienG
I didn’t find new error entries in the provided logs, but your screenshot from console is interesting. How about connector app page? Is there any pop-up error message when you are trying to click Save button?

Hi Alexandre

No, nothing shows up, only a green pop up that saying the changes have been saved, nothing in the console either

Understood, we are checking the situation.

Please clarify the exact issue scenario. Do you try to save a file via File > Save Copy as… or is it different scenario? If it’s possible, please record a video file.

It seems this occurs when I try to “Save Copy as”, but only when the document name is in lowercase (maybe there’s a link with the file that are sometime created when i try to do a copy, which are in lowercase and completly empty)
During my last record (WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free), we recorded a peak of memory usage which made the whole website lag for 30-40s at the exact moment when I tried to save the document, this already happened a few times before while i was testing to save the documents.

I really need to solve this problem, as soon as possible.

Thank you, we are checking provided video file.

Hello @BastienG
Please clarify your Chamilo profile status. Learner\student\administrator? Also did you create the course by yourself? What are your rights for the course where files are located?
By the way, please confirm that you are using connector app v.1.2. Additionally, is it possible to update Document server to v.7.4.1?


I’m an administrator of this Chamilo instance.
I own all the rights on the test course I’ve created, as for the files created.
The connector app version is 1.2, and Document Server is already installed with the latest version.

I was thinking, woulnd’t be possible for me to use OnlyOffice in Chamilo through a WOPI API integration (if we can’t solve my actuel problem)

We are checking the situation.

Hello @BastienG
I want to say thank you for provided information. We have reproduced the situation and we found a bug. We have started working on it. The fix is planned with one of the future connector app versions.

Hi Alexandre,

I’m glad I helped you to find a bug!

Is there any way I can integrate OnlyOffice in Chamilo at the moment, or I’ll have to wait for the fix?

Best Regards,

The bug is related to ‘Save Copy as’ scenario only. All other things are OK and ready to go.


Without using this option, is there a way for the students to save document into their own workspace, in a way where they can edit the document directly from Chamilo and the teacher(s) can see it?