ONLYOFFICE Docs v6.4 with conditional formatting, new scaling options, and WOPI protocol support
ONLYOFFICE Docs v6.4 released

No backup on Centos in web interface

I want to report a bug/problem which connected to backup in web interface
I wanted to do backup and i have found that in Control Pannel there is a function to do backup in web interface of a program.
But after going to Control Pannel i have received that there is a problem with “Error while fetching data” on the screen.

So i tried to uderstand what is the problem and in CLI wrote command:
#systemctl list-units --type service
And i saw that service onlyofficeBackup.service failed. I tried to check what is the problem, restarted service and watched the status of it and that the error what i saw:

Aug 19 11:20:47 onlyoffice.local mono[3791]: /var/www/onlyoffice/Services/TeamLabSvc/TeamLabSvc.exe: Exception has been thrown by the target of an invocation.
Aug 19 11:20:47 onlyoffice.local mono[3791]: /var/www/onlyoffice/Services/TeamLabSvc/TeamLabSvc.exe: The type initializer for ‘System.IO.TempPath’ threw an exception.
Aug 19 11:20:47 onlyoffice.local mono[3791]: /var/www/onlyoffice/Services/TeamLabSvc/TeamLabSvc.exe: Access to the path ‘/usr/lib/Data/temp’ is denied.
Aug 19 11:20:47 onlyoffice.local mono[3791]: /var/www/onlyoffice/Services/TeamLabSvc/TeamLabSvc.exe: Permission denied

I saw Access to the path ‘/usr/lib/Data/temp’ is denied. So i decided to check what is in this directory and it was not …/Data/temp directory inside.
So i decided to change that filepath in config files to see what can be happened. I have found the file /var/www/onlyoffice/Services/TeamLabSvc/TeamLabSvc.exe, but it is .exe file (On Linux server! What?), but there is another file TeamLabSvc.exe.config, and i decided to change “temp” filepath over there.

After changing to then restarted service onlyofficeBackup.service AND it worked for me in some case. I have opened Control pannel and no error with fetching data noticed.

But when i tried to run backup there was an error on the page “Method not found: void ICSharpCode.SharpZipLib.Tar.TarOutputStream…ctor(System.IO.Stream,System.Text.Encoding)”

Can you help me with backup on Centos server? Maybe i did something wrong? As i see backup on linux server is not configured, but i can be wrong because of lack of knowlege. Maybe there is no way to do backup on Linux server? Am i right, Can i do ususal backup of mysql and files in directory /var/www/onlyoffice/? Is it enough?
Thank you in advance!

Community Server version: v11.1
Type of installation of Workspace: manual installation
OS: Centos 7
Browser version: Chrome, Firefox, Edge latest version (no matter)

1 Like

Can you help me with backup on Centos server? Maybe i did something wrong? As i see backup on linux server is not configured, but i can be wrong because of lack of knowlege. Maybe there is no way to do backup on Linux server? Am i right, Can i do ususal backup of mysql and files in directory /var/www/onlyoffice/? Is it enough?

The backup feature should work out-of-the-box without additional changes in config files. It doesn’t matter that you are using Linux or Windows server. Please rollback your config file changes > reproduce the issue > provide us with whole Community Server logs folder.

As I mentioned in your other post, using actual versions of portal components is highly recommended. This eliminates the likelihood of facing a bug that has already been fixed in the current version of portal.

Also please provide us with additional information:

  1. Type of installation (docker\package)
  2. What guide did you use?
  3. Versions of the other ONLYOFFICE components (Control panel, etc.)
1 Like

Hello! Thank you for your answer. I gave you additional info in another topic, but i will dublicate it in this topic too.
I can’t reproduce making backup because i can’t do backup with additional changes in config files, so the same log files from onlyoffice Groups and onlyoffice docs are in another topic.

version of Onlyoffice groups:
[root@onlyoffice ~]# yum list installed | grep onlyoffice
onlyoffice-communityserver.noarch
11.5.2-460 @onlyoffice
onlyoffice-controlpanel.noarch 3.0.0-381 @onlyoffice
onlyoffice-repo.noarch 1.0.0-11 @/onlyoffice-repo.noarch
onlyoffice-xmppserver.noarch 11.0.0-107 @onlyoffice

Onlyoffice-docs:
[root@docs ~]# yum list installed | grep onlyoffice
Repodata is over 2 weeks old. Install yum-cron? Or run: yum makecache fast
onlyoffice-documentserver.x86_64 6.3.1-32 @onlyoffic
onlyoffice-repo.noarch 1.0.0-11 @/onlyoffice-repo.noarch

I have installed Onlyoffice groups through this manual (manual installation, without using script): Installing ONLYOFFICE Groups for Red Hat, CentOS, and derivatives - ONLYOFFICE

Hello titarenko.

I’m posting the same answer in both of your posts for other users to see.

First of all, please accept our apologies for the current situation. We double-checked the guide for manual installation which you pointed us to and we realized that it is not relevant at the moment. This guide is in the process of being updated. Installation via script is OK, but not the manual one.

Please be assured that we will update this guide.

We can offer the following solution to the situation at the moment: make MySQL DB dump, copy Data folder from the portal and restore it on new installation (installation via script).

Please follow my steps to do it:

  1. Make a MySQL dump. Use command mysqldump -u root -p<password> --databases onlyoffice > db_backup.sql

You can check password here: /var/www/onlyoffice/WebStudio/web.connections.config

Copy the dump to external storage.

Command to restore the dump on the new portal: mysql -u root -p < db_backup.sql

  1. Copy Data folder to the external storage:/var/www/onlyoffice/Data/

  2. Install new portal (Groups) via script. You can find it on the same page which you pointed earlier. Place data folder in the same location and restore MySQL dump.

NB! If you intend to use the current server for new portal installation (rollback to zero state) then we strongly recommend to make whole server backup. If something goes wrong during the described actions, you will be able to rollback to the current state.

After the described actions please check if the issues still persist.

Sorry for inconvenience.

2 Likes

Thank you! You are great!
As i mentioned these steps are correct and no troubles was while installation (script install):

no yum update before script installation
no selinux disabled
no firewall disabled
only installing of wget and 2 commands to download and install script.

Temp Backup and backup to Documents done correctly. Restoring from documents went OK (My browser stucked at 32% but after refreshing the page it shown 100% result and rollback to previous clean backup of Onlyoffice was ok).

So i think the problem is solved. Thank you so much! It was realy helpfull. I will test previous problems and write in case of good or bad result in another topic.

1 Like

We are glad to hear that the backup issue is solved. Please feel free to contact us.
As for the second issue, we’ll be waiting for your test result in your second topic.

2 Likes