Migration To another Server 2019

hello,
I have read all the documents and I cannot find the answer.
I have Windows 2019 installed on the workplace and in the last update of the community server it did not finish updating and left me without a server.
After several attempts I was able to go back to the previous version and in the version I have half running the doc does not work for me. It asks me to change the tokens and I can’t hit the nail on the head. Then I decided to do a new implementation but when passing the data that the manual says I find that I cannot access the mysql and it gives me an error of unknown colum u.user_lead in field list in the asp net

Hello @sistemcemep

Please let us know current versions of all components of your portal. You can find this information in Control Panel > Update section.


In general, what is your final goal at the end? As it comes from the name of the thread, you are planning migration. However, description says that you are willing to resolve issues on current portal.

In general, if you are planning migration to another server, you have to keep in mind that you need to have all most recent versions of all components before transferring data to another server. With that said, please make a backup/snapshot of the host server where Workspace is installed to update the portal itself afterwards. If you face any issues during an update, please make sure to provide detailed information on them.

Hello Constantine.
Strange things actually happen, the control panel informs me that I have a document version 4 and I have version 7 installed
The same thing happens with the community, everything is installed from scratch and after making the transfer it looks like this.

Please provide more details about this statement. How did you perform ‘transfer’? Did you create a backup of your portal with outdated versions and then restored it on newly installed portal, i.e. with all actual versions?

The problem started when I wanted to migrate services, after the migration there was a problem and it didn’t let me continue, I had to uninstall everything and reinstall the old version but in that process it stayed this way and I didn’t update anything,
What I was able to recover was the Mysql information and the documentserver and web studio information. The only way to retrieve it was manually since the control panel does not have any features. I tried to do it from a new installation but when I put the old database in it, although it takes the parameters, it leaves me with the old updates.

Thank you for the provided description. I’d like to know in which state portal currently is. Does it allow you to access any modules and work with documents? Please provide more screenshots of described errors and also a screenshot from Control Panel of your Windows Server with all currently installed Workspace components.


As you can see, the control panel detects an old update of the document server, to be more precise, 4.1.5.1. In the second image I show the version that is installed on the server.

Thank you for providing screenshots. Please kindly share this information too:

They partially work, documents ask me for a token, I cannot work internally. and the control panel none of the backup options work

Please make a backup of the host server where your portal is installed and please try updating again. I’d recommend trying to update with complete installer which you can get here:

101 / 5.000

Resultados de traducción

Resultado de traducción

Yes, I am doing the update but the community server does not install. I get the following error.

l Cleaner{&^&}1828{&^&}ONLYOFFICE Feed{&^&}2304{&^&}ONLYOFFICE Indexer{&^&}8732{&^&}ONLYOFFICE Notify{&^&}6100{&^&}ONLYOFFICE Storage Encryption{&^&}9016{&^&}ONLYOFFICE Storage Migrate{&^&}6988{&^&}ONLYOFFICE Radicale{&^&}5972{&^&}ONLYOFFICE SsoAuth{&^&}8148{&^&}ONLYOFFICE Telegram{&^&}8744{&^&}ONLYOFFICE Thumb{&^&}5664{&^&}ONLYOFFICE ThumbnailBuilder{&^&}7668{&^&}ONLYOFFICE UrlShortener{&^&}8652{&^&}ONLYOFFICE WebDav{&^&}8680{&^&}ONLYOFFICE Backup{&^&}5364{&^&}ONLYOFFICE SocketIO{&^&}9584{&^&}ONLYOFFICE AutoCleanUp{&^&}{&^&}'.
MSI (c) (78:AC) [15:15:58:074]: ChildUIThread wait timed out
MSI (c) (78:10) [15:17:24:293]: Doing action: FatalError
Action start 15:17:24: FatalError.
Action ended 15:19:16: FatalError. Return value 1.
MSI (c) (78:10) [15:19:16:810]: Doing action: AI_SHOW_LOG
Action start 15:19:16: AI_SHOW_LOG.
MSI (c) (78:38) [15:19:17:013]: Invoking remote custom action. DLL: C:\Users\ADMINI~1\AppData\Local\Temp\1\MSI968C.tmp, Entrypoint: LaunchLogFile
Action ended 15:19:17: AI_SHOW_LOG. Return value 1.
MSI (c) (78:10) [15:19:17:185]: Doing action: FatalError
Action start 15:19:17: FatalError.
Action ended 15:19:17: FatalError. Return value 1.
MSI (c) (78:10) [15:19:17:185]: Doing action: AI_CleanPrereq
Action start 15:19:17: AI_CleanPrereq.
MSI (c) (78:DC) [15:19:17:310]: Invoking remote custom action. DLL: C:\Users\ADMINI~1\AppData\Local\Temp\1\MSI9804.tmp, Entrypoint: CleanPrereq
Action ended 15:19:17: AI_CleanPrereq. Return value 1.
MSI (c) (78:10) [15:19:17:341]: Doing action: FatalError
Action start 15:19:17: FatalError.
Action ended 15:19:17: FatalError. Return value 2.
MSI (c) (78:10) [15:19:17:357]: Note: 1: 2205 2: 3: Environment
MSI (c) (78:10) [15:19:17:357]: Note: 1: 2228 2: 3: Environment 4: SELECT Environment,Component_ FROM Environment
MSI (c) (78:10) [15:19:17:482]: Destroying RemoteAPI object.
MSI (c) (78:D4) [15:19:17:482]: Custom Action Manager thread ending.
=== Verbose logging stopped: 1/23/2024 15:19:17 ===

May I ask you to provide step-by-step scenario on how do you perform migration?
As far as I understand, you are trying to update your old portal to transfer data to the new one. However, I’d like to know what is planned to do and what you have already done.


Currently, your old portal is working only partially due to inability to update it properly. Does your new portal work now?

Yes of course. In the first instance, install the workspace completely but before finishing it throws an error. The old portal does not work for my token, I have no way to change it, I have searched all the scenarios and it is not possible for it to recognize it.
What I have tried is to backup the data and webstudio folder of the Ascencio folder in program files 86, what I do is install the system from scratch and then move the mysql and the named folders to it. The problem that I always detect is that when restoring mysql the system stops working normally

The old system has LDAP installed and what does not work for me is the control panel, the Backup options and the document server that tells me that the token does not match

Let’s focus on your old portal first since your migration scenario is quite wrong. Best practice is to migrate via backup but for that you need both portals to be fully updated and functioning in the first place.

Please provide more details on this. I’d like to see screenshots of token errors you are facing and screenshot of the Control Panel when accessing it. Also, please provide all logs of Workspace from these directories of your old portal:

  • C:\Program Files (x86)\Ascensio System SIA\CommunityServer\Log\
  • C:\Program Files (x86)\Ascensio System SIA\ControlPanel\Log\

image

I need to make a backup of the emails and documents on the server, other than through the portal.

I configured another server and I have to pass that on to it. I installed the new server through docker.
Could you tell me what I should do to be able to do a manual migration?
I did a migration from windows to windows manually, and everything happened fine until I passed the sql. When I passed the SQL information the version of the document server dropped and that’s where the problems started

Do you want the log in rar?

Best practice is to have both servers with same versions of all portal components, perform backup of the source portal and then restore this backup on destination portal.

What are current versions of both portals?

version server A Versión 12.1.1194 (this is the problem)
Version server B Versión 12.5.2.1848