How to 'paste unformatted' in a single step?

Although the topic is discussed at Paste without formatting in document editor I haven’t found a way to ‘past unformatted’ using only a single keystroke.

After copied text is pasted (Ctl-v), a pop-up provides a way to remove the source formatting via a dialog box, but I assume there is a way to do it without that step.

However, pressing Ctl-t (or Cmd-t since I’m on a Mac) have no effect.

How is it done?

Hi @mk7z
Have you including Shift in your paste keystroke?
I’m on Windows, and I always use Ctrl-Shift-V to paste without formatting.
…maybe that’ll work for you.

> Have you including Shift in your paste keystroke?

Yes. (shift-cmd-v on Mac).
Nothing happens.

:anguished: Pity… I’m afraid I’ve got nothing else.

Hello @mk7z
Please try to use Shift+option+Command+V

Thanks @Alexandre, but no result from that key combination.

Currently, “cmd-v” is the only ‘paste’ operation I can use.

That, of course, retains the original formatting, which often is not what’s desired when pasting into existing text.

I am on a Mac, currently running OS 10.14.3 (Mojave).

@Alexandre My impression is that “shift-ctl-v” works in Windows but that there is no equivalent in Mac OS.

Usually, a keyboard shortcut for ‘paste unformatted’ is standard. I have not run into a situation where it (as “shift-cmd-v”) doesn’t work on a Mac.

Hello @mk7z

The combination Option-Shift-Command-V is also stated in the list of all shortcuts on Apple’s site:

I have tested it on MacOS Ventura 13 and it works fine. Maybe you should take a look in keyboard settings for the shortcut.

Thanks, @Constantine.

I had already tried that key combination. It has no effect. Nothing happens.

In all other apps I’m familiar with, shift-cmd-v works to paste text ‘as unformatted text’ into the target document. I’ve never had to add the ‘option’ key.

Note also that the Apple webpage states: “The behavior of these shortcuts may vary with the app you’re using.”

If that key combination works in Ventura, do you not get the same result just from “shift-cmd-v” –- or if not, what do you get instead ?

(Is there any way to use angle brackets – i.e. < and > – in messages here? They seem to just result in the text in between them disappearing.)


Consistent result: Shift-Command-v executes ‘paste unformatted’ in every app I’ve used it in EXCEPT Only Office. (It is, in effect, the same as the Windows kb shortcut, substituting the Mac’s ‘cmd’ key for the PC’s ‘ctl’ key.)

Also consistent result: Option-Shift-Command-v has no effect at all. Nothing happens. (Not only in OnlyOffice but everywhere else I’ve used it.)

From what I’ve gathered so far, the ‘option’ key is used when text (or a file) is to be ‘moved’ rather than ‘copied,’ but as stated I’m not finding it does anything in Mac OS Mojave (10.14.3). I have seen other posts about Option-Shift-Command-v not working, including by a Catalina user. Even if the key combination appears to work in Ventura, please check to make sure the text is actually being ‘copied’ and not ‘moved’ (i.e., deleted from its original location). Thanks.

Can you make sure that you are using correct version? There are two versions of Desktop Editors: for MacOS 10.13 or higher and for MacOS 10.12 or lower. Please try downloading the one that fits your system and checking the situation again:

Since I don’t have the most current version I’ll download that one and see whether that cures some of the unsolved mysteries. (If possible, please add the ‘Shift-Cmd-v’ kb shortcut for ‘Paste Unformatted’ on a Mac in the next update.)

When I install 7.4.1 will it just overwrite the current one (7.3.3) or do I need to manually delete 7.3.3 first?

I probably have the correct version of OnlyOffice – (Wouldn’t the one for 10.12 or lower not work if I didn’t?) – but if 7.4.1 was out on July 31st I don’t know why I ended up with 7.3.3 when I followed the download instructions at the website.

Do you proactively notify users of new releases when they come out (via email, etc.)?

Usually it does, but since it is possible that you are using another type, I’d recommend deleting installed app first and then installing new one.

I am not personally sure about that.

Yes, of course.