ONLYOFFICE DocSpace released: improve document collaboration with offices, customers, and partners. Use it for free!
ONLYOFFICE DocSpace released

Docs server not working after 7.3.3 update

I hope this is the right forum, got my docs server stuck after an update.
Document Server version: 7.3.3-49
Type of installation of the Document Server (docker, deb/rpm, exe) Install script
OS: Ubuntu 20.04 LTS
Browser version: Brave 1.50

I ran the update command on my OnlyofficeDocs server 7.1.1, to 7.3.3 with: -u true

I ran systemctl status redis, and it is running. I don’t know many other commands to check - when I run supervisorctl status I get no output though. I seem to remember this showing some output in the past.

I am running the licensed Enterprise personal edition, and it has had no issues since the update. Any ideas what to check, or how to get my documents to load?

Thank you

Found this in another post, thought I would share the output:

systemctl list-units | grep ds
  ds-converter.service                                                        loaded active     running   Docs Converter
  ds-docservice.service                                                       loaded active     running   Docs Docservice
  ds-metrics.service                                                          loaded active     running   Docs Metrics

Seems to be running, and I did not update the config, just let it install the update.
Thank you

Hello @dj423

You are running Document Server with Nextcloud, right? Please provide a screenshot of the connector app page while pressing the Save button. Also, provide the version of Nextcloud itself and the version of the connector app.

1 Like

Hello Constantine, Yes you are correct.

The version of nextcloud I am currently running: 24.07
The version of the onlyoffice app shows: 7.5.8.

Something to note, since I had no luck sorting the issue out after the update, I did revert back to the snapshot, so as of this morning it is back to version 7.1.1 for Onlyoffice. I can run through the update process again to troubleshoot it more though. I may need to update my nextcloud instance as well. But I know version 7.1.1 is getting pretty old, so I started with that.

Screenshot is attached.
Thank you

Please update your instance and follow this guide to configure your Document Server:

Also, note that newer version of the connector app is available.

Waiting for you to update and share the same screenshot from the settings of the connector app while saving the settings but from the actual version.
If you face any issues in the process, let me know.

1 Like

Wow, Thank you! I will run through this and give an update. Looks pretty straight forward. I remember doing the JWT key’s back when I initially deployed in 2019.

Now I am really interested in the Nextcloud-OnlyOffice UCS virtual appliance option. Wondering if I can use my enterprise license with the OVA install. I need to get up to speed I see.

Thanks again Constantine!

Please keep us updated.

About the license details you can contact, my colleagues will gladly answer your questions.

1 Like

Just wanted to update.

I finally got time to get back to this. After updating the onlyoffice connector app in Nextcloud to ver 7.7.0, everything updated to 7.3.3 fine. I just ran apt update && apt upgrade and like magic it is running fine. So my issue seems to be I needed to update the connector app in NC before running the onlyoffice update.

Thanks again for the help! Much appreciated!

1 Like

Glad to hear it!

Same problem:
Nextcloud 24.07 with connector app 7.7.0
Upgraded ONLYOFFICE to (from 7.1.1 which has been working perfectly for months)

Like the OP the now when I run supervisorctl restart all, there is no response. The services seem to be running:

systemctl list-units | grep ds

ds-converter.service loaded active running Docs Converter
ds-docservice.service loaded active running Docs Docservice
ds-metrics.service loaded active running Docs Metrics

All other services (nginx, redis etc) are running. The /welcome and /info pages are running.

When I try to reconnect the Nextcloud connector app, it returns the following error:

Error when trying to connect (Client error: GET https://<ONLYOFFICE FQDN>/cache/files/data/conv_check_952007633_docx/output.docx/check_952007633.docx?md5=wilg5TdEd9ZB7u1Z849Mgw&expires=1685388645&filename=check_952007633.docx resulted in a 403 Forbidden

The local.json file secrets match the Nextcloud secret key.

In the nginx error logs, the error shows up as:

…4 connect() failed (111: Connection refused) while connecting to upstream…

It seems the ds: services are refusing to respond

One last thing:

while the systemctl list-units |grep ds shows the document services as loaded and running, if I simply try to restart any particular service I get the following for example:

supervisorctl restart ds-metrics.service

ds-metrics.service: ERROR (no such process)
ds-metrics.service: ERROR (no such process)

Hello @mudslide567

Starting from version 7.3 of Document Server to restart all services you have to use systemctl restart ds-* for DEB/RPM packages installation method.

Did you change JWT credentials after the update? If you did, then possibly services restart would help.
If not, please try connecting again and check out logs of Document Server in /var/log/onlyoffice/documentserver/ for any errors and share them.

By the way, do you have any proxies? Do you have HTTPS enabled?

There is also newer version of the connector app is available.

Thanks for the update to use systemctl instead of supervisorctl, which I had figured out by trial and error after I first commented here.

Nothing was changed at the Nextcloud end at all i.e. I am still using the same secret as before the OO upgrade.

There are no proxies involved and HTTPS is enabled (using Godaddy as the CA). That is also unchanged from the last 18 months.

I restarted everything to get clean looks and then tried to reconnect from NC.

In the /var/log/onlyoffice/documentserver/docservice the err.log file is completely empty. The out.log simply shows:

[2023-05-30T07:29:39.045] [WARN] [localhost] [docId] [userId] nodeJS - Express server starting…
[2023-05-30T07:29:39.090] [WARN] [localhost] [docId] [userId] nodeJS - Failed to subscribe to plugin folder updates. When changing the list of plugins, you must restart the server. File system | Node.js v20.2.0 Documentation
[2023-05-30T07:29:39.411] [WARN] [localhost] [docId] [userId] nodeJS - Express server listening on port 8000 in production-linux mode. Version: 7.3.3. Build: 49

The /var/log/onlyoffice/documentserver/nginx.error.log file is also completely empty.

The nginx error log simply shows the “connection refused” error noted earlier:

… connect() failed (111: Connection refused) while connecting to upstream …

Please try executing this command bash /usr/bin/ and checking situation after that.

I ran this script. There was no output so I cannot be sure it actually executed. In any event, I restarted all services but the net result was unchanged. Still getting same response when trying to connect Nextcloud app.

Check what https://<document_server_address>/healthcheck page returns when accessed via browser and share the output.

I’d ask you to provide all logs of Document Server after attempting to connect. You can archive them, upload to any cloud storage and share the link to it. You can do it via PM in terms of safety.

Health check just returns the word true

LogFiles sent via From document server, error log nginx.error.log; from …/docservice is out.log (nothing in err.log) and included is the error log from the nginx instance itself

How can I get the Zip password to you? Site does not allow me to PM you.

Another datapoint: I looked in the database in the task_result table. At the same timestamp of the failed attempt to connect from NC, there is an entry in the table with the callback value: