Clueless newbie: How to suppress grey diagonals in OO spreadsheet?

Do you want to: Suggest a feature / Report a bug / Ask a how-to question
For feature suggestions, describe the result you would like to achieve in detail.
For bug reports, provide the steps to reproduce and if possible a minimal demo of the problem.
OS version:
App version:
Downloaded from: ONLYOFFICE website / Other (specify). Please point us to the installation guide that you used as well.
Additional information:
Any relevant details about the situation. You can also attach images and videofile to the post (or to place them to external storage).

  1. List item

Sorry, the new forum is hard to work on this small screen. I’ll try again.

I just switched to OnlyOffice from LibreOffice and think it’s great. Problem: imported LO spreadsheets appear with grey diagonal crosses in each of the cells, behind the text. The crosses print out with the rest of the spreadsheet, making it hard to read small supeimposed text. Is there some way to suppress them?

I tried filling with white (obviously) but that’s no good.

Sorry for such an obvious question…

Best, NP

I found it. I had to explicitly apply a “No borders” style from the “Borders” dropdown on the Home tab to all the cells showing diagonals.

Notes for the developers: I imagine that the application of the borders style to the imported OpenDocs spreadsheet was a response to clunky coding by Gnumeric, which seems to have some idiosyncratic features. Also, a few cells (five or six within a spreadsheet of several thousand) came through with the “No borders” style in place. I don’t understand why this would have been the case.

A further note: I use reverse dates (eg today is 240531) in order to set up certain processes downstream of the spreadsheet. In Gnumeric, I formulated these as “General”, but the result in OnlyOffice was that many of them were converted into formulae on the “2E+3456” model. I had to select them, choose “Number” format, place the cursor into the edit box and type a return to get the original text back. It’s no hardship, but suggests a glitch somewhere?

Best, NP

Hi @niftyprose :wave:
Please take a look at this topic!
In it, @Constantine has tried to find a workaround for the issue.

We will need the file from you to determine if this is the same bug that @natamox reported.