Black screen in the main console or at any document opening

Hello I am having this issue with a new installation on a new computer. All I get is a black screen in the main Console or any document I try to open.
I tried already to redo installation or reboot, install and launch as Admin, etc, nothing works.
There is no error window during the installation.
Do you know what may be causing this issue?
Is there any dependency of .NET, VisualC Runtime, Java or other thing that may be missing in the computer?
Thanks in advance for any guidance.

OS version: Windows 10 x64 Pro
App version: 7.5.1 for Windows x64
Downloaded from: ONLYOFFICE website (just today)

hi @bcesary :handshake:

Thank you for bringing attention to this issue and describing it on our forum.

We are investigating your problem. Once I receive new information from my colleagues regarding this issue, I will inform you promptly.

@bcesary
We continue our efforts to reproduce the issue you’ve described, unfortunately, without success so far.

  1. Could I kindly ask you to provide a screen recording or a detailed description of the actions you are taking? (Screen recording is preferable.)

  2. Please clarify the following information:
    2.1 Configuration of your computer
    2.2 Number of connected monitors
    2.3 Scale settings on the monitors you are using.

3.Did you use the exe or msi installation?

  1. When reproducing the issue in debug mode, could you please check for any errors that appear in the console?

  1. Does the issue persist when you resize the application window?

Hello Nikolas. I appreciate your help. Here are more info as per your requests.

  1. Done, please watch here.

  2. Acer Nitro 5 laptop, 32gb RAM, Win 10 Home 22H2, one monitor connected via HDMI. Resolution 1920x1980. Scale I tested 125% and 100% with same results.

  3. Tried both. Both give same result. In the video is the EXE that runs.

  4. Debug mode also shows a black screen in the console :frowning:

  5. Issue presists when I resize or I move to the external monitor.

@bcesary
Thank you for providing the video! :saluting_face:

I’ve forwarded the information to our specialists. I’ll reach out to you as soon as there’s any update.

1 Like

hey @bcesary :handshake:
In the near future, ONLYOFFICE Desktop Editors 8.0 will be available.
We’ve decided that it would be better to suggest waiting for the release version and trying to reproduce the issue on version 8.0.

The approximate release date for the desktop version is within 2-7 days.

Ok I will wait for the version 8.0 to give it a try, altough the black screen issue also happened with version 7.1.
Thanks.

:eyes:

Let’s try the following solution. My friend suggested launching the editor with GPU disabled using the following steps:

  1. Press Win + R
  2. insert

“%ProgramFiles%\ONLYOFFICE\DesktopEditors\DesktopEditors” --disable-gpu

  1. Press Enter

Hello Nikolas, this flag worked for both 7.5.1 and new 8.0 version. At least we can open the application now with a custom shortcut containng the flag,
But if the user double-clicks a file on the computer, the DesktopEditors launch without that flag and we get Black-Screen again.
And for users, you know, It is not natural to have to open the App first to them open the document.
Is there a way to make this –disable-gpu also works when I double-click a doc/xls/ppt document?
I also tried to disable all NVIDIA 3D settings for the DesktopEditors, but never helped.

@bcesary
Alright, we’ve determined that the problem is related to the video kernel.

  1. Could you please confirm if you have the latest drivers installed for your video adapter? If the drivers are outdated, please update them.

  2. Please attach a similar screenshot.

To access Device Manager, press Win + R, then type devmgmt.msc and press Enter.

  1. Additionally, could you please provide a screenshot of your graphics settings?

System > Display > Graphics > Change default graphics setting

Hello Nikolas I found a quicker workaround, to modify the Windows Register adding the --disable-gpu to all file extensions OpenWith keys.
This solved the issue.

I hope next releases of OnlyOffice you can store the “DISABLE GPU” flag permanently in a INI file or something to avoid similar issues on computers with non-trivial graphycs cards.
I have limited access to this specific system, so my engagement ends here.
Thanks!