Need dedicated support? Click here
Need dedicated support?
Click here

Zotero In-Text Citation feature keeps hanging up

For bug reports, provide the steps to reproduce and if possible a minimal demo of the problem:

Hello there,

I am appreciating the Zotero plugin, however I am finding it quite buggy.

I initially installed OnlyOffice through the software manager, followed the installation guide but couldn’t get the latest Zotero plugin to work properly. Specifically, it gets stuck at loading whenever I try to insert an in-text citation. I uninstalled the flatpak and tried to use the AppImage file. Initially, I managed to get it to work, however it fell back to the same issue.

Is there any recommendations on how to go about this issue?

Thank you very much.

Document Server version: N/A
Installation method: flatpak and AppImage
OS: LinuxMint 21.1 Vera (Cinammon Edition)
Browser version: Firefox

1 Like

Hello @mitsk
Please let us know version of your installed Desktop editors and point me to the guide which you used for Zotero installation.

Hello Alexandre,

Thank you for your reply!

They’re both the latest version

The instruction was the one I saw on the provided in github where I downloaded the plugin. →

Thanks again. :slight_smile:

I’ve checked out my Linux Mint test machine and I didn’t find an issue.

Probably we need additional information. Please try to run Desktop editors in debug mode: Running ONLYOFFICE Desktop Editors with parameters - ONLYOFFICE
This mode allows to open console on F1 button. Please reproduce the issue and send us screenshots from ‘Console’ and ‘Network’ tabs.
For flatpak installation, the debug mode enables with this command: flatpak run org.onlyoffice.desktopeditors --ascdesktop-support-debug-info

Hello Alexandre,

These are the screenshots from the debug:

Thanks again for looking into this.

Thank you for the provided data, we are looking into it.
By the way, we found similar case on GitHub:
Is this you? If so, please do not post the same request in different communication channels and let focus our work here (on the forum).

Could you please run a test? Please use this plugin, I’ve uploaded it here: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free
Install the plugin via plugin manager, use the first part of this guide: ONLYOFFICE Api Documentation - Adding plugins
Please try to reproduce the situation and let us know the result.

Hello Alexandre,

These are the results after following your instructions:

Yes. Apologies. Initially I didn’t know where I would get a response from.

Where did you get first screenshot? Console?
As far as I understand, you have reproduced the situation with our build of this plugin. I’m afraid we need additional information:

  1. If it’s possible please record entire usage scenario (from the moment you start the Desktop Editor till the issue reproduces).
  2. We need Zotero items list which you’re trying to use (the items which provoke the issue). Additionally, you can create timelimited key from your Zotero Web Library and send it to us. This way we’ll try to reproduce your scenario step-by-step.
  3. Your OS system language, editor language.

I had a similar problem with zotero plugin freezing when trying to insert citation. Reinstalling the plugin didn’t help. I had to clear the cache in /home/user/.local/share/onlyoffice/desktopeditors/data/cache/Cache/Cache_Data/. After that it worked again.

Another problem is I can’t find all the citation styles in the list and I can’t read the style from external csl file, I have to switch to windows office zotero plugin for that.

Hello @lachim

Another problem is I can’t find all the citation styles in the list and I can’t read the style from external csl file, I have to switch to windows office zotero plugin for that.

If it’s possible, please describe the situation in detail. You can make screenshots and add description of desired scenario. We will check it out.