You are trying to perform an action you do not have rights for. Please contact your Document Server administrator. Press "Ok" to return to document list

Thanks. Lets check if needed tables are there:

  1. Connect to PostgreSQL with earlier mentioned commands:
  1. Connect to onlyoffice database with \c onlyoffice;
  2. Show all tables with \dt.

Share an output after that. You should see 2 tables inside the database and their owner must be onlyoffice.

Hello,
The final output is as below \dt .

Is it the content of onlyoffice database? Please make sure to run those commands as they are listed. If it is really content of onlyoffice database then it makes sense that Document Server cannot operate.

To drop the database you can use following command from host (without starting interactive session):

sudo -i -u postgres psql -c "DROP DATABASE onlyoffice WITH (FORCE);"

Please prepare server backup or snapshot before running this command to have possibility to rollback server to its previous state if this database somehow contains important info.

After dropping database, please re-create it with:

After that restart Document Server services with systemctl restart ds-* and check the situation again.

Even though I did it again, the result was
(You are trying to perform an action you do not have rights for.Please contact your Document Server administrator)

Can you show a screenshot that also demonstrates steps you’ve performed? It is not quite clear how you received such output.


By the way, you can try running installation of Document Server with provided script:
https://helpcenter.onlyoffice.com/installation/docs-community-install-script.aspx

To run installation with DEB packages instead of Docker pay attention to last block:

You will be prompted to select the way you want to install ONLYOFFICE Docs. Type N and press Enter to install ONLYOFFICE Docs from DEB/RPM packages.

If you decide to attempt running a installation script, make sure to remove old package of Document Server.

Hello,
There are 2 tables in the database as below

withdt

Please check if the error in the interface returns now.

Error persists

Ekran Alıntısı

That is another error. Please share fresh logs now to check out.

Please set up rejectUnauthorized parameter in default.json config from directory /etc/onlyoffice/documentserver/ to false, restart Document Server services with systemctl restart ds-* and check the situation.

If any error occurs, please provide fresh logs and local.json config for analysis.

Hello Constantine,
I saw the same problem in a different article and ran this command (bash documentserver-update-securelink.sh)
The problem has been solved, thank you for your support.

1 Like

Hello, how can I fix this error?
The document security token was not generated correctly.
Ekran Alıntısı

Please find description of this error here:

Are you integrating Document Server with another app or it is prompted in the integrated test example of Document Server? In general, this error appears when incorrect JWT credentials are used between Document Server and application it is integrated with. You can find secret and header of JWT in local.json config of Document Server in token section.