Cloud Computing Insider Awards 2022: Vote for ONLYOFFICE
Vote for ONLYOFFICE

Wrong mx

Hi,
I installed OnlyOffice on the newly installed ubuntu 22.04 using a workspace script using docker option:
bash workspace-install.sh -md “skrutator.eu

After installation, I wanted to set up a mail domain. Unfortunately, the MX value was incorrect. How can I change this?

I tried to change the MX value by Changing domain used with ONLYOFFICE Mail - ONLYOFFICE, but failed.

THX for response

Details:
communityserver:12.0.0.1726
mailserver:1.6.75
controlpanel:3.1.0.460

Hello @Scorty
Please go to the host and run nslookup set type=mx your_domain_name . Please show us the result.

Hello @Alexandre
mx1

I’m a little bit confused because when I open http://skrutator.eu/ - I see Nginx proxy welcome page. Do I understand you right that you have proxy server in front of Workspace portal?
Please describe your installation.

Hi @Alexandre
you are right, the server is behind the proxy in the DMZ. The address is https://oo.skrutator.eu

In MySQL, I found a table with MX content from the first screenshot “mail_server_dns.mx” After the change (tested: mx.skrutator.eu, skrutator.eu), the content appears in place of the MX record, but verification still fails.

Is it possible to run a test? Please prepare whole server backup\snapshot of current server state. You will be able to rollback to it after the test. Rollback server to zero station (before portal installation) and use installation script with -md flag one more time. But it should look like that: bash workspace-install.sh -md “oo.skrutator.eu