ONLYOFFICE DocSpace released: improve document collaboration with offices, customers, and partners. Use it for free!
ONLYOFFICE DocSpace released

Workspace document editor doesn't load documents


I installed the community edition of OnlyOffice on my Linux server.
In the first couple of days, everything worked well. I was most interested in project management and CRM but quickly needed to add documents to project tasks.
Again, everything seemed to work great until yesterday when all the sudden, documents, spreadsheets, presentations, etc. don’t load on the web editor. It just stays there forever trying to load until it eventually times out.

I tried this with different browsers and it was the same with all of them.
My server runs Ubuntu Server 22.04 LTS

Hi @Expand7004

Please provide some additional information about:

  1. Type of installation of Document Server (docker, deb/rpm).
  2. To get better understanding please provide screenshots of browser’s console Network and Console tabs.:

To do these screenshots please follow this scenario:

2.1 Open any document in the editor to reproduce the issue;
2.2 Open browser’s console (F12 in Chrome/Firefox/Edge);
2.3 Reload the page;
2.4 Make screenshots of Network and Console tabs of browser’s console.

Have you updated OO Workspace?
You may have performed some actions on the server. If this could be, please specify.

Hi Nikolas,

Thank you so much for reaching out. When I 1st opened this ticked I had my OO installed in a ubuntu server 22.04 LTS (Deb packages).
Since then, I decided to make a a new install and I used Debian 11 this time. Also deb packages. I had the same exalt result. It works fine for 24 hours and the following day I can’t open documents. Nothing really changed in my config or system. I leave it alone and when I come back the next day is broken :confused:

Below you will find the screenshots you requested

Thank you again

Hi, @Expand7004

Provide the following information:

Screenshot of the settings for integration with the document server:
settings > Document service > Document service location

Are the documents you are opening on a server or external storage?

Run the following commands and provide the result of their execution:

apt list --installed | grep onlyoffice
netstat -tulpn

Check if your document-server page opens: http://ip.your.portal/ds-vpath/

Hi @Nikolas

I appreciate your help.
I am a new user and I am trying to understand the mechanics of the document service.

When I installed workspace, my main goal was to use project and CRM. I added documents to my projects and it worked (on the 1st day) without me setting up the document service. I did add a webdav location for backups but never added a location for the doc-server, never looked like I needed to setup anything to use documents.

I ran the commands you sent me and this is what I got:


telmo@onlyoffice:~$ apt list --installed | grep onlyoffice

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

onlyoffice-communityserver/squeeze,now all [installed]
onlyoffice-controlpanel/squeeze,now all [installed]
onlyoffice-documentserver/squeeze,now 7.3.3-49~stretch amd64 [installed]
onlyoffice-xmppserver/squeeze,now all [installed]

telmo@onlyoffice:~$ netstat -tulpn
(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp 0 0* LISTEN -
tcp6 0 0 :::* LISTEN -
tcp6 0 0 ::1:9300 :::* LISTEN -
tcp6 0 0 :::22 :::* LISTEN -
tcp6 0 0 ::1:5432 :::* LISTEN -
tcp6 0 0 :::9889 :::* LISTEN -
tcp6 0 0 :::33060 :::* LISTEN -
tcp6 0 0 :::5672 :::* LISTEN -
tcp6 0 0 :::9800 :::* LISTEN -
tcp6 0 0 :::9834 :::* LISTEN -
tcp6 0 0 :::3306 :::* LISTEN -
tcp6 0 0 :::9899 :::* LISTEN -
tcp6 0 0 :::9999 :::* LISTEN -
tcp6 0 0 :::* LISTEN -
tcp6 0 0 ::1:9200 :::* LISTEN -
tcp6 0 0 ::1:5232 :::* LISTEN -
tcp6 0 0 :::4369 :::* LISTEN -
tcp6 0 0 :::8082 :::* LISTEN -
tcp6 0 0 :::8083 :::* LISTEN -
udp 0 0* -


When testing and trying to figure out where my problem is, I noticed that now my control panel screen also doesn’t load :confused:
And I tried to open the document-server page on my browser and it opened.

Hello, @Expand7004

I don’t see port 8000 for document service.

Please check the document service
supervisorctl status all

Start the service if it is stopped:
supervisorctl start all

but the document service port is 8083… or am I wrong?

Port 8083 is nginx – proxy to DocumetServer
port 8000 is docservice

You can use:
sudo netstat -tulpn
to see Program name using port

Hi @Nikolas

I don’t have supervisorctl. I actually installed it but I don’t see any services there.
What is bothering me right now is the fact that is i list the active services with systemctl i see this:

mysql.service loaded active running MySQL Community Server
networking.service loaded active exited Raise network interfaces
nginx.service loaded active running A high performance web server and a reve>
onlyofficeAutoCleanUp.service loaded active running ONLYOFFICE AutoCleanUp Service
onlyofficeBackup.service loaded active running Start ONLYOFFICE Backup Service
onlyofficeControlPanel.service loaded active running ControlPanel Main
onlyofficeFeed.service loaded active running ONLYOFFICE Feed Service
onlyofficeIndex.service loaded active running Start ONLYOFFICE Index Service
onlyofficeJabber.service loaded active running ONLYOFFICE Jabber Service
onlyofficeMailAggregator.service loaded active running ONLYOFFICE MailAggregator Service
onlyofficeMailCleaner.service loaded active running ONLYOFFICE MailCleaner Service
onlyofficeMailImap.service loaded active running ONLYOFFICE MailImap Service
onlyofficeMailWatchdog.service loaded active running ONLYOFFICE MailWatchdog Service
onlyofficeNotify.service loaded active running ONLYOFFICE Notify Service
onlyofficeRadicale.service loaded active running ONLYOFFICE Radicale Service
onlyofficeSocketIO.service loaded active running ONLYOFFICE SocketIO Service
onlyofficeSsoAuth.service loaded active running ONLYOFFICE SsoAuth Service
onlyofficeStorageEncryption.service loaded active running Start ONLYOFFICE StorageEncryption Servi>
onlyofficeStorageMigrate.service loaded active running Start ONLYOFFICE StorageMigrate Service
onlyofficeTelegram.service loaded active running ONLYOFFICE Telegram Service
onlyofficeThumb.service loaded active running ONLYOFFICE Thumb Service
onlyofficeThumbnailBuilder.service loaded active running ONLYOFFICE ThumbnailBuilder Service
onlyofficeUrlShortener.service loaded active running ONLYOFFICE UrlShortener Service
onlyofficeWebDav.service loaded active running ONLYOFFICE WebDav Service

Those are the onlyoffice services. I don’t see a docservice among those.

My fault.
Since 7.3 Service manager in the onlyoffice-documentserver packages changed from supervisord to systemd to get rid of excess dependence and simplify functionality for end users.

Check: systemctl restart ds-converter ds-docservice ds-metrics ds-example

systemctl restart ds-*

Workspace document editor doesn’t load documents

We reproduced the situation.
I will let you know when I get something.

1 Like


Thank you for the information. We reproduced the situation.
Fix for this issue will be added in version 12.5.

Currently, as a workaround, use the following solution:

chown ds:ds -R /var/log/onlyoffice/documentserver
systemctl restart ds-*


Thank you so much for all your patience and time.

I can confirm your workaround fixed the issues I had loading the “document editor” and the “control panel” pages.

It was a pleasure,


1 Like