Meet ONLYOFFICE Docs Cloud, complete office software as a service
Meet ONLYOFFICE Docs Cloud

WOPI Integration, Session Expiration and configuration settings

Hi,

i successfully managed to create a WOPI endpoint and can view and edit documents. However i wonder if there is a setting to configure the session expiration. Sometimes i get an expiration message after ca. 60 seconds and sometimes immediately after opening a document.

Second. I have set the autoassembly interval and step to 0m in local.json. I found that in an article to force ONLYOFFICE to do a post to the PutFile endpoint on saving. Otherwise iam always getting a version mismatch message. Is there any known better solution than just forcing to post every change back? I saw a question on github issues with exactly that problem, but the issue was closed without leaving an answer there.

The configuration file has multiple options and for most of them i couldnt find documentation. Is there a document available which describes the various documentation options?

Iam using ONLYOFFICE 7.1 docker container as WOP Client.

Thank you in advance

Stefan

Hello @StefanW
Sorry for the late reply.

Second. I have set the autoassembly interval and step to 0m in local.json. I found that in an article to force ONLYOFFICE to do a post to the PutFile endpoint on saving. Otherwise iam always getting a version mismatch message. Is there any known better solution than just forcing to post every change back? I saw a question on github issues with exactly that problem, but the issue was closed without leaving an answer there.

As far as I understand you are looking for ForceSave feature. Please note, that we are still working on this feature for WOPI. Recently we discussed the situation here: Running OnlyOffice with Docker-Compose - WOPI - Connection refused while connecting to upstream - #21 by Alexandre

However i wonder if there is a setting to configure the session expiration. Sometimes i get an expiration message after ca. 60 seconds and sometimes immediately after opening a document.

Please provide us with details of your desired scenario. default.json file contains sessionidle and sessionabsolute parameters which regulate editing session expiration.

“sessionidle” parameter is responsible for the disconnection user from the editor if they are inactive for some time. It can be set in /etc/onlyoffice/documentserver/default.json inside the container with the Document Server this way:

                        "expire": {
                                "sessionidle": "0",

Value can be “1h” for 1 hour, “3d” for three days, “20m” for 20 minutes and so on - any time period that meets your requirements. Please execute supervisorctl restart all after you make any changes to the default.json to apply them.

“sessionabsolute” parameter. This parameter is responsible for forcing the closing of the file after a certain amount of time.