ONLYOFFICE 7.0: online forms, password protection in sheets, collaboration improvements and much more
ONLYOFFICE 7.0 released

Windows Server 2022 Standard - Installation fails

Hi im using a fresh installed Windows Server 2022 Standard.

After installing OnlyOffice Workspace for Windows Server the installation fails with an non specified error.
I took Windows Server Installer from here Download ONLYOFFICE Workspace | ONLYOFFICE

Here are the last rows of the log of the installation. Any idea :frowning: ?

...
...
...
Property(S): SIGNALR_PORT =  
Property(S): SSO_AUTH_PORT = 9834
Property(S): SecureCustomProperties = OLDPRODUCTS;AI_NEWERPRODUCTFOUND;AI_SETUPEXEPATH;SETUPEXEDIR
Property(S): SqlConnectionError =  
Property(S): USERNAME_PROP = root
Property(S): ButtonText_Return = &Return
Property(S): WindowsType9X = Windows 9x/ME
Property(S): WindowsType9XDisplay = Windows 9x/ME
Property(S): WindowsTypeNT = Windows 9x/ME/NT/2000/XP/Vista/Windows 7/Windows 8 x86/Windows 8.1 x86/Windows 10 x86
Property(S): WindowsTypeNT40 = Windows NT 4.0
Property(S): WindowsTypeNT50 = Windows 2000
Property(S): WindowsTypeNT50Display = Windows 2000
Property(S): WindowsTypeNT5X = Windows XP/2003
Property(S): WindowsTypeNTDisplay = 32-bit Windows versions
Property(S): ErrorDialog = ErrorDlg
Property(S): INSTALLLEVEL = 3
Property(S): EnableUserControl = 1
Property(S): AppsShutdownOption = All
Property(S): PROMPTROLLBACKCOST = P
Property(S): ButtonText_Browse = Br&owse...
Property(S): ButtonText_Accept = &Accept
Property(S): ButtonText_Exit = &Exit
Property(S): ButtonText_Finish = &Finish
Property(S): ButtonText_Ignore = &Ignore
Property(S): ButtonText_Install = &Install
Property(S): ButtonText_No = &No
Property(S): ButtonText_OK = OK
Property(S): ButtonText_Remove = &Remove
Property(S): ButtonText_Repair = &Repair
Property(S): ButtonText_Reset = &Reset
Property(S): ButtonText_Retry = &Retry
Property(S): ButtonText_Yes = &Yes
Property(S): ButtonText_Decline = &Decline
Property(S): CtrlEvtChanging = Changing
Property(S): CtrlEvtRemoving = Removing
Property(S): CtrlEvtRepairing = Repairing
Property(S): CtrlEvtchanges = changes
Property(S): CtrlEvtremoves = removes
Property(S): CtrlEvtrepairs = repairs
Property(S): InstallMode = Typical
Property(S): InstallModeComplete = Complete
Property(S): InstallModeCustom = Custom
Property(S): InstallModeTypical = Typical
Property(S): Wizard = Setup Wizard
Property(S): Progress1 = Installing
Property(S): Progress2 = installs
Property(S): AiPrerequisitesColums = PrereqLabel,PrereqReq,PrereqFound,PrereqAction
Property(S): Text_Next = Next
Property(S): IAgree = No
Property(S): ButtonText_Back = < &Back
Property(S): ButtonText_Next = &Next >
Property(S): Text_Install = Install
Property(S): AI_CommitButton = ButtonText_Install
Property(S): CompleteSetupIcon = completi
Property(S): CustomSetupIcon = custicon
Property(S): MsiHiddenProperties = REDIS_PASSWORD_PROP
Property(S): DlgTitleFont = {\DlgFontBold8}
Property(S): ExclamationIcon = exclamic
Property(S): InfoIcon = info
Property(S): InstallerIcon = insticon
Property(S): RemoveIcon = removico
Property(S): RepairIcon = repairic
Property(S): UpDirIcon = Up
Property(S): NewDirIcon = New
Property(S): AI_LOG_CHECKBOX = 1
Property(S): AiStyleConditions =  
Property(S): TabBackground = tabback
Property(S): AI_BUILD_NAME = Workspace
Property(S): AI_BOOTSTRAPPERLANGS = 1033;
Property(S): AI_BOOTSTRAPPER_OPTIONS = h
Property(S): AI_BOOTSTRAPPERORIGINALLANG = 1033
Property(S): AI_PACKAGE_TYPE = Intel
Property(S): Intel = 23
Property(S): AI_EXE_EXTRACTION_FOLDER = [AppDataFolder]Ascensio System SIA\Workspace\install
Property(S): AI_EUIMSI = 1
Property(S): AI_FilesInsideExe = 1
Property(S): AI_SETUPEXEPATH = C:\ONLYOFFICE_Workspace_Win-install.latest.exe
Property(S): TARGETDIR = C:\Program Files (x86)\Ascensio System SIA\
Property(S): MsiLogFileLocation = C:\Users\ADMINI~1\AppData\Local\Temp\2\MSI8072.LOG
Property(S): AI_INSTALL = 1
Property(S): CustomActionData = C:\ONLYOFFICE_Workspace_Win-install.latest.exe
Property(S): AI_SETUPEXEPATH_ORIGINAL = C:\ONLYOFFICE_Workspace_Win-install.latest.exe
Property(S): ARPINSTALLLOCATION = C:\Program Files (x86)\Ascensio System SIA\
Property(S): SourceDir = C:\Users\Administrator\AppData\Roaming\Ascensio System SIA\Workspace\install\
Property(S): SystemFolder = C:\Windows\SysWOW64\
Property(S): TempFolder = C:\Users\ADMINI~1\AppData\Local\Temp\
Property(S): VersionNT = 1000
Property(S): RedirectedDllSupport = 2
Property(S): PreReqSearch_1 = 1
Property(S): PackageCode = {847DA0E8-8E12-4B98-8104-0397CF2DD6DB}
Property(S): ProductState = -1
Property(S): PackagecodeChanging = 1
Property(S): USERNAME = Windows User
Property(S): VersionDatabase = 200
Property(S): AIEXTERNALUI = 5
Property(S): EXECUTEACTION = INSTALL
Property(S): AI_MORE_CMD_LINE = 1
Property(S): ACTION = INSTALL
Property(S): AI_MISSING_PREREQS = ONLYOFFICE DocumentServer|ONLYOFFICE IIS Configure
Property(S): CLIENTPROCESSID = 6128
Property(S): SECONDSEQUENCE = 1
Property(S): CHAINERUIPROCESSID = 7348Chainer
Property(S): CLIENTUILEVEL = 0
Property(S): ADDLOCAL = ONLYOFFICE,ONLYOFFICEDocumentS,MainFeature,ONLYOFFICEIISConfi
Property(S): PRIMARYFOLDER = APPDIR
Property(S): ROOTDRIVE = C:\
Property(S): AI_PREREQFILES = C:\Users\ADMINI~1\AppData\Local\Temp\2\{808BA2F2-1208-4954-8796-7079616BC5A5}\onlyoffice-documentserver.latest.exeC:\Users\ADMINI~1\AppData\Local\Temp\2\{808BA2F2-1208-4954-8796-7079616BC5A5}\ONLYOFFICE.IIS.Configure.msi
Property(S): AI_PREREQDIRS = C:\Users\ADMINI~1\AppData\Local\Temp\2
Property(S): SETUPEXEDIR = C:\
Property(S): AI_LOGFILELOCATION = C:\Users\ADMINI~1\AppData\Local\Temp\2\MSI8072.LOG
Property(S): AI_FOUND_PREREQS = .NET Framework 4.8|Visual C++ Redistributable for Visual Studio 2013 x86|Visual C++ Redistributable for Visual Studio 2013 x64|Visual C++ Redistributable for Visual Studio 2015-2019 x86|Visual C++ Redistributable for Visual Studio 2015-2019 x64|SharePoint Server 2013 Client Components SDK x64|MySQL Connector/ODBC 8.0.21 x86|MySQL Installer Community 8.0.21 x86|MySQL Installer Community 8.0.21 x64 Runner|Node.js v12.18.0 x64|PostgresSQL v9.5.4 x64|Erlang v20.3 x64|RabbitMQ v3.7.4 x64|PostgreSQL ODBC Driver x64|Python 3.7.2 x64|Redis 3.0.504 x64|Java SE Runtime Environment 8u171 x64|Elasticsearch v7.9.0 x64|WinCertes v1.4.2 x64
Property(S): EXE_CMD_LINE = /exenoupdates  /forcecleanup  /wintime 1648383219  
Property(S): MsiSystemRebootPending = 1
Property(S): VersionMsi = 5.00
Property(S): VersionNT64 = 1000
Property(S): WindowsBuild = 20348
Property(S): PreReqSearch_9_1AiVerMin = 1.0.0
Property(S): ServicePackLevel = 0
Property(S): ServicePackLevelMinor = 0
Property(S): MsiNTProductType = 3
Property(S): WindowsFolder = C:\Windows\
Property(S): WindowsVolume = C:\
Property(S): System64Folder = C:\Windows\system32\
Property(S): RemoteAdminTS = 1
Property(S): ProgramFilesFolder = C:\Program Files (x86)\
Property(S): CommonFilesFolder = C:\Program Files (x86)\Common Files\
Property(S): ProgramFiles64Folder = C:\Program Files\
Property(S): CommonFiles64Folder = C:\Program Files\Common Files\
Property(S): AppDataFolder = C:\Users\Administrator\AppData\Roaming\
Property(S): FavoritesFolder = C:\Users\Administrator\Favorites\
Property(S): NetHoodFolder = C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\Network Shortcuts\
Property(S): PersonalFolder = C:\Users\Administrator\Documents\
Property(S): PrintHoodFolder = C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\Printer Shortcuts\
Property(S): RecentFolder = C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\Recent\
Property(S): SendToFolder = C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\SendTo\
Property(S): TemplateFolder = C:\ProgramData\Microsoft\Windows\Templates\
Property(S): CommonAppDataFolder = C:\ProgramData\
Property(S): LocalAppDataFolder = C:\Users\Administrator\AppData\Local\
Property(S): MyPicturesFolder = C:\Users\Administrator\Pictures\
Property(S): AdminToolsFolder = C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools\
Property(S): StartupFolder = C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup\
Property(S): ProgramMenuFolder = C:\ProgramData\Microsoft\Windows\Start Menu\Programs\
Property(S): StartMenuFolder = C:\ProgramData\Microsoft\Windows\Start Menu\
Property(S): DesktopFolder = C:\Users\Public\Desktop\
Property(S): FontsFolder = C:\Windows\Fonts\
Property(S): GPTSupport = 1
Property(S): OLEAdvtSupport = 1
Property(S): ShellAdvtSupport = 1
Property(S): MsiAMD64 = 23
Property(S): Msix64 = 23
Property(S): PhysicalMemory = 7719
Property(S): VirtualMemory = 4233
Property(S): AdminUser = 1
Property(S): MsiTrueAdminUser = 1
Property(S): LogonUser = Administrator
Property(S): UserSID = S-1-5-21-4095768159-4102115056-1141099337-500
Property(S): UserLanguageID = 1033
Property(S): ComputerName = WIN-AIPTS9R2I6B
Property(S): SystemLanguageID = 1033
Property(S): ScreenX = 1024
Property(S): ScreenY = 768
Property(S): CaptionHeight = 19
Property(S): BorderTop = 1
Property(S): BorderSide = 1
Property(S): TextHeight = 16
Property(S): TextInternalLeading = 3
Property(S): ColorBits = 32
Property(S): TTCSupport = 1
Property(S): Time = 16:14:32
Property(S): Date = 3/27/2022
Property(S): MsiNetAssemblySupport = 4.8.4161.0
Property(S): MsiWin32AssemblySupport = 6.3.20348.1
Property(S): MsiRunningElevated = 1
Property(S): Privileged = 1
Property(S): DATABASE = C:\Windows\Installer\6ea997.msi
Property(S): OriginalDatabase = C:\Users\Administrator\AppData\Roaming\Ascensio System SIA\Workspace\install\ONLYOFFICE_Workspace_Win-install.v22.01.654.msi
Property(S): UILevel = 5
Property(S): Preselected = 1
Property(S): SavedGamesFolder = C:\Users\Administrator\Saved Games\
Property(S): WindowsLibrariesFolder = C:\Users\Administrator\AppData\Roaming\Microsoft\Windows\Libraries\
Property(S): PublicDocumentsFolder = C:\Users\Public\Documents\
Property(S): PublicFolder = C:\Users\Public\
Property(S): UserProfileFolder = C:\Users\Administrator\
Property(S): CostingComplete = 1
Property(S): OutOfDiskSpace = 0
Property(S): OutOfNoRbDiskSpace = 0
Property(S): PrimaryVolumeSpaceAvailable = 217036232
Property(S): PrimaryVolumeSpaceRequired = 9760
Property(S): PrimaryVolumeSpaceRemaining = 217026472
Property(S): PrimaryVolumePath = C:
Property(S): SOURCEDIR = C:\Users\Administrator\AppData\Roaming\Ascensio System SIA\Workspace\install\
Property(S): SourcedirProduct = {808BA2F2-1208-4954-8796-7079616BC5A5}
Property(S): AI_CHAINER_CMD_LINE = IC:\Users\Administrator\AppData\Roaming\Ascensio System SIA\Workspace\install\ONLYOFFICE_ControlPanel_Win-install.latest.msiAPPDIR="C:\Program Files (x86)\Ascensio System SIA\\ControlPanel" API_SYSTEM_PORT="8081" CONTROL_PANEL_PORT="8082" MYSQLODBCDRIVER="MySQL ODBC 8.0 Unicode Driver" SERVER_PROP=localhost DATABASE_PROP=onlyoffice USERNAME_PROP=root PASSWORD_PROP=onlyoffice PORT_PROP=3306C:\Users\ADMINI~1\AppData\Local\Temp\CHAINERS_LOG\ControlPanel_Win-install.v22.01.654.logNVIC:\Users\Administrator\AppData\Roaming\Ascensio System SIA\Workspace\install\ONLYOFFICE_CommunityServer_Win-install.latest.msiAPPDIR="C:\Program Files (x86)\Ascensio System SIA\\CommunityServer" INSTALLATION_TYPE=Workspace DOCUMENT_SERVER_INSTALLED="TRUE" DOCUMENT_SERVER_PORT="8083" JWT_ENABLED="true" JWT_SECRET="sxkj1RvzaUaiZFyHrB5eHwynSioD53" JWT_HEADER="AuthorizationJWT" API_SYSTEM_PORT="8081" CONTROL_PANEL_PORT="8082" SSO_AUTH_PORT=9834 MYSQLODBCDRIVER="MySQL ODBC 8.0 Unicode Driver" SERVER_PROP=localhost DATABASE_PROP=onlyoffice USERNAME_PROP=root PASSWORD_PROP=onlyoffice PORT_PROP=3306C:\Users\ADMINI~1\AppData\Local\Temp\CHAINERS_LOG\CommunityServer_Win-install.v22.01.654.logNVIC:\Users\Administrator\AppData\Roaming\Ascensio System SIA\Workspace\install\ONLYOFFICE_XMPPSERVER_Win-install.latest.msiAPPDIR="C:\Program Files (x86)\Ascensio System SIA\\XMPPServer" INSTALLATION_TYPE=Workspace SERVER_PROP=localhost DATABASE_PROP=onlyoffice USERNAME_PROP=root PASSWORD_PROP=onlyoffice PORT_PROP=3306C:\Users\ADMINI~1\AppData\Local\Temp\CHAINERS_LOG\XMPPSERVER_Win-install.v22.01.654.logNV7348Chainer
Property(S): AI_MSI_CHAINER_CONDITION = 1
MSI (s) (58:64) [16:14:32:591]: MainEngineThread is returning 0
MSI (s) (58:1C) [16:14:32:591]: RESTART MANAGER: Session closed.
MSI (c) (F0:1C) [16:32:34:159]: Back from server. Return value: 1603
MSI (c) (F0:1C) [16:32:34:159]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (c) (F0:1C) [16:32:34:159]: PROPERTY CHANGE: Deleting SECONDSEQUENCE property. Its current value is '1'.
Action ended 16:32:34: ExecuteAction. Return value 3.
=== Verbose logging stopped: 3/27/2022  16:32:34 ===

MSI (c) (B4:54) [16:14:21:591]: Note: 1: 2205 2:  3: AI_TempFile 
MSI (c) (B4:54) [16:14:21:591]: Note: 1: 2228 2:  3: AI_TempFile 4: SELECT `Property` FROM `AI_TempFile` 
MSI (c) (B4:54) [16:14:21:591]: Note: 1: 2205 2:  3: AI_XmlLocator 
MSI (c) (B4:54) [16:14:21:591]: Note: 1: 2228 2:  3: AI_XmlLocator 4: SELECT `Property` FROM `AI_XmlLocator` 
MSI (c) (B4:54) [16:32:34:206]: Doing action: FatalError
Action start 16:32:34: FatalError.
Action ended 16:36:53: FatalError. Return value 1.
MSI (c) (B4:54) [16:36:53:466]: Doing action: AI_SHOW_LOG
Action start 16:36:53: AI_SHOW_LOG.
MSI (c) (B4:4C) [16:36:53:653]: Invoking remote custom action. DLL: C:\Users\ADMINI~1\AppData\Local\Temp\2\MSI2339.tmp, Entrypoint: LaunchLogFile
Action ended 16:36:53: AI_SHOW_LOG. Return value 1.
MSI (c) (B4:54) [16:36:53:809]: Doing action: FatalError
Action start 16:36:53: FatalError.
Action ended 16:36:53: FatalError. Return value 1.
MSI (c) (B4:54) [16:36:53:809]: Doing action: AI_CleanPrereq
Action start 16:36:53: AI_CleanPrereq.
MSI (c) (B4:B0) [16:36:53:856]: Invoking remote custom action. DLL: C:\Users\ADMINI~1\AppData\Local\Temp\2\MSI2492.tmp, Entrypoint: CleanPrereq
Action ended 16:36:53: AI_CleanPrereq. Return value 1.
MSI (c) (B4:54) [16:36:53:872]: Doing action: FatalError
Action start 16:36:53: FatalError.
Action ended 16:36:53: FatalError. Return value 2.
MSI (c) (B4:54) [16:36:53:872]: Note: 1: 2205 2:  3: Environment 
MSI (c) (B4:54) [16:36:53:872]: Note: 1: 2228 2:  3: Environment 4: SELECT `Environment`,`Component_` FROM `Environment` 
MSI (c) (B4:54) [16:36:53:903]: Destroying RemoteAPI object.
MSI (c) (B4:10) [16:36:53:903]: Custom Action Manager thread ending.
=== Verbose logging stopped: 3/27/2022  16:36:53 ===

Hello @Meron
We know about this issue (internal bug number - 52591). We are planning to fix it in Community server v.12
Workaround solution, use different Windows server OS (not v.2022).
Sorry for inconvenience.

1 Like

ok, too bad it is not working with the newest windows server :confused: . Anyway thank you for the fast reply!

Fresh installed Windows Server 2019 Standard. Installation worked without errors. But i can’t reach the OO Workspace over the shortcut / browser:

Fixed with:

Next problem:

I try to open a demo document or fresh created document:

I do install it on 2012 R2, I think maybe it’s your system environment.
When i installed ,it;s can’t auto install mysql ,so i installed Microsoft Visual C++ 2015-2022 x86/x64 manually , and mysql-connector-odbc-8.0.21 maybe need Visual Studio 2019 x64(I installed it manually )

and you must install Rewrite module for IIS as Carl told me, it’s can’t auto config.

When you setup to the prerequisites window , you can check what it requirement and check your control panel to find if all installed, If not you can install the requirement manually .

Before the install finished, you can find the requirement soft in the temp folder.

1 Like

Hello @Meron
Please try to follow these steps:

  1. Open local.json configuration file in C:\Program Files (x86)\Ascensio System SIA\DocumentServer\config and find the following sections:
"secret": {
        "inbox": {
          "string": "JWT_secret"

And

 "inbox": {
          "header": "JWT_header"
  1. Copy the values of the parameters “string” and “header” - the first one is a JWT secret and the second is a JWT header.
  2. Open web.appsettings.config in C:\Program Files (x86)\Ascensio System SIA\CommunityServer\WebStudio and find the following lines:
    <add key="files.docservice.secret" value="JWT_secret" />
    <add key="files.docservice.secret.header" value="JWT_header" />
  3. Compare the values of JWT_secret and JWT_header in both configs, they must be identical. If they do not match each other, please replace the values of JWT secret and header in local.json of the Document Server, save the file and restart all Document Server services in Windows Services tool.
    After that please let us know the result.

Thank you for the reply.
I had to change all three entries:

      "secret": {
        "inbox": {
          "string": "xxxx"
        },
        "outbox": {
          "string": "xxxx"
        },
        "session": {
          "string": "xxxx"
        }

After that, it worked. Thanks :)!

I have a few more questions, should i open a new thread?

I want to change the server to https with my already generated ssl certificate. I do not need a new generated one (with letsencrypt script), because it is used by other services too. Is there any way to set manually a ssl certificate?

This manual is not helpful in my case:
https://helpcenter.onlyoffice.com/de/installation/workspace-enterprise-https-windows.aspx

Edit:

ok i think i found the right manual:
Switching ONLYOFFICE Groups to HTTPS protocol - ONLYOFFICE (Part: Switching ONLYOFFICE Community Server version 8.5 and later to HTTPS manually). I will try it out tomorrow :).

That’s right. Please let us know the result of your attempt to switch portal to HTTPS via this guide.

Hi @Alexandre ! It worked, i have to export my letsencrypt certificate with the following command on my linux server

openssl pkcs12 -export -out wildcard.pfx -inkey privkey.pem -in cert.pem -certfile chain.pem```

After that i could import the wildcard.pfx to my windows 2019 server and import it into IIS Manager. One problem that occured is, that windows firewall blocks my https requests. I have to figure out where i have to set the new rule. (Edit: Fixed, added custom port rule in windows firewall)

Another two questions:

  1. How can i change the password of the Administrator Account of OnlyOffice? I can’t find it. I think i got something wrong by mixing up english / german keyboard layouts

  2. In the profile Tab (Admin) i can set my email (hotmail). It says, that an activation mail has been send. But didn’t receive any mail (checked junk / spam folder). Is there any proper configuration to do, to get it working?

One more question:

  1. After i switched to https the document server does not work properly. Do i have to change it to https too? The default adress of the document server is http://localhost:8083/
  2. The document server port (8083) should be open too in my router firewall?

Hello @Meron

  1. You should be able to do it via People module. Click on desired account > password change > the user will get email notification to change the password.
  2. Let’s check notification service in general first. Please go to portal settings > Integration > SMTP settings > click ‘Send Test mail’. Will you get the test mail?
  3. Please clarify what you mean by ‘ does not work properly’. Also how exactly did you change default Document server port?
  4. Yes. We have information about necessary ports here: Ports which must be opened for ONLYOFFICE Docs - ONLYOFFICE
    Firewall shouldn’t interrupt them
  1. I can’t find the “change password” entry?

Edit: I set up a gmail Account for the OnlyOffice Workspace Sever. It worked. After the confirmation of my private Mail Account i could finally change my password. So 1. and 2. is fixed :)!

I will reply later to 3. and 4.

For 3. (and 4.):

The problem started, after i changed the community server from http to https.

Now i also changed the documents Server nginx from http to https. Https works now on the welcome page of the document Server (working certificate).
I followed: Switching ONLYOFFICE Docs for Windows to HTTPS protocol - ONLYOFFICE
Hint: The mentioned paths in step 2. of the tutorial are not up2date.

old: %ProgramFiles%\ONLYOFFICE\DocumentServer\nginx\conf\ds-ssl.conf.tmpl
new: %ProgramFiles%\\Ascensio System SIA\DocumentServer\nginx\conf\ds-ssl.conf.tmpl

I opened the ports for Document Server and Community Server.

Community Server Settings for the Document Server:

If i try to open a document i always get Bad Gateway 502 errors in the Browser Console.
The document Server Url works fine (internal and external). It shows the welcome page of the document server.

I started the “Onlyoffice Document Server Example” Service. When i try to open the “GO TO TEST EXAMPLE” on the welcome page of the document Server i also got a bad gateway 502 error in the browser console.

Docservice logs are suspicious:

[2022-04-02T22:04:07.541] [WARN] nodeJS - Express server starting...
[2022-04-02T22:04:07.541] [WARN] nodeJS - Failed to subscribe to plugin folder updates. When changing the list of plugins, you must restart the server. https://nodejs.org/docs/latest/api/fs.html#fs_availability
[2022-04-02T22:04:07.557] [ERROR] nodeJS - [AMQP] Error: connect ECONNREFUSED 127.0.0.1:PORTCENSORED
    at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1148:16)

nginx.error.log

2022/04/02 23:26:53 [error] 6060#8688: *35 connect() failed (10061: No connection could be made because the target machine actively refused it) while connecting to upstream, client: IPadress, server: , request: "GET /favicon.ico HTTP/1.1", upstream: "http://127.0.0.1:8000/favicon.ico", host: "httpsdocumentserverurl", referrer: "httpsdocumentserverurl/ds-vpath"

I changed the ports for the document server and the community server, too.

HttpsUrlOfDocumentServer/ds-vpath → 502 Bad Gateway
HttpsUrlOfDocumentServer/web-apps/apps/api/documents/api.js → works

Any ideas? :slight_smile:

Sorry, if my advice was not clear.
Workspace (portal installation) is an all-in-one product. If you need your portal to run on https then you should obtain SSL certificate to portal. There’s no need to obtain additional separate certificate for Document server.
Moreover, there’s no need to change Document Service settings on the portal. Workspace is the out-of-the-box solution, it should work properly after installation.

I followed: Switching ONLYOFFICE Docs for Windows to HTTPS protocol - ONLYOFFICE

This is a guide for standalone Document server only.

After the all-in-one installation of Workspace:
Ok, so if i change the community server to https with a certificate, I dont have to change the document server to https manually too?

Ok, so if i change the community server to https with a certificate, I dont have to change the document server to https manually too?

That’s right. File editing should work properly when portal is switched to https, so no additional actions are needed.

Ok, i try to restore my changes for the document server and give a reply :slight_smile:

1 Like