Window usage on 4k monitor

Report a bug
OS version: Linux Mint 21.1 (Mate)
App version: 7.4.1 AppImage and Flatpak

I’m calling out 4k multi-screen desktops because it works fine on a single 1080p screen.

All apps (doc, ss, pp) work the same way including the initial open screen.

As you can see the app does not use the entire window that is called out from the window manager. And the usable space will scale proportionally to the window size, never using the whole window.

The computer is a Dell XPS laptop using GeForce RTX 3060 laptop GPU (v 525.125.06 drivers)

What’s going on here?

Hello @Pedulla

There is a newer version of Desktop Editors available, please update your app and check the situation again:

If issue reproduces after the update, let us know the exact scenario on how to reproduce the issue. Do I understand correctly that you have multiple screens and your main one is with FullHD resolution?

Thanks Constantine for getting back to me.
You are correct, 3 screens (3840x2400, 3840x2160, 3840x2160)
(Can only add one screen shot, so I saved it for later)

I’ve installed/tried the Snap from the Mint repository (Ubuntu), the AppImage from this site and the new 7.5.0 deb package from this site. They all exhibit the same behavior.

I included the desktop background so you can see the issue more clearly.
The application calls up a window of a certain size (dark gray area), but only uses a small portion of that window. If you resize the dark gray area the used space scales with it and never uses the whole thing. It’s as if the scaling math is wrong somewhere.

Additionally, if you grab the top control bar to move the window, as soon as the mouse moves, the application window jumps down and to the right by about the same proportion that the application window is off.

I’ve tried changing window managers (Metacity, Marco, Compiz) to further isolate the issue. The behavior is consistent with each.

Thank you for details. I’m looking for the solution. Once I get any news, I will provide an update.

1 Like

I’d ask you to provide some additional information on the issue:

  1. Model type of used external displays;
  2. Built-in display size (diagonal size);
  3. System interface scaling for each display;
  4. Interface scaling of Desktop Editors from Settings, e.g. Auto, 100%, 200%, etc.;

Also, I’d kindly ask you to record a video demonstration of the issue for better visual reference.

  1. Model type
    eDP-1 = Dell XPS-17 - 9720
    DP-2 = Dell P2723QE
    DP-5 = Dell U4320Q

2&3) Display sizes
~$ xrandr
Screen 0: minimum 320 x 200, current 11520 x 2400, maximum 16384 x 16384
eDP-1 connected primary 3840x2400+0+0 (normal left inverted right x axis y axis) 366mm x 229mm diag 431.7mm

DP-2 connected 3840x2160+7680+96 (normal left inverted right x axis y axis) 941mm x 529mm - diag 685mm

DP-5 connected 3840x2160+3840+96 (normal left inverted right x axis y axis) 597mm x 336mm - diag 1079.5mm


~$ xrandr --listmonitors
Monitors: 3
0: +*eDP-1 3840/366x2400/229+0+0 eDP-1
1: +DP-2 3840/941x2160/529+7680+96 DP-2
2: +DP-5 3840/597x2160/336+3840+96 DP-5

  1. Auto for each monitor

Video to follow…

Can’t upload… I’m still a “New User”
Lets try this: screen capture

Thank you for the details.

You did not specify scaling of Desktop Editors. Check it out in Settings tab of the app, under Interface Scaling drop-down and provide a screenshot too.

By the way, I’ve removed some unnecessary information.

It’s set to Auto, but is the equivelant to being set to 150%.

As I change the settings the whole window size changes accordingly and the used space in the window remains proportional.

Can you elaborate on this? What kind of equivalent you are referring to?

Can you record a demo of described behavior? I’ve increased your trust level so you should be able to attach small videos directly to the reply.

Video size limit reached.
Attaching another link. Screen Cap

Hello @Pedulla
If you don’t mind I will join to this thread too. Thank you for provided video file, we are already working on the described situation.

One more thing. Is the situation reproduced on all three monitors? Also, did you capture the video file from the main monitor (not external one)?

Yes. This situation is reproduced whether I move the app to an external monitor or it launches on that monitor.

Both video’s were captured from the main monitor.

Thank you for working on this.

Thank you, we ae looking into it.

Hello again @Pedulla

It’s been a while. Unfortunately, we didn’t manage to reproduce the issue yet so I’d ask you to provide few more details. But first, there is newer version of Desktop Editors is available, please update your app and check if behavior is changed.

If it isn’t, then try running the app without GPU acceleration, for that you need to:

  1. Open Run menu (Win + R);
  2. Type in "%ProgramFiles%\ONLYOFFICE\DesktopEditors\DesktopEditors" --disable-gpu;
  3. Run the command by pressing Enter and check if it changes anything.

Additionally, please let me know if there are multiple GPU’s in your set up. If there are, then share information about them (type, version).