When opening this file is an error

Hello everyone,

I have a problem with existing MS-Office files. If I open it, I always get this warning message! I found that this is due to the writing protection of the file when copying. Can I bypass the problem without taking out the writing protection manually?


I still found that the writing protection only comes with files from the NextCloud. If you copy a file from the cloud to the desktop for editing, the attribute writing protection is copied! This forces the user either to quit the error and then save a copy and then open and edit this copy or to intend or intersect the writing protection from the file.


Hello @zeroblue2005

If I understand your usage scenario correctly, you can try connecting your Nextcloud portal to Desktop Editors via Connect to cloud menu on the main screen.

Yes you understood it right! The workaround is also ok and works. But please pass on the error message as a bug to the development. When opening a document, the error message must not be displayed. It makes no sense and unsettled the user.

I’ve tried to reproduce the issue by creating random files in MS Office and Desktop Editors and setting writing protection to them. Then opened both files in Desktop Editors and instead of getting the error pop up I see next warning for both files:

Is it possible to share the document that you have problems with for analysis?

OK you have a privat Message for analysis the document

Thank you for the file.

Unfortunately, I wasn’t able to reproduce the issue with provided file.
I’ve simply downloaded the file, then opened it in Desktop Editors and didn’t face any errors.

Could you please try to open the file on any other PC in test purposes?

I’ve already tried that. Is on all computers Windows 10 + 11

Please confirm that you don’t have this file opened in any other editor at the moment of opening it in Desktop Editors.
Also, please download the file via provided link and check its properties - on my side I cannot see that file has writing protection enabled.

Have you tried to activate the file on your page as above in the picture and then open it?

No, I haven’t, since according to your initial message the file from Nextcloud downloads with enabled writing protection already.

That’s how I understood your scenario:

  1. You create a file locally on PC and then setting writing protection to it;
  2. Uploading resulting file to the Nextcloud portal;
  3. Downloading the file from Nextcloud and opening it via Desktop Editors.

In this scenario I wasn’t able to find the writing protection on the shared file thus didn’t see the error message.
Please confirm that I got it correctly.

I’m sorry that I speak such a bad English! The problem is not the writing protection! But it’s all about the error message. It is correct that a file from the cloud is opened with writing protection and also retained when copying and has something to do with certainty! But where does the error message come from? Have you understood my question now?

What causes the error message? This error message must not be displayed when opening a writing -protected file!

Please do not apologize.
I’m trying to find out the root of the issue too. Me and my colleague tried to share a protected document via Nextcloud and after download the document seems to have “blocked” attribute instead “protected”.
I was finally able to reproduce the issue by manually setting writing protection to the document and opening it in Desktop Editors after. We are checking the situation with this error. I will update the thread once any news come up.

I am happy to do that thank you

Hello again @zeroblue2005

Thank you for your patience.
I can confirm that this issue will be solved in future update.

Please accept my sincere apologies for the inconvenience caused.

1 Like

Thanks for your feedback! It was important to me to report the mistake! :slight_smile:

1 Like