Cloud Computing Insider Awards 2022: Vote for ONLYOFFICE
Vote for ONLYOFFICE

Weird Spellcheck bug on long document

Hello, first post here. A search of the forums did not return a similar issue.

I have a document of nearly 50K words, and at some point around 30K words, the United States English spell check started acting-up. This is the spellcheck plugin that shipped with the Linux desktop version of OnlyOffice.

Basically, the spellcheck recognizes a word that is spelled correctly as misspelled, and then suggests words that are nowhere near the correctly spelled word. For example, in my screenshot attached, you can see where I’ve spelled the word “do” correctly and the plugin suggests “especial” and “special.” I have tried deleting words and retyping them, and I have checked for special characters. Changing the type of English spellchecker momentarily fixes the problem, however the problem returns if I continue using South African English, for example.

OnlyOffice_Spellcheckbug

I have also tried breaking up the document by copy and pasting sections into a fresh DOCX, but the problem remains. I have not tried reproducing the problem in MS or Apple software yet, but it is something I am considering.

Has anyone seen a similar problem?

Thanks in advance for any response.

Hello @forrhead
is it possible to provide us with an example of the file where the issue reproduces? I believe that we have to take a closer look at the file.
If file contains sensitive information, please replace it with gibberish. Also you can send me a file via PM directly.