Meet ONLYOFFICE Docs Cloud, complete office software as a service
Meet ONLYOFFICE Docs Cloud

Vector object and how to add square and index symbols

When trying to copy a vector object from a finished document, it is inserted into a new document in the form of an incomprehensible angular spot. In Microsoft Word, this happens correctly.
Can you tell me how to add upper and lower case characters when editing formulas? (i.e. 2 squared; “B” with the index “bx”)? I never found this function in OF. In the products of other companies, this can be done in the main tab, on the buttons next to the fonts (in OF it is darkened at this moment and it is impossible to press it) or with the hotkey "CTRL + ‘+’ " (there is no such thing here).
In Only Office, I can’t edit ready-made formulas of the old MathObject3.0 format
. Can I make a single row of two or three pages when zooming out the document?
OS version: Win10x64
App version: 7.2
Downloaded from: ONLYOFFICE website
(upload://Pj82eH47Mi5NKaKSJCeSYziV1S.jpeg)

Hello @Prikolist2022
Would you mind providing us with details of the situation? If it’s possible record a videofile with comparison of mentioned scenario in our editor and other one. Also please provide us with a file where we can reproduce the situation and exact steps how to do it.

I don’t know how to upload a video file or DOC-file here so I did it with another site. There are two files in the archive: video and the text document that I tried to edit.
There I couldn’t add an object, edit the formula and to put an index or square sign in the formula. Microsoft Word does it correctly.

Sorry for bothering you, but we need a detailed description. I have compared file in our editor and MS 2013. As far as I see, MS recognizes that as formula, our editor as an image:

Please confirm that I understand the issue right.
As for other situations, ‘add an object’ and ‘put an index or square sign in the formula’ - we need a description and file example. I didn’t find these issues on the provided video.

By the way, there’s odd behavior on the video, when you had copied and pasted to second file, the copied data transforms to black square. I’ve tried to reproduce it, but without any result. Could you please re-install desktop editor and double-check that scenario?


I installed Only Office today on another notebook with Win8.1 on board (my main PC is with Win10). And I had the same problem. First 3-5 times it had been copied correctly but after the problem repeated. Try several times to push ‘copy-paste’ on different schemes. This case I described as “add an object” in the first message.
New video: TransFiles - бесплатный файлообменник без регистрации - Страница скачивания загрузки ktafy
About formulas: is this how it should be that formulas are recognized as images?
And when I create a formula in OnlyOffice I can’t set square index (see the screenshot or video).

Thank you for your description, we are checking the situation.

Thanks ).
Did you manage to repeat my problem?
And what about indexes in formulas and “formula as a picture”?

Did you manage to repeat my problem?

I was not able to reproduce the issue with black square, so I passed this case to QA team, we are checking the situation.

As for two other situations (formulas as a oicture and indexes in formulas), we are checking them too.
I’ll notify you when we have something to share.

Hello @Prikolist2022
We have added described issue to internal tracksystem (internal number - 59622), we have started working on it.

Great!)
What does this issue include? Only black square or ‘formula as imagine’ and putting little/big indexes too?

Hello @Prikolist2022
We have finished our checks. So, there’s the result:
‘formula as imagine’ issue is related to bug 59622.
‘black square’ issue. We have added a new bug (59629). We have started working on it too.

As for ‘putting little/big indexes too’. Our editor has the same behavior as MS Office. I have prepared a short demonstration how to use indexes: Monosnap