ONLYOFFICE 7.0: online forms, password protection in sheets, collaboration improvements and much more
ONLYOFFICE 7.0 released

Upgrade >> 7.x fails with remote postgresql

  • Document Server version: 6.4
  • Type of installation of the Document Server deb
  • ubuntu 20.04 lts
  • local webserver is apache 2.4, following config provided at https://github.com/ONLYOFFICE/document-server-proxy
  • ssl is added through a load balancer/ssl termination with haproxy

Upon upgrade to 7.x I see

setting up onlyoffice-documentserver (7.0.1-37) ...
psql: error: could not connect to server: Connection refused
        Is the server running on host "localhost" (::1) and accepting
        TCP/IP connections on port 5432?
could not connect to server: Connection refused

How can I manage a deb package upgrade on a dovserver system with a remote psql database?

Hello @thommie
Please clarify how exactly you set up remote PostgreSQL (the entire scenario). Which config files did you edit to achieve it?

Upon the first installation the database was created locally. I then duplicated it to the remote database cluster server and edited local.json accordingly.
If there are required changes for the database structure for the 6.x >> 7.x upgrade, it would be good to have them separately from the rpm upgrade process/scripting. At least optional.

Current version info (from https://download.onlyoffice.com/repo/debian)

Package: onlyoffice-documentserver
Priority: optional
Section: web
Installed-Size: 926263
Maintainer: Ascensio System SIA support@onlyoffice.com
Architecture: amd64
Version: 6.1.0-83

Please go to the host and run sudo debconf-show onlyoffice-documentserver.
Please show us the output result.

root@doc1:~# debconf-show onlyoffice-documentserver

  • onlyoffice/db-pwd: (password omitted)
  • onlyoffice/rabbitmq-pwd: (password omitted)
    onlyoffice/db-host: localhost
  • onlyoffice/jwt-enabled: false
  • onlyoffice/rabbitmq-user: rabbitmq
  • onlyoffice/jwt-secret: secret
  • onlyoffice/ds-port: 80
  • onlyoffice/cluster-mode: false
  • onlyoffice/db-user: onlyoffice
  • onlyoffice/docservice-port: 8000
  • onlyoffice/db-type: postgres
    onlyoffice/db-port:
  • onlyoffice/jwt-header: Authorization
  • onlyoffice/example-port: 3000
  • onlyoffice/rabbitmq-host: localhost
    onlyoffice/remove-db: false
    onlyoffice/db-name: onlyoffice

Thank you for provided information.

Please try to run the following steps:
echo onlyoffice-documentserver onlyoffice/db-host string <DB_HOST> | sudo debconf-set-selections - set the correct address of your database. After that try to run update process one more time.

Additional information about debconf options is here: Installing ONLYOFFICE Docs for Debian, Ubuntu, and derivatives - ONLYOFFICE

NB! As usual, we recommend to prepare whole server backup before server side actions.