Cloud Computing Insider Awards 2022: Vote for ONLYOFFICE
Vote for ONLYOFFICE

Unable to install on Debian

Trying to install with this guide Installing server version from RPM/DEB packages using the provided script - ONLYOFFICE

Here is the error:

# bash install-Debian.sh
Hit:1 http://download.onlyoffice.com/repo/debian squeeze InRelease
Hit:2 http://deb.debian.org/debian bullseye InRelease                                                   
Hit:3 https://d2nlctn12v279m.cloudfront.net/repo/mono/ubuntu xenial InRelease                           
Hit:4 http://deb.debian.org/debian bullseye-updates InRelease                                           
Hit:5 https://deb.nodesource.com/node_12.x bullseye InRelease                                           
Hit:6 https://artifacts.elastic.co/packages/7.x/apt stable InRelease                                    
Hit:7 http://security.debian.org/debian-security bullseye-security InRelease                            
Ign:8 https://download.mono-project.com/repo/debian stable-bullseye/snapshots/6.8.0.123 InRelease       
Hit:9 http://ftp.uk.debian.org/debian bullseye InRelease  
Err:10 https://download.mono-project.com/repo/debian stable-bullseye/snapshots/6.8.0.123 Release
  404  Not Found [IP: 152.199.19.161 443]
Reading package lists... Done
E: The repository 'https://download.mono-project.com/repo/debian stable-bullseye/snapshots/6.8.0.123 Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Using debian-11.1.0-amd64.

1 Like

Hello @selandrey
We know about this issue (bug number - 52361) and we are working on it. It’s related to Debian 11 only. The fix is planned to release in Community version v.11.6. Meanwhile, please use Debian v.10.

1 Like

14.02.2022 the problem is not solved!

Hello @lordalexnight
It should be fixed already. Please let us know your OS version and point me to the guide which you used.

hi,

i can confirm, this still doesn’t work.

Distributor ID: Debian
Description: Debian GNU/Linux 11 (bullseye)
Release: 11
Codename: bullseye

and I used this script: https://download.onlyoffice.com/install/install-Debian.sh

from this site: Installing server version from RPM/DEB packages using the provided script - ONLYOFFICE

We are checking the situation. I will update this post when I get any news.

1 Like

@Norbert @lordalexnight
Sorry about this situation. We made a mistake with scripts which you used for installation. We’re fixing it right now. I will notify you when I get any news.

1 Like

Install with Docker [Y/N/C]? N
Пол:1 … bullseye-security InRelease [44,1 kB]
Сущ:2 … bullseye InRelease
Сущ:3 … squeeze InRelease
Пол:4 … bullseye-updates InRelease [39,4 kB]
Сущ:5 … stable InRelease
Сущ:6 … xenial InRelease
Пол:7 … bullseye-security/main Sources [98,5 kB]
Игн:8 … stable-bullseye/snapshots/6.8.0.123 InRelease
Пол:9 … bullseye-security/main amd64 Packages [119 kB]
Пол:10 … bullseye-security/main Translation-en [76,8 kB]
Сущ:11 … bullseye InRelease
Ошб:12 https:// download.mono-project.com/repo/debian stable-bullseye/snapshots/6.8.0.123 Release
404 Not Found [IP: 152.199.19.161 443]
Чтение списков пакетов… Готово
E: Репозиторий «Index of /repo/debian stable-bullseye/snapshots/6.8.0.123 Release» не содержит файла Release.
N: Обновление из этого репозитория нельзя выполнить безопасным способом, поэтому по умолчанию он отключён.
N: Информацию о создании репозитория и настройках пользователя смотрите в справочной странице apt-secure(8).

5.10.0-11-amd64 #1 SMP Debian 5.10.92-1 (2022-01-18) x86_64 GNU/Linux

install Docker not work too. container restart every 60sec

install Docker not work too. container restart every 60sec

We know about it, we discussed docker installation here: Community server container keep restarting - #6 by Alexandre
We are working on the fix for docker installation for Debian 11 too (bug number - 53124)

Thanks!
I’m waiting for the opportunity to install onlyoffice rpm and docker

1 Like

Package installation on Debian 11 is fixed. Please check it out

1 Like

Package installation on Debian 11 is fixed.
Thanks!

1 Like