ONLYOFFICE Docs v6.4 with conditional formatting, new scaling options, and WOPI protocol support
ONLYOFFICE Docs v6.4 released

Unable to export calendar

Hello,
I am trying to export my calendar to a client (like calendar on Mac). I followed the indications given here
https://helpcenter.onlyoffice.com/userguides/groups-gettingstarted-calendar.aspx
I use the caldav link to synchronize the calendar. But when I enter my credential, I allways get a “authentification error” , and it keep asking for the password.
I am absolutely sure of my password.
I got the same behavior trying with Thunderbird.

I then tried to use the ical method.
But I definitely don’t understand the sentence:
" Follow the iCal link provided to save your calendar into a file in the iCal format with .ics extension on your hard disk drive"
I found a way, using Firefox. Right click and “save the target on disk”, and I manually put the extension .ics. But when I try to import this file, I got an error message “0 event imported. Unabled to treat the file” (I tried with Calendar for Mac, with Thunderbird and with Google Agenda). I tried to save the file with the extension .iCal, but without any success.
I opened the file with textedit, and the only thing inside is
“{“status”:0,“statusCode”:200,“response”:{}}”

Any idea ?
Thanks,
René

Hello!

Please find a correct instruction on connecting ONLYOFFICE calendar to Mac calendar:

  1. copy the entire link provided in the CalDAV section in ONLYOFFICE calendar;
  2. in Mac calendar open the dialog for adding a third-party calendar (Preferences > Internet Accounts > Add Other Account > CalDAV Account );
  3. select Account type: Manual ;
  4. in the Username and Password field enter Username and Password from your ONLYOFFICE portal ;
  5. in the Server Address field enter the link from the point 1, but without any protocols

Hi,
Thanks to answering my question.
I have tried your method.
But I obtain an error message “unable to check the account’s name or password”.
I am not sure of what you mean by “without any protocol”. I have pasted the entire link I obtained clicking on the button “copy” in the CalDAV section in OnlyOffice calendar.
For the name, I tried the email address I use to login on the portal, and my first name, then last name, without any success.
I checked twice the password is correct, using copy/paste of the password I use to login on the portal.
I have also tried the “advanced” settings, but I don’t know what to put as a port and as a path for the server.
Here is the content of the radicale.log file (for the time when I tried to connect the account on the Mac Calendar)

Blockquote
021-11-11 18:18:06,114 - [7f12939e1700] INFO: PROPFIND request for ‘/XXXXX@YYYYY-conseil.com@bureau.YYYYY-conseil.com/f9ce1fa8-f3ae-44a9-8a54-e2e5e7d61652’ with depth ‘0’ received from ‘2a01:cb19:150:e600:d4a5:46e9:29b8:8d02’ (forwarded by 127.0.0.1) using ‘Mac+OS+X/10.14.6 (18G9216) CalendarAgent/416.5.2’
2021-11-11 18:18:06,116 - [7f12939e1700] INFO: Rights: ‘’:‘XXXXX@YYYYYY-conseil.com@bureau.YYYYYY-conseil.com/f9ce1fa8-f3ae-44a9-8a54-e2e5e7d61652’ doesn’t match any section
2021-11-11 18:18:06,117 - [7f12939e1700] INFO: Rights: ‘’:‘XXXXXX@YYYYY-conseil.com@bureau.YYYYYY-conseil.com’ doesn’t match any section
2021-11-11 18:18:06,117 - [7f12939e1700] INFO: Access to ‘/XXXXX@YYYYY-conseil.com@bureau.YYYYY-conseil.com/f9ce1fa8-f3ae-44a9-8a54-e2e5e7d61652’ denied for anonymous user
2021-11-11 18:18:06,117 - [7f12939e1700] INFO: PROPFIND response status for ‘/XXXXX@YYYYY-conseil.com@bureau.YYYYY-conseil.com/f9ce1fa8-f3ae-44a9-8a54-e2e5e7d61652’ with depth ‘0’ in 0.004 seconds: 401 Unauthorized
2021-11-11 18:18:06,178 - [7f12939e1700] INFO: PROPFIND request for ‘/XXXXX@YYYYY-conseil.com@bureau.YYYYY-conseil.com/f9ce1fa8-f3ae-44a9-8a54-e2e5e7d61652’ with depth ‘0’ received from ‘2a01:cb19:150:e600:d4a5:46e9:29b8:8d02’ (forwarded by 127.0.0.1) using ‘Mac+OS+X/10.14.6 (18G9216) CalendarAgent/416.5.2’
2021-11-11 18:18:06,179 - [7f12939e1700] INFO: Auth token: ‘ASC radicale:20211111171806:zCR2syBjXD7+XPPEbPYFDI5MkLY=’
2021-11-11 18:18:06,179 - [7f12939e1700] INFO: Remote host: ‘bureau.YYYYY-conseil.com
2021-11-11 18:18:06,331 - [7f12939e1700] ERROR: Error login response: {‘value’: ‘false’, ‘message’: ‘Error: TrustFailure (Authentication failed, see inner exception.)’}
2021-11-11 18:18:06,331 - [7f12939e1700] INFO: Failed login attempt: ‘XXXXXX@YYYYY-conseil.com’
2021-11-11 18:18:07,829 - [7f12939e1700] INFO: PROPFIND response status for ‘/XXXXX@YYYYY-conseil.com@bureau.YYYYY-conseil.com/f9ce1fa8-f3ae-44a9-8a54-e2e5e7d61652’ with depth ‘0’ in 1.651 seconds: 401 Unauthorized
2021-11-11 18:18:07,888 - [7f12939e1700] INFO: PROPFIND request for ‘/XXXXX@YYYYY-conseil.com@bureau.YYYYY-conseil.com/f9ce1fa8-f3ae-44a9-8a54-e2e5e7d61652’ with depth ‘0’ received from ‘2a01:cb19:150:e600:d4a5:46e9:29b8:8d02’ (forwarded by 127.0.0.1) using ‘Mac+OS+X/10.14.6 (18G9216) CalendarAgent/416.5.2’
2021-11-11 18:18:07,890 - [7f12939e1700] INFO: Rights: ‘’:‘XXXXX@YYYYY-conseil.com@bureau.YYYYY-conseil.com/f9ce1fa8-f3ae-44a9-8a54-e2e5e7d61652’ doesn’t match any section
2021-11-11 18:18:07,891 - [7f12939e1700] INFO: Rights: ‘’:‘XXXXX@YYYYY-conseil.com@bureau.YYYYY-conseil.com’ doesn’t match any section
2021-11-11 18:18:07,891 - [7f12939e1700] INFO: Access to ‘/XXXXX@YYYYY-conseil.com@bureau.YYYYY-conseil.com/f9ce1fa8-f3ae-44a9-8a54-e2e5e7d61652’ denied for anonymous user
2021-11-11 18:18:07,892 - [7f12939e1700] INFO: PROPFIND response status for ‘/XXXXX@YYYYY-conseil.com@bureau.YYYYY-conseil.com/f9ce1fa8-f3ae-44a9-8a54-e2e5e7d61652’ with depth ‘0’ in 0.003 seconds: 401 Unauthorized

I don’t undestand these logs…
Could it be a problem of IPV6?

Regards,

Hello,
Please prove the server address link once again. It should be without https:// and start with portalname. If it doesn’t help, please send us screenshots or a video of your actions step by step and a screenshot of the error.

Hello Rene, you deleted .com in the server address link. It should be bureau.ixeo-conseil.com/caldav/

Hello Kate,
This was a trial. But I first used the full address without more success.
I desperately search for a solution. Thus I try everything I could imagine.

I did progress. Today, the link is functionning (I got a crash of my Mac, so something may have changed with reboot). So I have been able to load my calendar on my Android phone.
But a weird behavior: I have only the event I did create myself. All the event I have been invited at by a colleague are not on my phone.
I did the same with Calendar for Mac, and I obtained the same behavior.

I tried the method with the iCal link, but it doesn’t work at all. The file obtained with “save the target as” contains only one line with

{“status”:0,“statusCode”:200,“response”:{}}

Is there any way to synchronize all my events?
Thanks

Hello!
If you have several calendars in ONLYOFFICE you should import all the calendars one by one following the instruction above. You can’t add all the calendars in one operation.
An iCal link provides a read-only version of the calendar, the events won’t be editable.

Hello Kate,
Thank for answering my posts.
I had understood that, and I had no problem to synchronise my personnal calendar. My problem comes from the professional calendar, where I receive invitations from colleagues. Apparently the invitations I have accepted finally show up in my calendar. But after a very long time (more than a day). And the one I have not yet accepted don’t show up.
But, I did not have an answer at my other question. Why the file downloaded with the ical protocol is empty?

Hello!
Could you please please describe your actions step by step regarding both the cases:

  1. Explain how you connect Shared with me calendar to your third party app.
  2. Explain how you generate iCal link and where you open it to see this one line.

Hello Kate,
I will try to discribe my methods as clearly as possible. As my system is in French, I am not sure of the name of the menus in English…
1 to connect to Calendar for Mac using Caldav.
I click on the pencil appearing right of the name of the calendar I want to synchronise. A window opens, and at the bottom, I click on “Export and synchronize”. Another window open, with two links (the first one takes often some time to appear). I click on the “copy” button at the right of the first link.
In Calendar for Mac, I go to the menu “Calendar” and click on item “accounts”. A window open, I click on “add a new account” and then on “CalDAV account”. In the window which open, Capture d’écran 2021-11-24 à 21.33.59
I click on “manual”, and enter my email address I use to connect to OnlyOffice portal, the password to connect to the OnlyOffice portal, and the link I just copied. And in this line I manually remove “https://” at the beginning of the link. (cf. picture). And I click on “connect”.
But this process seems to work now. The only point is that it took more than one day to synchronise my calendar. The event I did enter myself appeared rapidely (a few minutes) but the event I have been invented to took more than one day.
The two following pictures show my OnlyOffice calendar for Monday 6/12 and the synchronized calendar on Calendar for Mac. You can see that the two events at 9:30 and 12:00 do not appear. I have been invited to these events. But the one in the evening, I have written myself appears in the synchronized calendar.

I have the same behavior on my Android phone (using DAVx5 to sync the calendar)

2 ) the ICal link. I open OnlyOffice portal in Firefox (not in Chrome). Same thing as previously, and in the window with the two links, I make a right click on the second link and click on “save the target of the link as”.
It takes a few second and I am proposed to save a file on my desktop. The file as a very long name, ending with .htm. I change .htm to .ics and save the file. It takes a long time to save this file. But it contains only 43 octets !
I then open the file with “textedit” and I can see it contains only one line reading
{“status”:0,“statusCode”:200,“response”:{}}

Hello Rene33.
As for iCal link you should just copy it from Export and Sync tab. Please describe situation in detail if I misunderstood it.
As for calendar sync issue. Could you please reproduce the issue (export calendar via CalDAV), check the issue > provide us with whole Community server logs folder.

Hello Alexandre,
Thank you for your answer.
For the CalDav problem (event recieved as invitation not synchronized)
Here is a link to the folder with the logs
deleted

For the iCal link, sorry I didn’t understand the advice for the iCal link. Once I have copied the link, what should I do with it? I have tried for instance to create a new calendar in a google calendar, chosing “by URL”, but nothing appears.

Some more details.
with CalDAV, I have observed that only the events starting from Sept 24 are synchronized.
I have tried to use the iCal link with another client (Mailo) and I obtain an error message (wrong format).

Thank you for provided logs.

As for iCal issue, please check it out:Calendar. Getting Started - ONLYOFFICE

You can copy necessary link or follow it to save your calendar into a file in the iCal format with .ics extension on your hard disk drive.

As for CalDav issue, is it possible to provide us with test account to your portal? So we are able to check it out on the spot. If so, please contact me via PM.

Hello Alexandre,
I did send you a PM.
For iCal issue, I am sorry, but I don’t understand how I can save a link into a file. That is what I have tried, and described before. When (using Firefox) I click on “save target of link as” I obtain a file with only one line: “{“status”:0,“statusCode”:200,“response”:{}}”
If I put the URL in the address line of the browser, I obtain at the best the same line or an error message.

Hello Rene33.
Thank you for access to your portal. We found a match with the known bug (bug number - 53817). We are working on it. The fix will be released as a part of the next Community server version (v.11.6).