Unable to customize Table of Contents on Windows 10 (Works without issues on Mac)

Hello everyone,

I’m unable to customize my table of contents in any way on the Windows 10 Version.
I followed the steps listed in the official user guide to no avail.
No matter what i try, the table of contents always resets to the default settings when i update it. Choosing any of the available styles (simple, standard, classic, etc.) does absolutely nothing, it always reverts to “Current”.

I tried doing the exact same thing on my Mac and funnily enough it works without issues there.

I imported the working ToC from my Mac to my Windows PC, which looks like this:

When i open up a fresh document on my Windows PC it keeps looking like this (I can’t post another picture because of the restrictions):

Test1___________1
Test2___________1
Test3___________1
Test4___________1

(I hope you get what i mean. It always displays without indentation)

I’m assuming this either has to be some kind of bug in the Windows Version or I’m doing something wrong.

Either way I’m thankful for any help.

OS: Win 10
App version: 8.1.0.169 (x64 exe)

Hey @ThommyGhun :hugs:

If you can, please attach a video showing the issue you encountered.
I’ve granted you some additional permissions to add multiple photos.

However, remember that you can always include a link to photos/videos or an archive from an external storage.

Hello @Nikolas !

Thanks for your reply.

In the first video i created a new file on my Win10 PC. Editing the table of contents is not possible, it always resets itself. I tried switching styles too, also not working.
(Both recordings got cut off near the bottom unfortunately, sorry about that)

The next video shows a file i created with Onlyoffice on my Mac. I then sent that file to my Win10 PC and tried to do the same thing, which worked without problems.

I don’t know if that’s a problem on my end or some kind of bug in the Windows Version of Onlyoffice

(Offtopic but i also encountered a bug regarding copy/paste within multilevel lists that crashes the document every time. Should i open a new thread about this?)

1 Like

@ThommyGhun :vulcan_salute:
Thank you for providing the videos. We will try to reproduce the issue. If we need additional information, we will reach out to you.

I will keep you updated on any progress.

Thanks again!

1 Like

Yes, it would be better to create a new topic :slight_smile:

It seems like this has already been fixed with the latest version :star_struck:

My problem with ToCs still persists sadly, but maybe you guys can figure something out :brain:

Hello @ThommyGhun :upside_down_face:

We have reproduced the issue you mentioned and will make every effort to fix it in the upcoming version 8.2.0.

We will notify you as soon as the version with the fix is released. :handshake: