ONLYOFFICE 7.0: online forms, password protection in sheets, collaboration improvements and much more
ONLYOFFICE 7.0 released

The “documentType” parameter for the config object is invalid. Please correct it

Hi guys,

I run the OO Document Server as a Docker Container in combination with Nextcloud, mariadb and redis on my unraid server. Until now, everything worked fine, but after upgrading OO app to version 7.2.0 in nextcloud, I get the following error:

The “documentType” parameter for the config object is invalid. Please correct it.

This error occurs as a browser notification when I try to open any type of document. The only way to get OO working again is to restore a backup of the appdata. In the logs of nextcloud no error occurs due to this.

Unfortunately, I’m not the only one with this error, as you can see here and here.

Can anyone help with this?

Thank you in advance!

Maginos

Hello Maginos. Sorry for the late reply.
Please provide us with additional information about:

  1. Version of Document server and Nextcloud version.
  2. Please reproduce the issue with open browser console:
  • Open browser console (for example, F12 in Chrome) → choose ‘Network’ tab in browser console → reproduce the issue → check if there are any error entries in console and send us a screenshot;
  • Choose ‘Console’ tab in browser console → reproduce the issue → check if there are any error entries in console and send us a screenshot.
  1. Provide us with whole Document server logs folder. It’s located here: /app/onlyoffice/DocumentServer/logs/documentserver/

Hi Alexandre and thank you for your reply.

I’m sorry for the inconvenience, but I solved the problem on my own. I found out, that I was using an older version of the document server (5.5.0.165) from a different repository and after upgrading to the official docker container (from Siwat2545’s Repository), I can upgrade to OO 7.2.0 in Nextcloud without any issues.

The unraid version is 6.9.2, NC version is 22.2.0, OO document server version is 6.4.

Maginos

We are glad that the issue is solved.

Indeed, the issue was related to old version of Document server. You can check changelog here https://github.com/ONLYOFFICE/onlyoffice-nextcloud/releases

Connector no more longer supports old version od Document server (v.6.0 and older).

By the way, you mentioned Siwat2545’s Repository. Please note, there’s our official repository Docker Hub

This issue is not solved for paid Integration Edition docker users. That docker hub image hasn’t gotten updates in over a year.
https://hub.docker.com/r/onlyoffice/documentserver-ie

I made an issue in github.

Nevermind, I didn’t get the message to use documentserver-ee, will do so.

Hello mxroo. That’s right, There was a rebranding. The old images (onlyoffice-documentserver-ie) no more supported.
Official repository for commercial version: Docker Hub

Hi Maginos!

May I ask how you did this? I’m on the same environment and tried to simply edit the docker configuration and changed it to Siwat2545’s repository. Unfortunately that now leads to the error message that onlyoffice is currently not available. No difference whether I call it using the local IP address or the external URL (with Swag as reverse proxy).

Petjek

Hi Petjek,

I compared the Host Ports and Paths and they are they same for both containers (chvb/onlyofficedocumentserver:latest and onlyoffice/documentserver), so that should fit. Nevertheless, I would put the Documentserver from chvb to another network and download and configure the documentserver from Siwats Repository (as an alternative you can try to use the documentserver from docker hub directly) the same way as for the container from chvbs repository. The change of network is necessary, that you don’t have two DS on the same network. You should also stop the DS from chvb, so that you don’t have port conflicts on the host.
After the config, start the container and check the logs. If everything seems to be ok, try to access the DS via https://internal_ip:HTTPS_PORT. Ignore the browser warning and check if you can see the page from DS which says “ONLYOFFICE Docs Community Edition installed”. If this works, check if you can access via dyndns and then it should also work in NC.

Good luck!

Maginos