The delusion of trying OnlyOffice

Dear OnlyOffice developers,

I spent nearly ten days trying to make your product works in sight of a professional use and these are the points I realized:

  1. OnlyOffice is an heavy and complicated product, badly documented with outdated online documentation; none of your procedures are applicable to the actual version;

  2. I tried to install OnlyOffice behind an IPv4 proxy to reuse an IPv4 (static addresses are expensive when available!) - You don’t provide any indication of how to perform such configuration and OnlyOffice appears to be unusable even with all the 80 & 443 ports forwarded; what other ports should be forwarded? Documentation doesn’t report anything; the only clue I had a “protocol error” the broswer report when opening a document for editing;

  3. I installed OnlyOffice on an IPv6 capable exposed host, with the same result: OnlyOffice simply hung, with showing blank pages, no error at all, nor on the log nor on the user’s page; ok, not all the software are ready to perform under IPv6;

  4. Finally reinstalled under Debian and on an exposed IPv4 host - No way!! The installer script is unable to download repositories signatures from ubuntu repos; you know the problem and you’re working on it, but I’d like to test OnlyOffice NOW, so I decided to…

  5. Install on a CentOS host; the first run of the installer stopped with a repository error (again??) but the second run succeeded; wow! I have OnlyOffice running, cool! I receive the invitation to strenghten my installation (exactly what I want to do) going from http to https; perfect! I have my own certificates that I renew once for all my infrastructure! I follow the related document and…

  6. All my installation gets corrupted because the nginx config template seems a mixup of docker + bare metal installation; I don’t need to add another virtualization layer (docker) on my virtualization layer (qemu) so I really need a bare metal install; hopefully because I’m 52 and I know the value of a backup I restore the previous setup from my backup;

  7. Ok I really need to go https! It’s imperative! So I go to the https pane of the control panel to see… “oh sorry! If you need to go https you have to run these script to generate [another] let’s encrypt certificate” - Ok let’s go! Script runs with no error - but please specify that I have to indicate the fqdn of the instance of OnlyOffice! Nevermind, now the certs are there so…

  8. Let’s edit my first document: Impossible! The nasty message “The document cannot be saved” pops up every time I begin editing a document! No more please! No more!

  9. I don’t want to waste more time! I remember other products like ProxMox, OwnCloud, DokuWiki and GitLab that went online flawlessy and still run! Why not OnlyOffice?

Some design concerns:

  1. You have to choice for a DB? You choiced Postgree? Cool! Please, is there any reason to install mySQL and redis? There is no reason to install THREE DIFFERENT data base engines on a single host!! Why this incredible waste of resources?

  2. I tried to run a yum update and a series of update error appeared about broken packages: Do you mean that I cannot update my linux box with OnlyOffice installed?

Again, no more please! No more! :frowning:

Also buying a commercial subscription I’m sure will not change the soul of the product. As a software and validation engineer I strongly believe that OnlyOffice needs a strong re-engineering to enlighten the design (three databases!!!) and to drastically improve the documentation!

Once the customer sees that OnlyOffice works with no bullshits can think about buying support license when the game become hard and the business must run, not earlier.

As always I’m available for any face-to-face discussion with your team or any other help I can give to a promising project to improve or test documentation, but at this stage I cannot trust OnlyOffice anymore!

With deep regret.

Hello @fpiraneo
It’s really sad that you faced some issues during your tests.
Let’s figure out what exactly goes wrong.
First of all, please let us know your OS and point me to the guide which you used for installation process. Also please clarify if you use clean separate server for Workspace (I mean there are no other installed apps).
You mentioned proxy in front of Workspace (in this topic and others). Does the issue reproduce without proxy server in front of Workspace?
As for three databases in Workspace installation. We are working on it already. There’s internal suggestion number 51841 (add Postgre support to Community server, so Document server will use the same database as Community server, as for Redis, it performs separate tasks).

As for the situation in general, please reproduce it and provide us with detailed description of each issue (issue scenario step by step with screenshots and necessary logs from Document server and Community server). I believe that we can resolve all of them together.

Good afternoon,

  1. I tried OnlyOffice on both CentOS Stream 9 and Debian 11;
  2. The guide I followed can be found here workspace-install-linux
  3. The installation has been performed on a qemu virtual host, a new clean linux instance, up to date, all dedicated to OnlyOffice;
  4. I tried both with a proxied installation and with an exposed host with a public IPv4 address: Quite same result; focusing on the exposed (not proxied host) the instance was a CentOS 9 Stream and worked fine until I installed the https certificates; so with http OnlyOffice seems to works correctly but I really need an https!

At this stage and with the fire of angry I destroyed my OnlyOffice installation; I’m going to replicate it (CentOS 9 Stream, clean installation, exposed host, http); waiting for your consideration on what written above; then what I need is a clear procedure to go https with my own certificates (domain wide certificate released by Let’s Encrypt).


PS about the installation guide I followed - bullet 2 - a popup appeared when posting the reply: “You cannot post a link on this site”.

Update: Rolled back the CentOS 9 Stream installation from a backup and here is the behaviour when I open a document with https: the document opens but an error popup appears.

After dismissing the popup the document is closed.

To enable https I followed the instructions here:

(cannot post a link on your forum)

Any suggestion is welcome.

(Cannot put three screenshots in one post… :frowning: )

Any indication on that? Any checklist? Any idea?

I can’t open this link, please point me to the guide.

At this stage and with the fire of angry I destroyed my OnlyOffice installation; I’m going to replicate it (CentOS 9 Stream, clean installation, exposed host, http); waiting for your consideration on what written above; then what I need is a clear procedure to go https with my own certificates (domain wide certificate released by Let’s Encrypt).

Let’s try from scratch. Please follow this guide and install Workspace with installation script: Installing server version using the provided script - ONLYOFFICE
You can choose docker or package installation during the installation step.

Docker installation contains the opportunity to get Let’s Encrypt certificate from Control Panel:

For package installation, you have to follow this guide to switch portal to https: How to switch your office to HTTPS when installing from RPM/DEB packages? - ONLYOFFICE

Update: Rolled back the CentOS 9 Stream installation from a backup and here is the behaviour when I open a document with https: the document opens but an error popup appears.

We have to take a look at Document server logs folder. Please reproduce the issue and provide us with whole logs folder. It’s located here: /var/log/onlyoffice/documentserver/

Hi Alexandre, thanks to ChatGPT that pointed me on the right direction, yesterday evening I solved the issue; Under Setup >> Integration >> Document Service the parameter “Community Server address for requests from the Document Service” must be changed manually to the https FQDN. After that it worked as expected.

I hope that no more changes has to be performed to have OnlyOffice fully functional; however I expect that the installation script does this automatically or an indication appears that I have to do this by myself.

However, the task to update the linux box once OnlyOffice is still open: this is the result when I perform a yum update:

An hint to solve this is welcome.

Hello @fpiraneo
Please keep in mind that there’s hard dependency on component versions of Workspace. We do not recommend its manual update.
For Workspace update we recommend to use installation script with -u true flag: Installing server version from RPM/DEB packages using the provided script - ONLYOFFICE
If you’re going to update other packages\OS itself, please do not touch Workspace related packages.

Alexandre, the problem is that I cannot update anything on my linux box if OnlyOffice is installed because yum refuse to update everything! Yum seems broken!

because yum refuse to update everything! Yum seems broken!

Please run a test. Run yum update command one more time, but specify package which you want to update. Please do not try to update all packages because you can interrupt Workspace.
You might as well prepare whole server backup before any server side actions just in case.

Same here, tried docker and rpm/deb versions.
I have the same opinion about the complex code base and multiple databases and nested virtualization methods…

I was so excited to become a partner/reseller, but with all this complexity I doubt it would be accepted by medium/large companies…

Like the author, I’ve been trying to get this working for days…

ATM, there’s a ubuntu 22.04 install without the mail component running… let’s see if this will work…

Here’s what happened when I tried docker install

./ line 108: [: missing `]'
Setting up swapspace version 1, size = 6 GiB (6442446848 bytes)
no label, UUID=fb085cb3-9310-4f78-a424-3a0eb915a5c4
/usr/bin/jq: line 1: html: No such file or directory
/usr/bin/jq: line 2: syntax error near unexpected token `<'
'usr/bin/jq: line 2: `<head><title>301 Moved Permanently</title></head>
Docker pull argument exception: repository=onlyoffice/documentserver, tag=

At first attempt, had to fix line 108 … missing ] , but docker install failed.

I’m an experienced sysadmin and I never struggled this much trying to get a software working

We’ve been using our own self hosted instance of OnlyOffice (OO) for a number of years now. It’s not been without extreme frustrations and challenges, but once you get it going, it does work pretty well.

Originally tried to run it on Ubuntu behind an nginx proxy. Eventually found there’s a bug specific to Ubuntu installs.

Then went to Windows Server behind a proxy. That worked. Until an OO update broke the proxying. I eventually got recommendations on what to change in nginx to get it to work. At that point we had already migrated to a cloud server, on Windows Server, to get around the proxy issues. I don’t know if the recommendations worked or not.

Since then I’ve run into countless issues with upgrades breaking the install. In most cases I eventually figure out what the install breaks, and tell OO support about it. The issues still aren’t fixed, well over a two years later. I just know I have to update a log of config files I have to manually upgrade after an upgrade to get it working again.

There are also some really weird rules, such as the author of a document is the only one who can delete it. But any other properly permissioned user can edit it? And the calendar has major issues with repetitive events. Again, not fixed well over two years later. And there are some odd sharing “features” as well. Email support (non server) was always a joke as well; again, never fixed.

Right now the current version of Community Server upgrade (12.5.1228) fails hard, rendering my instance unusable. Sadly I expect this type of thing anymore with upgrades, and I always thoroughly test in a local virtual machine before I consider applying it to our production instance.

It appears that OO is a small, bordering on VERY SMALL, organization that is not capable of testing their upgrades in a robust manner. I’d imagine their pay-to-host version probably works fine? I’ve asked this type of question many times “how/why did you not catch this in your testing before you released it???” and never get a straight answer. I also have to question their statement about millions of users. That said, they don’t say what type of user?

Now, all that said, we are VERY GLAD we are found and are able to use OO as our centralized document repository and centralized calendaring system. We all know how to work around the quirks and hope that some day OO gets their act together and fixes some of the glaring issues with the product.

My fear is to spend too much time to go deep into the product and find the same issues community version has in the enterprise version. That would be a no-go as a partner/reseller.

I’ve just managed to get it working under ubuntu 22 packages install. It requires an apt-get upgrade and reboot prior to running the install script to avoid apt lock issues.
I was hoping to get it working under docker to create a setup to use in kubernetes later…
As you’ve stated, it really looks smooth once installed.

BTW @charles , have you got a wiki/list of the issues you’ve faced so far and its fixes?

1 Like

Hello, would love to see it working in kubernetes, if you manage to make a working deployement please share !

Hello @msilveira @charles and @fradarr
First of all, we always appreciate any feedback on our products. It helps us to build the better apps.
@charles you mentioned some issues which were passed to support. If any of them cause concern, please contact me via PM, I’ll check out issues which you reported.

@msilveira We are glad that you have successfully installed Workspace. I’ve noticed that you’re looking for Kubernetes, please keep in mind that we didn’t test Workspace on Kubernetes, so we cannot predict possible issues. But we have ready-to-go guide for Document server:
Anyway, please feel free to share your experience and ideas.

Hi, no, I have not created a wiki or blog or the like for this.

I’ve contemplated doing this type of things to share my experiences with different technologies with the world, however in today’s litigious society, I didn’t wish to deal with any potential “cease and desist” requests. And it takes time and money to do, and I’m a fervent believer that ads are a curse of the internet.