Cloud Computing Insider Awards 2022: Vote for ONLYOFFICE
Vote for ONLYOFFICE

Spell check language changing back to English

This bug happens after changing document language or paragraph/text language. As soon as you start typing, it changes back to English. When you create a new line/paragraph, it changes back to desired language, but when you continue typing, it changes to English again.

This is really annoying and makes spell checking in other languages almost unusable. The only way to use spell checking is to select all the text after writing and set language, but even then it keeps changing to English if you continue.

Steps to reproduce:

  • Create new document
  • Change document language or paragraph/text language to something other than English
  • Start typing
  • (you’ll notice that language in status bar changes back to English)
  • Go to new line
  • (language changes to language that you set before)
  • Continue typing
  • (language changes to English again)

This happens only on desktop version (not in browser), but it happens on both offline and cloud documents. If you edit the same document from a browser and desktop editors at the same time, only desktop is constantly changing to English.

OS: Windows 10
Onlyoffice version: 7.0.1.37

2 Likes

Hello @Toaster,

We are currently analyzing this issue and will keep you posted about the results.

1 Like

Hello @Toaster,

To avoid problems with spellchecker language change you can set “Spelling language detection” setting to Disabled in the Settings menu of the application.
Hope it solves your problem.

Same problem here for the same versions. It would be great to be able to keep writing in the same language the paragraph was in.
Thanks for your work :heart_eyes_cat:

1 Like

Hi! I have the same problem, and is really annoying this kind of issue. Could be excellent if you fix this bug.

Hello @jesusdicen and @rlacroix
As far as I understand @Constantine provided a solution in the previous post.
If I misunderstood the situation, please clarify it.

Could not find said setting but since then I lost access to my windows laptop so cannot answer sorry.

You will find this option here: