Spell check does not work for OnlyOffice docs 7.1 in Spanish language

I am testing OnlyOffice Desktop Editors 7.1 in Spanish. I found a problem in the OnlyOffice Spanish Text Document Editor. When I write text in Spanish, I test the program and I type words that contain misspellings errors expecting the application to mark those incorrect words with a red underline. That’s where the failure occurs. The misspelled words in Spanish are not underlined with red color and so clicking with the right mouse button on those misspelled words I could find options to correct them but OnlyOffice 7.1 is flawed in this item.
OnlyOffice should have a solution for this bug including the use of all Spanish keyboards, not only for Spain but also the Spanish keyboards for Latin America as LibreOffice does in Spanish.
In OnlyOffice 7.0 a ticket or requirement 31412 was created because the spelling correction for the Spanish version was working with many limitations. Later they reported that this issue had been resolved but that is not true. In OnlyOffice 7.1 in Spanish not only the problem was not corrected but the solution disappeared completely and users are forced to stop using OnlyOffice 7.X in Spanish and migrate to LibreOffice 7.3 in Spanish.

OS version: Windows 10 (64 bits) in Spanish.
App version: Text Document Editor in Spanish
Keyboard Layout: Spanish - Colombia.
Downloaded from: ONLYOFFICE website.

Hello @Albaco69

Please make sure that you performed the following actions:

  • Selected the language Español (España, alfabetización internacional)
  • Activated the spell checking option (File > Advanced Settings > tick Spell Checking)

If it doesn’t help, please send us

  • the screenshot of the Advanced Settings where the Spell Checking option is activated
  • the screenshot that shows how a misspelled word looks like in your document.

Hi, I’m having the same problem (OnlyOffice 7.3.3). Spell Checking is activated, Español (España, alfabetización internacional) is selected. Misspelled words are not highlighted.

Hello @Diaboliquin
I took a quick look at this test and it looks OK:

Spellchecker marks incorrect words. Please provide us with additional information: your OS, Desktop Editor installation type (point me to the guide which you used for installation). I performed the test from the screenshot on Windows 11.

Hi, thanks for answer.

OS: Windows 10 22H2
OnlyOffice 7.3.3 exe file.
Installation path: C:\Program Files\ONLYOFFICE\DesktopEditors

I tried reinstalling (uninstalled OnlyOffice, deleting all user preferences/cache) to not avail.

Could you please run a test? Remove contents of this folder from your PC: C:\Users\User\AppData\Local\ONLYOFFICE\DesktopEditors\data\cache
After that please re-install desktop editors and re-check the situation.

Thanks, it worked. Now there is another problem, I changed the language to "“Español (España, Alfabetización Internacional)” so that the spell checker works but when I type something new the status bar changes to “Español (México)” so the spell check is disabled. Ah, too much hassle. Thanks for taking the time to solve this.

Could you please reproduce this situation and record a videofile? Does the issue reproduce with any file (new file) or specific one only?

not working for me in English. I tried reinstalling and deleting cache from app data but still doesn’t work.

Hello @sadmansaji2003
Sorry for the late reply. I don’t see document language and spellchecker status on your screenshot. I mean this:

Please reproduce the situation and make a screenshot of entire editor.