Meet ONLYOFFICE Docs Cloud, complete office software as a service
Meet ONLYOFFICE Docs Cloud

Speech plugin settings dropdown is empty in Linux Manjaro

This is on my online, only office account and my desktop app as well, using Linux Manjaro KDE Firefox 103.0.2, also did not work in Chrome, in settings it has a dropdown, it is empty, and it is not working after highlighting text and pressing start, so I guess this is why. I set media.webspeech.recognition.enable to true with no help, I have a Read Aloud plugin for Firefox that works fine, does anyone know how to fix this?

Hello @flesh
Please clarify the product you are using. Personal (https://personal.onlyoffice.com/), Workspace, stand-alone Document server?
Also point me to the guide which you used for plugin installation.

As for the issue in general, please check that issue reproduces in different browsers (also, try to clean browser cache and cookies).
Also please make a screenshot of the issue.

I am using Personal, and Workspace online at onlyoffice

I tried Firefox, Chrome, and Brave, but only in Opera do I get something in the box, but it does not work.

For my Desktop, I used this Plugin guide ONLYOFFICE Api Documentation - Adding plugins

This works fine in Windows, just not Linux Manjaro.

Thanks

Thank you for provided details. We are checking the situation. I will update this post when we have something to share.

Hello,
could you please check if there are fresh updates for your Manjaro installation? After an update please re-check the issue.
Also please clarify the guide which you used for Desktop Editors installation.

This is Arch Linux Manjaro KDE, it is a rolling release, and always up to date by default, it checks for updates on boot, and as far as I know, OnlyOffice comes preinstalled, and is in the main repository.

I opened a ticket at Manjaro Forum, I do have Speech working in Libre Office, OnlyOffice Speech plugin settings drop down is empty, not working - Software & Applications - Manjaro Linux Forum

Hello @flesh
We ran a few tests and figured out few things.

About Google Chrome (AUR) browser. The plugin should work with that browser out-of-the-box without any additional actions. Could you please try to reinstall Chrome and re-check the situation?

About Firefox browser. Manjaro OS uses ‘voices’ as default speech synthesis system. For some reason, Firefox doesn’t work properly with that system on Manjaro.
Workaround solution is installation different speech synthesis system (for example, festival or espeak-ng) and set it as default system.
Useful links:
text to speech - How can I change the voice used by Firefox Reader View (Narrator) in Ubuntu? - Ask Ubuntu (this guide is related to apt commands, so you need to use pacman)
Arch Linux - espeak-ng 1.51-1 (x86_64)

About Opera browser. It looks like this browser doesn’t support speech synthesis system on Manjaro.

As for Desktop Editors, we are still checking the situation. I will update this post when we have something to share.

One more thing. Could you please run a test? Please remove your pre-installed Desktop Editors app and try to re-install it via flatpak\snap. We have necessary guides here:
https://helpcenter.onlyoffice.com/installation/desktop-install-flatpak.aspx
https://helpcenter.onlyoffice.com/installation/desktop-install-snap.aspx

Will the situation change?

Flatpak did not help, and snap is a read-only file system, so the plugin would have to be installed by default.

I installed festival and speech-dispatcher
sudo pacman --noconfirm --needed -S festival festival-english festival-us speech-dispatcher

I edited speechd.conf
sudo gedit /etc/speech-dispatcher/speechd.conf;
Uncomment the line AddModule “festival” “sd_festival” “festival.conf”
Add the line DefaultModule festival and commented out espeak.

Now it works for Firefox

You have to install one of the speak engines

#AddModule “espeak” “sd_espeak” “espeak.conf”
#AddModule “espeak-ng” “sd_espeak-ng” “espeak-ng.conf”
AddModule “festival” “sd_festival” “festival.conf”
#AddModule “flite” “sd_flite” “flite.conf”
#AddModule “ivona” “sd_ivona” “ivona.conf”
#AddModule “pico” “sd_pico” “pico.conf”
#AddModule “espeak-ng-mbrola-generic” “sd_generic” “espeak-ng-mbrola-generic.conf”
#AddModule “espeak-mbrola-generic” “sd_generic” “espeak-mbrola-generic.conf”
#AddModule “swift-generic” “sd_generic” “swift-generic.conf”
#AddModule “epos-generic” “sd_generic” “epos-generic.conf”
#AddModule “dtk-generic” “sd_generic” “dtk-generic.conf”
#AddModule “ibmtts” “sd_ibmtts” “ibmtts.conf”
#AddModule “cicero” “sd_cicero” “cicero.conf”
#AddModule “kali” “sd_kali” “kali.conf”
#AddModule “mary-generic” “sd_generic” “mary-generic.conf”
#AddModule “baratinoo” “sd_baratinoo” “baratinoo.conf”
#AddModule “rhvoice” “sd_rhvoice” “rhvoice.conf”
#AddModule “voxin” “sd_voxin” “voxin.conf”

#DefaultModule espeak-ng
DefaultModule festival

festival sounds better than espeak or espeak-ng, you can test;
spd-say “Hello. How are you?”
espeak “Hello. How are you?”
echo “Hello. How are you?” | festival --tts

I am getting closer, but still need to get the app to work.

Do I understand it right that plugin works in Firefox now? As for Desktop Editors, could you please re-install Desktop Editors one more time and make screenshots on each steps (whole flatpak installation scenario)?

I did something to break the browser, it was working, I have been doing so many things trying to get this to work, that I broke Pulse a few times, got pipewire to work, broke it, bake to Pulse.
I might need to reinstall Manjaro KDE just to get back to where it was, but I do not think this is the issue.
I uninstalled the default version that comes stock in Manjaro KDE
I installed using flatpak

sudo flatpak install flathub org.onlyoffice.desktopeditors -y;
Looking for matches…
Required runtime for org.onlyoffice.desktopeditors/x86_64/stable (runtime/org.freedesktop.Platform/x86_64/21.08) found in remote flathub
org.onlyoffice.desktopeditors permissions:
    ipc      network      pulseaudio      wayland     x11     devices     file access [1]     dbus access [2]
    [1] /tmp, host, xdg-config/gtk-3.0
    [2] org.gtk.vfs.*
        ID                                        Branch           Op           Remote            Download
 1. [✓] org.freedesktop.Platform.Locale           21.08            i            flathub              17.7 kB / 325.8 MB
        ID                                        Branch           Op           Remote            Download
 1. [✓] org.freedesktop.Platform.Locale           21.08            i            flathub            17.7 kB / 325.8 MB
 2. [✓] org.freedesktop.Platform                  21.08            i            flathub            87.7 MB / 200.4 MB
 3. [✓] org.onlyoffice.desktopeditors             stable           i            flathub           437.2 MB / 546.5 MB
Installation complete.

install plugin

if [ -d ~/Downloads/OnlyOffice/Plugin-Speech ]; then rm -rf ~/Downloads/OnlyOffice/Plugin-Speech; fi
mkdir -p ~/Downloads/OnlyOffice/; mkdir -p ~/Downloads/OnlyOffice/Plugin-Speech/; cd ~/Downloads/OnlyOffice/Plugin-Speech/
git clone https://github.com/ONLYOFFICE/plugin-speech
cd ~/Downloads/OnlyOffice/Plugin-Speech/plugin-speech/
zip -r plugin-speech.plugin *
rm -rf ~/Downloads/OnlyOffice/{D71C2EF0-F15B-47C7-80E9-86D671F9C595}
cp -r ~/Downloads/OnlyOffice/Plugin-Speech/plugin-speech/ ~/Downloads/OnlyOffice/{D71C2EF0-F15B-47C7-80E9-86D671F9C595}
sudo cp -r ~/Downloads/OnlyOffice/{D71C2EF0-F15B-47C7-80E9-86D671F9C595} /var/lib/flatpak/app/org.onlyoffice.desktopeditors/x86_64/stable/active/files/bin/opt/onlyoffice/desktopeditors/editors/sdkjs-plugins/

Global speech dispatcher

cat /etc/speech-dispatcher/speechd.conf
LogLevel  3
LogDir  "default"
DefaultVolume 100
# currently supported: MALE1, MALE2, MALE3, FEMALE1, FEMALE2, FEMALE3,
DefaultVoiceType  "MALE1"
DefaultLanguage "en-US"
SymbolsPreproc "char"
SymbolsPreprocFile "gender-neutral.dic"
SymbolsPreprocFile "font-variants.dic"
SymbolsPreprocFile "symbols.dic"
SymbolsPreprocFile "emojis.dic"
SymbolsPreprocFile "orca.dic"
SymbolsPreprocFile "orca-chars.dic"
AddModule "festival"                 "sd_festival"  "festival.conf"
DefaultModule festival
LanguageDefaultModule "en"  "festival"
Include "clients/*.conf"

Local speech dispatcher

cat ~/.config/speech-dispatcher/speechd.conf
LogLevel  3
LogDir  "default"
DefaultRate   0
DefaultPitch   0  
DefaultVolume 100
DefaultLanguage   en
AudioOutputMethod   pulse
DefaultModule   festival
Include "clients/*.conf"
/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=desktopeditors --file-forwarding org.onlyoffice.desktopeditors @@u %U @@
Gtk-Message: 11:18:36.726: Failed to load module "xapp-gtk3-module" [*1]
Gtk-Message: 11:18:36.726: Failed to load module "canberra-gtk-module" [*2]
Gtk-Message: 11:18:36.759: Failed to load module "window-decorations-gtk-module" [*3]
Gtk-Message: 11:18:36.760: Failed to load module "colorreload-gtk-module" [*4]
QXcbConnection: XCB error: 8 (BadMatch), sequence: 16059, resource id: 90179683, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 16068, resource id: 90179683, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 16071, resource id: 90179683, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 16117, resource id: 90179683, major code: 130 (Unknown), minor code: 3

  1. github /linuxmint/xapp/commit/e846e76a392d44d211b7007691358f173f1b44a3
  2. bugs.archlinux /task/23655

cat $HOME/.gtkrc-2.0
gtk-enable-animations=1
gtk-primary-button-warps-slider=0
gtk-toolbar-style=3
gtk-menu-images=1
gtk-button-images=1
gtk-cursor-theme-size=24
gtk-cursor-theme-name="breeze_cursors"
gtk-icon-theme-name="breeze"
gtk-font-name="Noto Sans,  10"

gedit ~/.gtkrc-2.0
append

gtk-enable-event-sounds=true
gtk-enable-input-feedback-sounds=true
gtk-sound-theme-name=freedesktop

wiki.archlinux title Libcanberra

sudo systemctl restart canberra-system-bootup.service
sudo systemctl enable canberra-system-bootup.service
sudo systemctl status canberra-system-bootup.service

sudo pacman -S libcanberra gsound vala gjs perl-glib-object-introspection python-gobject
yay -S lua-lgi-git ruby-gir_ffi
echo $GTK_MODULES
canberra-gtk-module
  1. github tauri-apps tauri issues 3715
  2. github tauri-apps tauri issues 3715

These are all Warnings and not an issue, so the app runs without errors.

I am only allowed two links as a new user, so I had to obscure them.

Thanks, Flesh

I switched back to Linux Mint, the browser works, sounds like a robot, but the app does not, flatpak install, the same issue, so I am going to look into speech-dispatcher and try to figure this out, but the bottom line is, unless you want to pay for Swift Cepstral voices, you will not like it much, so have to learn to live with this and use Windows version to get a better voice, but I still want to get this working, because I want to use Swift, and it is an option in speech-dispatcher.

speech-dispatcher is causing all kinds of crackling issues, I have to disable it when not using it, there is a bug report for it, so I am like everyone else waiting for it to get fixed.

I would like to know if anyone using Linux has this working, what distro, and how, but we all know how the voices sound, like a robot, but Only Office is awesome, and getting Read Aloud to work, is what makes it awesome, it was the only reason I have MS Word, so this is an important feature regardless of how it sounds, there are better voices out there, and those out there will improve in time.

We are still checking the situation with Desktop Editors, I will update this thread when we have something to share.

Hello @flesh
Sorry for the late reply.

We have checked the situation and we added a bug to internal tracksystem (internal number - 59565). We have started working on it.
Thank you for pointing us to this situation!

Good to hear, now if we can just get someone to make an AI TTS.

Thanks, Flesh

I believe that the issue will be resolved, when we figure out what is the reason of such behavior. I will update this thread when we have something to share.
Thank you one more time.