Cloud Computing Insider Awards 2022: Vote for ONLYOFFICE
Vote for ONLYOFFICE

Slow work in local onlyoffice workspace community edition

Hello!

I decided to try to deploy a server based on Ubuntu 20.04.3 LTS your onlyoffice workspace community edition.

Worked well for several months.
Recently made some minor changes to LAN addressing.

Found a serious problem with onlyoffice workspace. When working in a local network, accessing the onlyoffice workspace resource by IP address, even by http, even by (SSL) https, it slows down a lot. Slow response. Ping and traceroute are fast and the web interface is slow to open with long delays.

But if you access via the Internet using an external IP address, or using a domain name with SSL https and without it, via http it works quickly, without problems.

I do not understand where to dig, where to look for the cause.
As I wrote above, the only thing I changed in the local network was addressing.

Was - 10.10.0.0/20
Now - 100.10.0.0/20

The onlyoffice workspace address has also changed accordingly. Didn’t make any more changes.

Before that everything worked well.
Other resources of a similar nature continue to work on http and https without any problems.

Help please, what can affect the speed of work?

Thank you very much in advance!

Best regards, Sergei.

Hello @s.timofeev
Is there proxy server\firewall in front of Workspace? Probably the issue is related to network rules. Could you please reproduce the issue and record a videofile? Also please check Network and Console tabs in the browser console. Make screenshots of error entries in those tabs.