Meet ONLYOFFICE Docs Cloud, complete office software as a service
Meet ONLYOFFICE Docs Cloud

Set default spelling language and turn AutoCorrect off

Hi! I just set up the community edition on my home server and I am impressed by the relatively simple setup, thanks to the install script!

Maybe I’m just dense, but I cannot find a way to set a default spelling language! Every time I, or anyone else, create a new document, it starts with English. Since this document server will be used by non-techies, I can’t train them to change this to Norwegian for every new document they make. The same goes for AutoCorrect, which messes up allot when writing in Norwegian – I want to turn this off for all new documents by default.

I am pretty sure I have hunted trough every setting there is, so if anyone could point me in the right direction to achieve these seemingly simple things, I will be very thankful!

Hello @rsolva

Do you use ONLYOFFICE Document Server in integration with any storage app? Like Nextcloud, ownCloud or else.

No, it is a clean docker install (without the email server) of the Workspace community edition.

Sorry for the late reply.

Unfortunately, you cannot change spelling default language since it is based on the language of the document. Workspace uses certain templates for every new document and these templates are corresponding to the language of the portal.
You can use customized document templates as a workaround solution in this case. First, you have to create new document templates:

  1. create new empty files of docx, xlsx and pptx formats and set the language to the desired one;
  2. save them with next names new.docx, new.xlsx and new.pptx.

Now connect to your Community Server container and get to next folder /var/www/onlyoffice/WebStudio/Products/Files/DocStore/new/
In this folder you will see different catalogs containing templates for every language of the portal. Open the folder with the language that you are using on your portal, for example, English (United States) is en-US (to check it out click on your name > Profile), and replace existing files with recently created ones.
From that point, when user creates new document the Document Server will use these templates for every new document so the language will be set to the document by default.

Note that if your users are using different languages of the portal (they can be set for each user personally) then you will have to replace templates in each folder that is corresponding to the used on the portal language.

1 Like

I have tried to connect to the Community Server docker container, but do not get an interactive session when using docker attatch. I also tried to do a docker cp using the path you mention, but it did not work.

To connect to the running container you can use command docker exec -it <ID> bash where <ID> is the ID of Community Server container. To see the list of running containers use docker ps.

It didn’t work out because this is not complete path. As I mentioned it before inside of /new/ catalog are located language based folders each containing templates for specific language. So if you want to change templates for English (United States) language you will have to replace them in next folder:
/var/www/onlyoffice/WebStudio/Products/Files/DocStore/new/en-US/

1 Like

Thanks for your patience! I got the file in place and the default spelling language is now Norwegian :+1:

Unfortunately, the settings to turn various AutoCorrect-features off did not follow the file, but I see that it does not automatically capitalize the “I” when the Norwegian spelling is active, which is the most important thing.

Thank you so much for all the help!

Auto-Correct settings are stored in Document Server, not in the document. So if you want to change them please open your editor, navigate to the File tab → Advanced SettingsProofingAutoCorrect Options. After setting up do not forget to tap on Apply button so save the changes.

As for the capitalization issue: I wasn’t able to reproduce the issue myself with given description so could you make a video demonstrating the problem? If not then please provide a detailed scenario on how to reproduce it so we can run some tests and check out the situation.

I guess this then applies pr user?

It is not an issue when the spelling language is set to Norwegian, so no problem there, luckily!