Restoring Saas version on local machine

Dear All! Could you please help me.
Recently I’ve installed workspace community version on my Ubuntu 22.04 vm. HW spec 8 vCpu, 16 Gb ram+ 200 gb Ssd. I’ ve installed onlyoffice via script without docker.
Next I downloaded backup from saas
Version and tried to recover via admin or control panel.
Sometime system shows unknown error during recovery process. Latest recovery procedure sad that recovery completed, but I cannot see any files on documents area.

Main target of this activity is to download all files ~ 70 gb to external hdd and provide to the customer as second backup.
So they have two questions :

  1. how to recover or migrate all documents from saas to on-prem
  2. how to download all files to external drive in some automated way ? Thank you very much!

Hi @Migre,
There are some issues with restoring the backup file of a cloud portal on the server version of Workspace at the moment, we are actively working on a fix. Once the fix is available, we will notify you.

Could you please specify if the backup you created at Workspace Cloud included mail? If yes, please try creating a backup without including mail and then restore it on the server. Let me know the results.

Dear Carl!
Thank you for your reply, we do not use mail in our cloud portal. So our backup do not contain mail files or configs.
Should I try again restore same backup file or create new and download to new on-prem server?

Could you please create a new backup file, restore it on the server and send me the log file svcBackup.log from the directory /var/log/onlyoffice/ if the issue is reproduced again?

sure, backup process has been started, its takes 3-4 hours 74 (74Gb) and ~ 5 hours to download, so tomorrow - Ill give you feedback. Thank you!

Dear @Carl
Restore failed again
Here is log from on-prem installed portal:
2024-05-22 22:00:30,051 ERROR [27] ASC - Unknown block type 7

Restoration process quite strange:

  1. I`ve downloaded backup from online portal to VM (on-prem)
  2. on first stage it`s just copy file from separate disk to /var/www/onlyoffice/data/temp/backup and shows Restore Completed successfully - but there no data on portal
  3. next I`ve press Restore again - and process started again, but behavior was different - portal shows Restoration in progress and portal goes to inaccessible for the users
  4. after couple hours - again Restore completed successfully, but still no data on portal, folder /var/www/onlyoffice/data/temp - consist of two folders - backup file and folder called p4fazzc
    in this folder we have 2 sub-Folders :
    databases and files
    drwxr-xr-x 10 onlyoffice onlyoffice 4096 мая 23 00:46 .
    drwxr-xr-x 4 onlyoffice onlyoffice 4096 мая 23 00:46 …
    drwxr-xr-x 2 onlyoffice onlyoffice 4096 мая 23 00:46 calendar
    drwxr-xr-x 2 onlyoffice onlyoffice 4096 мая 23 00:46 community
    drwxr-xr-x 2 onlyoffice onlyoffice 4096 мая 23 00:46 core
    drwxr-xr-x 2 onlyoffice onlyoffice 4096 мая 23 00:46 crm
    drwxr-xr-x 2 onlyoffice onlyoffice 4096 мая 23 00:46 files
    drwxr-xr-x 2 onlyoffice onlyoffice 4096 мая 23 00:46 files2
    drwxr-xr-x 2 onlyoffice onlyoffice 4096 мая 23 00:46 projects
    drwxr-xr-x 2 onlyoffice onlyoffice 4096 мая 23 00:46 webstudio

in files folder - we have a lot of file_xxyyzz folder - seems it is from backup.

but still we do not have files on web-portal.

Please provide the previously requested log file (attach it as a file to your message).

Sorry, but new users cannot upload attachments ))

but, there are not any new lines there, only one and I`ve copied it in previous message.

Please create a zip archive of the whole directory /var/log/onlyoffice/, upload it to some hosting and send me the download link.

Could you please try to open the backup file with any archive utility (e.g. 7zip)? Can it be opened correctly with no errors? We suppose the backup file is corrupt in your case.

@Carl yes, I did this before restoration via 7z - everything is fine

Could you please make a screenshot of the file’s content?

do you have something to restore manually without web interface and rich logs ?

For Docker installation, situation a little bit different:

Once Restore progress bar goes to 100% system refreshes page and that is all, not popup about Restoration process completed successfully or other messages.
bunch of log files from docker here: - Google Drive

the second strange issue is that portal still accessible for the users:
on separate tab of my browser I can open portal and get access to the files.
so I think restoration process did not started and system tries only copy file from disk to docker and that is all.

WOW! finally, I able to restore backup to docker version of portal

it`s takes 2,5 hours, what I did:

  1. upload backup file to Documents module and than moved to Common,
  2. Restore from Common folder
  3. Reset password.