Need dedicated support? Click here
Need dedicated support?
Click here

Removing ONLYOFFICE Docs for Linux ubuntu 20.04

galiaf@galiaf-HP-Notebook:~$ sudo apt purge onlyoffice-documentserver
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  gconf-service gconf-service-backend gconf2-common libgconf-2-4 pwgen supervisor
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
0 upgraded, 0 newly installed, 1 to remove and 7 not upgraded.
1 not fully installed or removed.
After this operation, 1 270 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 225359 files and directories currently installed.)
Removing onlyoffice-documentserver (7.2.2-56) ...
dpkg: error processing package onlyoffice-documentserver (--remove):
 installed onlyoffice-documentserver package post-removal script subprocess returned error exit status 1
dpkg: too many errors, stopping
Errors were encountered while processing:
Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)

Please tell me how to fix the error.

Hello @galiaf,

The error message is indicating that there was an issue with the removal of the “onlyoffice-documentserver” package. The post-removal script of the package has returned an error with exit status code 1, and as a result, the package removal process has been stopped. To resolve the issue, you can try the following steps:

  • Try to remove the package again using the following command:

    sudo dpkg --purge --force-remove-reinstreq onlyoffice-documentserver

  • If the above step doesn’t work, you can try to manually remove the package and its dependencies using the following command:

    sudo dpkg --remove --force-all onlyoffice-documentserver

  • Finally, run the following command to clean up any remaining dependencies:

    sudo apt autoremove

Let us know about the results.

NB!: Before trying these steps, it is recommended to backup or snap any important data or files.

Hello. I already tried these steps. Output result

Hello @galiaf

Sorry for the late reply.

We’ve tried to reproduce the situation, but it seems that the issue is related to your server\dpkg only. I’m not sure that we can provide support for this situation, but I believe you have to start your research with dkpg issue.

I’m facing the same issue, and its your requirement that did say to use a vps. Provide an answer that makes sense for license users

Hello @mnplus
The mentioned error entries as provided by topic starter are dpkg related in general, please check out this thread: apt - E: Sub-process /usr/bin/dpkg returned an error code (1) dpkg error - Ask Ubuntu
It seems that the situation is related to your OS\installed packages.