ONLYOFFICE Docs v7.3 released: enhanced forms, SmartArt, new security settings, Watch Window, and more
ONLYOFFICE Docs v7.3 released

Removing Cloud Server

ONLYOFFICE Mobile: Documents
Do you want to: Ask a how-to question
Device: iPhone 12
OS version: iOS 16.2
App version: 7.2
Mode: Connect to Cloud


I had a catastrophic failure on my Nextcloud server, and had to rebuild it from scratch. I am still using the same domain and logins.

However, when trying to connect to my newly rebuilt Nextcloud server, the Documents app still recognizes my old server, and throws the error “The operation couldn’t be completed. (FilesProvider.FileProviderWebDavError error 1.)”

I have tried uninstalling and reinstalling the Documents app, but it continues to recognize my old server. I’ve also tried to add it as a new Nextcloud Server, and I am able to add my subdomain and enter my login credentials, but I still end up with the same error.

Is there a way to remove an existing cloud account that I am missing? I’ve looked everywhere I can think of in the app.

Hello @johnnyboricua

First of all, please try clearing cache of the app before trying again: go to Settings > Storage section > tap on Cache and confirm the removal. Then if it does not help please try to sign in via username and password of the Nextcloud, not with the mail address or vice versa if previously used mail.

Let me know if it helps in the first place.

Thanks for the suggestions. I tried again this morning, and I uninstalled the app and made sure to delete all data, as iOS doesn’t seem to have an option to delete the cache that I can see. However, it still shows up with an account there.

I then tried logging into a new Nextcloud account, using the username and password, not email, as suggested. It allows me to put it in, but since the username is the same as the existing one, it doesn’t add a new account, and presents the same error.

I realized that it might be trying to connect using the caldav or carddav account I am using for contacts or calendar. I uninstalled the app again, ensuring I told it to delete all data, and disconnected from caldav and carddav accounts and tried again, but it is still showing the same thing.

It seems like the app should have the ability to disconnect from an existing cloud service, shouldn’t it?

Sorry for the late reply.

Please try connecting with this scenario:

  1. Remove all Nextcloud servers from the My clouds list;
  2. Clear the cache of the Documents app in Settings > Storage section > Cache:
  3. Close the app;
  4. Launch it again and try to log in.

If it does not allow you to do it, please record a video demonstration of the issue and provide a version of Nextcloud portal that you are trying to add to the list of storages.

I’m sorry, perhaps I was not clear as to what my issue is. Your first step above requires me to remove the server, which is my whole issue. I am not able to locate that option in the iOS app. I fully recognize this might be user error, so could you help me find it?

Please accept my apologies for misleading.
Try to do next actions:

  1. Open the app and proceed to the Clouds menu;
  2. In the list My clouds find Nextcloud portal that you want to remove;
  3. Swipe to the left on this portal to expose “Delete” button and remove the portal from the list:

Please let me know the result.

Thank you so much! I feel silly for not attempting to swipe the account previously. Deleting out the account and signing in to the account again corrected the issues, and I have tested accessing and editing different types of documents. This has resolved my issue.

Thanks again!

1 Like

That’s not a problem. I’m glad to hear that the issue is resolved after all.
Please feel free to contact us if you face any other issues.