[Question] Apply new settings(local.json/default.json) in Onlyoffice Doc in Windows version

Hello, my Windows Server 2016 have installed Onlyoffice Document Server

And my server would like to change settings in default.json for:

  1. Increase file size limitation (maxDownloadBytes)
  2. Set timeout for preventing user locking file data (sessionidle)
  3. Allow request from self signed certificate (rejectUnauthorized)

After I updated these setting and restart following service:

  1. ONLYOFFICE DocumentServer-IE Converter (DsConverterSvc)
  2. ONLYOFFICE DocumentServer-IE DocService (DsDocServiceSvc)
  3. ONLYOFFICE DocumentServer-IE Proxy (DsProxySvc)
  4. ONLYOFFICE DocumentServer-IE Spellchecker (DsSpellcheckerSvc)

The updated setting still not applied in Onlyoffice, may I know that is that still have another service needed to restart for applying new setting? Thanks!

Hello Qyinx.

Restarting the specified services should be sufficient for the changes to be applied.

However, I noticed a few oddities. You are using an old unsupported version of DS (DocumentServer-IE, ‘Integration Edition’). There was rebranding a year ago. Now we provide support only for a new version of the product (ONLYOFFICE Docs).

In this situation, I recommend you to update to ONLYOFFICE Docs Enterprise Edition if you have commercial license or to Community Edition if you prefer to use open-source one. There’re the guides:



NB! We strongly recommend to prepare whole server backup before update process.

After that please reproduce your actions and let us know the result.

Hi Alexandre, thank you for responding.
Yes, we also planning to upgrade the Onlyoffice Document server in near future(already have license and testing), due to importance we need to change following settings first.

In final, some of settings are applied the setting by restarting Onlyoffice services without restart windows server.
**It is noticed that documentserver-prepare4shutdown.bat need to excute first otherwise editing data may get lost.

By the way, no matter how decrease or incrase limit on following settings but nothing happened:
In previous time due to this behavior, I just thought updated settings not applied.

Hello Qyinx.

Please try to run a test. Rename the extension of your test file to .zip and open the archive to see the unzipped size of the file’s xmls and resources. Now you know what value is needed for uncompressed setting (inputLimits).

But general recommendation is the same as before at the moment. Please update your Document server first.