Cloud Computing Insider Awards 2022: Vote for ONLYOFFICE
Vote for ONLYOFFICE

Problem with tables after upgrading from version 6.0

Good afternoon, after updating the document server to version 7, I got glitches :frowning:
there is a macro:
value_number = value_number.replace(/\s/g, “”); from cell should remove all spaces previously worked
had to change to this value_number = value_number.replace(/[^0-9,.]/g, “”);
Further, the data validation is buggy set up like this:
when copying from a cell above/below, the drop-down list is disabled for some reason and cannot yet be distributed to the cell below, it is possible only through copying

We use the version of Community Edition, Google Chrome browser
windows server 2012r2

Hello @Kristofer
Could you please provide us with entire macro script which has worked on DSv.6.0, but now you face an issue.
If it’s possible, please record a video file with step-by-step scenario.

the script is not complicated, we copy the data from the program and it was necessary to convert the string into numbers, everything worked like this:
(function()
{
var oWorksheet = Api.GetActiveSheet();

var rowcount; 
for(var i = 0; i < 16500; i++) { 
    var cell = oWorksheet.GetRange("C" + (i + 2));
    var value = cell.GetValue();
    if(value === null || value === "") {
        rowcount = i;
        console.log(rowcount);
        break;
    }

}
//console.error(rowcount);
var range_date = oWorksheet.GetRange("C2:C" + (rowcount + 1));
range_date.ForEach(x => {
    var value_date = x.GetValue();
    x.SetValue(value_date);
    //console.log("ДО " + value_date);
    x.SetNumberFormat("dd/mm/yyyy"); 
});
range_date = null; 

var range_number = oWorksheet.GetRange("D2:E" + (rowcount + 1));
range_number.ForEach(x => {  
    var value_number = x.GetValue(); 
    if(value_number === null || value_number === ""){
        return; 
    }
    else{ 
        value_number = value_number.replace(/\s/g, ""); 
        value_number = value_number.replace(/,/g, "."); 
        value_number = Number(value_number); 
        x.SetValue(value_number); 
        x.SetNumberFormat("### ### ##0.00"); 
    }
});

})();
link to video: https://cloud.mail.ru/public/yVom/YXQSKtKKw

Hello @Kristofer
Sorry for the late reply. We checked your scenario and we found a bug. We added it to internal tracklist (56052). We have started working on it.
Thank you for pointing us to this situation.

One more thing. Please let us know how exactly you are copying drop-down list?

usually through cell broach, but sometimes through ctrl + c and insert ctrl + v
Thank you for your reply Alexander :slight_smile:

We rechecked the scenario with drop-down list copying and added separate bug to internal tracklist (bug number - 56222). When we get any news about these issues, I will update this post.
Thank you for valuable data.