ONLYOFFICE 7.0: online forms, password protection in sheets, collaboration improvements and much more
ONLYOFFICE 7.0 released

Problem with Onlyoffice and Mattermost

Do you want to: Report a bug
Bug: I installed onlyoffice Documentserver on a Server withe the Guide from the offical site. With chrome I can connect to the Domain and use the Demoservice. But I want to use Onlyoffice with Mattermost. I installed the Onlyoffice Addon for Mattermost from Github. I used the same link as above with Port 80 (and also tried 8000). The server shows me an editing sign for office files. When I try to edit a file, it the Site goes white and nothing is happening. The domain is running with http. Im not using JWT.

Document Server version: 7.0.0
Connector version: 1.00
OS: Ubuntu 20.04 LTS

Hello,
I would like to have onlyoffice for our schoolservers and dont get it to work. Appreciate some help.

Kind Regards
geE68

Hello @geE68
Could you please reproduce the issue and make a screenshot. Also please check Mattermost server logs entries. Is there any error? It’s located here: http://domain_name/admin_console/reporting/server_logs
Also please let us know which guide you used for Document server installation.

Hello @Alexandre,

thank you for your answer.
The page looks like this. It’s the same for the Browser and Desktop App.

I followed this Guide: Installing ONLYOFFICE Docs for Debian, Ubuntu, and derivatives - ONLYOFFICE

Blockquote
{“timestamp”:“2022-02-02 20:03:53.455 Z”,“level”:“error”,“msg”:“Access to route for non-existent plugin”,“caller”:“app/plugin_requests.go:37”,“missing_plugin_id”:“com.mattermost.apps”,“url”:"/plugins/com.mattermost.apps/api/v1/bindings?user_id=ftbapk3hoj8hbbax3z9b47waga&channel_id=ud8e4esz1jrfdg6qep6tei6mnr&team_id=&user_agent=webapp",“error”:“plugin not found: com.mattermost.apps”}
{“timestamp”:“2022-02-02 20:04:24.981 Z”,“level”:“warn”,“msg”:“Unable to parse developer flag”,“caller”:“web/handlers.go:106”,“developer_flag”:""}
{“timestamp”:“2022-02-02 20:04:32.593 Z”,“level”:“warn”,“msg”:“Unable to parse developer flag”,“caller”:“web/handlers.go:106”,“developer_flag”:""}
{“timestamp”:“2022-02-02 20:05:04.290 Z”,“level”:“warn”,“msg”:“Unable to parse developer flag”,“caller”:“web/handlers.go:106”,“developer_flag”:""}
{“timestamp”:“2022-02-02 20:05:27.327 Z”,“level”:“warn”,“msg”:“Unable to parse developer flag”,“caller”:“web/handlers.go:106”,“developer_flag”:""}
{“timestamp”:“2022-02-02 20:05:54.715 Z”,“level”:“warn”,“msg”:“Unrecognized config permissions tag value.”,“caller”:“api4/config.go:380”,“tag_value”:“sysconsole_write_*_read”}
{“timestamp”:“2022-02-02 20:05:54.812 Z”,“level”:“info”,“msg”:"[ONLYOFFICE]: The server responded without errors",“caller”:“app/plugin_api.go:921”,“plugin_id”:“com.onlyoffice.mattermost”}
{“timestamp”:“2022-02-02 20:07:02.789 Z”,“level”:“warn”,“msg”:“unable to extract file content”,“caller”:“docextractor/combine.go:35”,“error”:“error unzipping data: zip: not a valid zip file”}
{“timestamp”:“2022-02-02 20:07:46.052 Z”,“level”:“info”,“msg”:“Public links have been disabled.”,“caller”:“web/context.go:103”,“path”:"/api/v4/files/8oci7ptpi7y8mqqaezu4gtmf5a/link",“request_id”:“ngd1yjhugpfri8dqmw7krr5n1w”,“ip_addr”:“xxx.xxx.xxx.xxx,“user_id”:“ftbapk3hoj8hbbax3z9b47waga”,“method”:“GET”,“err_where”:“getPublicLink”,“http_code”:501,“err_details”:”"}
{“timestamp”:“2022-02-02 20:07:48.932 Z”,“level”:“info”,“msg”:“Public links have been disabled.”,“caller”:“web/context.go:103”,“path”:"/api/v4/files/8oci7ptpi7y8mqqaezu4gtmf5a/link",“request_id”:“76qygzt373n45mxtrbyg1ncy8c”,“ip_addr”:“xxx.xxx.xxx.xxx,“user_id”:“ftbapk3hoj8hbbax3z9b47waga”,“method”:“GET”,“err_where”:“getPublicLink”,“http_code”:501,“err_details”:”"}
{“timestamp”:“2022-02-02 20:09:11.326 Z”,“level”:“warn”,“msg”:“Unable to parse developer flag”,“caller”:“web/handlers.go:106”,“developer_flag”:""}
{“timestamp”:“2022-02-02 20:09:39.996 Z”,“level”:“info”,“msg”:“Public links have been disabled.”,“caller”:“web/context.go:103”,“path”:"/api/v4/files/8oci7ptpi7y8mqqaezu4gtmf5a/link",“request_id”:“b1xghythojypbyjqdzsafacqjh”,“ip_addr”:“xxx.xxx.xxx.xxx,“user_id”:“ftbapk3hoj8hbbax3z9b47waga”,“method”:“GET”,“err_where”:“getPublicLink”,“http_code”:501,“err_details”:”"}
{“timestamp”:“2022-02-02 20:10:06.591 Z”,“level”:“info”,“msg”:“Public links have been disabled.”,“caller”:“web/context.go:103”,“path”:"/api/v4/files/8oci7ptpi7y8mqqaezu4gtmf5a/link",“request_id”:“zm6j6cxtpbgjfciixnbqcickcr”,“ip_addr”:“xxx.xxx.xxx.xxx,“user_id”:“ftbapk3hoj8hbbax3z9b47waga”,“method”:“GET”,“err_where”:“getPublicLink”,“http_code”:501,“err_details”:”"}

Thank you for your help,
geE68

Are both sides on http? Please reproduce the issue with open browser console (F12 in Google Chrome), check Network and Console tabs. Are there any error entries?

Also please make a test. Please set AuthorizationJWT in JWT Header: in ONLYOFFICE plugins.

One more thing, please provide us with whole Document server logs folder. It’s lcated here: /var/log/onlyoffice/documentserver/

Hi @Alexandre,

thanks again for your kind help. I got it it working now!

Your hint with HTTPS / HTTP made it. I checked the Chrome logs and it showed this:
screen

So i switched the Onlyoffice server to https and it worked.

But I have a question concerning the Plugin. Is there a Button to go back to the channel? Because i didn’t find it and I have to start a new tab to go back to the channel. On the Desktop app its a bigger problem, because you have to kill the mattermost task every time.

Kind Regards
geE68

Hello @geE68
We are glad that the integration issue is solved. As for plugin question, we are checking the situation. I will notify you when I get any news.

Update: There’s ‘open file location’ button in the right top corner. Is this what you are looking for?