Cloud Computing Insider Awards 2022: Vote for ONLYOFFICE
Vote for ONLYOFFICE

Problem with integration ONLYOFFICE with Nextcloud

Do you want to: Report a bug
Document Server version: Version: 7.1.1. Build: 23
Type of installation of the Document Server docker
OS: NAME=“Ubuntu”
VERSION=“20.04.4 LTS (Focal Fossa)”

Browser version: Safari Version 15.5 (17613.2.7.1.8)

Running ONLYOFFICE with params:
docker run -i -t -d -p 8443:443 --restart=always
-v /app/onlyoffice/DocumentServer/logs:/var/log/onlyoffice
-v /app/onlyoffice/DocumentServer/data:/var/www/onlyoffice/Data
-v /app/onlyoffice/DocumentServer/lib:/var/lib/onlyoffice
-v /app/onlyoffice/DocumentServer/db:/var/lib/postgresql
-e JWT_ENABLED=‘true’
-e JWT_SECRET=‘test’
-e JWT_IN_BODY=‘true’
-e JWT_HEADER=‘AuthorizationJwt’
-e USE_UNAUTHORIZED_STORAGE=‘true’
onlyoffice/documentserver

Use self-signed certificates

Always get error like:
[2022-06-20T12:54:54.259] [ERROR] nodeJS - error downloadFile:url=https://nextcloud11z1.h.ae-rus.net/index.php/apps/onlyoffice/empty?doc=eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJhY3Rpb24iOiJlbXB0eSJ9.sfvWZHyrcPGPOQHopwhN9FbAjzKuYjbIEoB-Kj-7oTk;attempt=3;code:undefined;connect:undefined;(id=conv_check_1618279739_docx)
Error: Error response: statusCode:403; headers:{“date”:“Mon, 20 Jun 2022 12:54:53 GMT”,“server”:“Apache/2.4.41 (Ubuntu)”,“referrer-policy”:“no-referrer”,“x-content-type-options”:“nosniff”,“x-frame-options”:“SAMEORIGIN”,“x-permitted-cross-domain-policies”:“none”,“x-robots-tag”:“none”,“x-xss-protection”:“1; mode=block”,“set-cookie”:[“ocz70aiqyik2=37ti0rrt76o8nfp0817usmln2e; path=/; secure; HttpOnly; SameSite=Lax”,“oc_sessionPassphrase=pwctbt%2BcJa5yNsi%2FZw1BBw463KNeZWQmFMazRsBSrHyeM%2FoLNn3KuUdS2GGP3wrcR%2FXkb%2FZYFk97lIJs0v7f6aR8ojNVps8JKH%2Bn8eSWK6nc9y8f025bYBukkdPUmaWy; path=/; secure; HttpOnly; SameSite=Lax”,“ocz70aiqyik2=i6qc2euir9pntghrg44pgfeas6; path=/; secure; HttpOnly; SameSite=Lax”,"__Host-nc_sameSiteCookielax=true; path=/; httponly;secure; expires=Fri, 31-Dec-2100 23:59:59 GMT; SameSite=lax","__Host-nc_sameSiteCookiestrict=true; path=/; httponly;secure; expires=Fri, 31-Dec-2100 23:59:59 GMT; SameSite=strict"],“expires”:“Thu, 19 Nov 1981 08:52:00 GMT”,“cache-control”:“no-cache, no-store, must-revalidate”,“pragma”:“no-cache”,“content-security-policy”:“default-src ‘none’;base-uri ‘none’;manifest-src ‘self’;frame-ancestors ‘none’”,“x-request-id”:“FbwXxG5gu1eyq69AmRQf”,“feature-policy”:“autoplay ‘none’;camera ‘none’;fullscreen ‘none’;geolocation ‘none’;microphone ‘none’;payment ‘none’”,“content-length”:“27”,“keep-alive”:“timeout=5, max=100”,“connection”:“Keep-Alive”,“content-type”:“application/json; charset=utf-8”};
at Request.fResponse (/snapshot/server/build/server/Common/sources/utils.js)
at Request.emit (events.js:400:28)
at Request.onRequestResponse (/snapshot/server/build/server/Common/node_modules/request/request.js:1059:10)
at ClientRequest.emit (events.js:400:28)
at HTTPParser.parserOnIncomingClient (_http_client.js:647:27)
at HTTPParser.parserOnHeadersComplete (_http_common.js:126:17)
at TLSSocket.socketOnData (_http_client.js:515:22)
at TLSSocket.emit (events.js:400:28)
at addChunk (internal/streams/readable.js:290:12)
at readableAddChunk (internal/streams/readable.js:265:9)
at TLSSocket.Readable.push (internal/streams/readable.js:204:10)
at TLSWrap.onStreamRead (internal/stream_base_commons.js:188:23)

or

2022-06-20T13:01:05.846] [ERROR] nodeJS - error downloadFile:url=https://nextcloud11z1.h.ae-rus.net/index.php/apps/onlyoffice/empty?doc=eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJhY3Rpb24iOiJlbXB0eSJ9.sfvWZHyrcPGPOQHopwhN9FbAjzKuYjbIEoB-Kj-7oTk;attempt=3;code:undefined;connect:undefined;(id=conv_check_1848482984_docx)
Error: Error response: statusCode:403; headers:{“date”:“Mon, 20 Jun 2022 13:01:04 GMT”,“server”:“Apache/2.4.41 (Ubuntu)”,“referrer-policy”:“no-referrer”,“x-content-type-options”:“nosniff”,“x-frame-options”:“SAMEORIGIN”,“x-permitted-cross-domain-policies”:“none”,“x-robots-tag”:“none”,“x-xss-protection”:“1; mode=block”,“set-cookie”:[“ocz70aiqyik2=9mavrsgk9agh8fl09i88bcg7ab; path=/; secure; HttpOnly; SameSite=Lax”,“oc_sessionPassphrase=%2Bl3s3iYNg8xkRNbwVJjuBekBcnhv7CGoYCZqvDq7mdeJYjFOhFROc63pdUva9uISizKrMacF9oiEhaAI3rwB70NaWI%2BAl7OpzDfPvykzFk3aOpBwHQmzKETI%2FaEUH8FK; path=/; secure; HttpOnly; SameSite=Lax”,“ocz70aiqyik2=hs3s92peh370p09vndvo7hrbpr; path=/; secure; HttpOnly; SameSite=Lax”,"__Host-nc_sameSiteCookielax=true; path=/; httponly;secure; expires=Fri, 31-Dec-2100 23:59:59 GMT; SameSite=lax","__Host-nc_sameSiteCookiestrict=true; path=/; httponly;secure; expires=Fri, 31-Dec-2100 23:59:59 GMT; SameSite=strict"],“expires”:“Thu, 19 Nov 1981 08:52:00 GMT”,“cache-control”:“no-cache, no-store, must-revalidate”,“pragma”:“no-cache”,“content-security-policy”:“default-src ‘none’;base-uri ‘none’;manifest-src ‘self’;frame-ancestors ‘none’”,“x-request-id”:“CqWbvTZx9QnaRw4BNcgt”,“feature-policy”:“autoplay ‘none’;camera ‘none’;fullscreen ‘none’;geolocation ‘none’;microphone ‘none’;payment ‘none’”,“content-length”:“27”,“keep-alive”:“timeout=5, max=100”,“connection”:“Keep-Alive”,“content-type”:“application/json; charset=utf-8”};
at Request.fResponse (/snapshot/server/build/server/Common/sources/utils.js)
at Request.emit (events.js:400:28)
at Request.onRequestResponse (/snapshot/server/build/server/Common/node_modules/request/request.js:1059:10)
at ClientRequest.emit (events.js:400:28)
at HTTPParser.parserOnIncomingClient (_http_client.js:647:27)
at HTTPParser.parserOnHeadersComplete (_http_common.js:126:17)
at TLSSocket.socketOnData (_http_client.js:515:22)
at TLSSocket.emit (events.js:400:28)
at addChunk (internal/streams/readable.js:290:12)
at readableAddChunk (internal/streams/readable.js:265:9)
at TLSSocket.Readable.push (internal/streams/readable.js:204:10)
at TLSWrap.onStreamRead (internal/stream_base_commons.js:188:23)

From Nextcloud side get error: Error when trying to connect (Error occurred in the document service: Error while downloading the document file to be converted.) (version 7.1.1.23)

Hello @tsf0x13
What are Nextcloud and connector app versions?
Also please run a test. Run DS container deploying without -e JWT_IN_BODY=‘true’ (or just set it to false). Will the situation change?