Problem updating version 7 to 8

Do you want to: Suggest a feature / Report a bug / Ask a how-to question
For feature suggestions, describe the result you would like to achieve in detail.
For bug reports, provide the steps to reproduce and if possible a minimal demo of the problem.
Document Server version: From 7 to 8
Type of installation of the Document Server (docker, deb/rpm, exe)
OS: Windows server
Browser version: latest


I tried to update Document Server from version 7 to 8.

After updating Erlang and RabbitMQ (with the versions recommended by Onlyoffice), restarting the server, OnlyOffice no longer works.

The problem seems to come from RabbitMQ where the node is not started
Has anyone encountered this problem before?

Thank you for your answers

Hi @Jerome :wave:

Please avoid creating duplicate topics on the forum. Since this message contains more initial information, we will address the issue in this topic. I’ll close the other thread.

  1. Do you have Windows Server or Windows 10?:slight_smile:
  1. Could you please provide more details on how you performed the update for ONLYOFFICE Docs?

If you’ve installed the previous version using a different port and want to install the new version in the same way, please refer to the installation instruction for more details on how to install ONLYOFFICE Docs Community Edition to your Windows machine.

  1. Could you provide the logs located in the directory: C:\Program Files\ONLYOFFICE\DocumentServer\Log?

  2. Additionally, please provide a screenshot of the error and check the browser’s console tab for any information:

    • Open or create a new document and wait for the page to fully load.
    • Open the browser console (F12) and reload the page while keeping the console open.
    • Take screenshots of any error entries found in the Console and Network tabs.


sorry for the duplicate of this technical ticket

I did tests on both environments, Windows server 2019 and Windows 10

I started with version 7 of Onlyoffice with Erlang 19.1, Rabbitmq 3.5.4 and postgresql 14 which were working well and then I wanted to update

Regarding the update under Windows server 2019 :

  1. uninstalling Erlang then installing version 26.2.3
  2. uninstalling Rabbitmq then installing version 3.13
  3. Postgresql always in version 14
  4. uninstallation of onlyoffice (following the protocol) then installation of version 8
  5. Both work on port 8080 and Tokens are disabled

I followed the same procedure on Windows 10 but the behaviors are different

Under 2019 server :
the page only displays the Onlyoffce banner and and after a while there is a disconnection message

In the out.log file there are many lines (the same) :
[2024-03-25T13:52:52.900] [ERROR] [localhost] [docId] [userId] nodeJS - [AMQP] Error: connect ECONNREFUSED
at TCPConnectWrap.afterConnect [as oncomplete] (node:net:1187:16)

after research, it seems that this comes from Rabbitmq without us having managed to correct this malfunction
With F12, there are erros (see pictures below)

Under Windows 10 :
Download error
Both files out.log and error.log (c:.…\log\docservice) are empty
No errors inside network and console Tab into the firefox debug

And today I tried to install an Onlyoffice 8 version on a Windows 11 (new) and I got the same error as with the update under Windows 10 (download error)

thank for your help

Try performing the following steps:
(Windows Server 2019)

  1. Stopping the RabbitMQ service
  2. Delete the contents of the C:/Users/Administrator/AppData/Roaming/RabbitMQ/db/ folder
  3. Execute a (re)install of the RabbitMQ service.

And please provide RabbitMQ logs C:\Users\Administrator\AppData\Roaming\RabbitMQ\log